aboutsummaryrefslogtreecommitdiff
path: root/games/npush
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-07-06 23:07:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-07-06 23:07:43 +0000
commit74b8776533890227c95082d5036504ff533ca935 (patch)
tree46c85fcbec4e8c335e922565e497767d195c64a9 /games/npush
parent94c2cca151cbdc10156b071dbdb504a7de2288f7 (diff)
downloadports-74b8776533890227c95082d5036504ff533ca935.tar.gz
ports-74b8776533890227c95082d5036504ff533ca935.zip
Notes
Diffstat (limited to 'games/npush')
-rw-r--r--games/npush/Makefile37
-rw-r--r--games/npush/distinfo3
-rw-r--r--games/npush/pkg-descr13
-rw-r--r--games/npush/pkg-plist13
4 files changed, 66 insertions, 0 deletions
diff --git a/games/npush/Makefile b/games/npush/Makefile
new file mode 100644
index 000000000000..4c0c881abcd0
--- /dev/null
+++ b/games/npush/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: npush
+# Date created: 05 Jul 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= npush
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= SF
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= A curses-based logic game similar to Sokoban and Boulder Dash
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '/opendir/ s|"\."|"${DATADIR}"|; \
+ /"rb"/ s|name|(std::string("${DATADIR}/")+&)|' \
+ ${WRKSRC}/npush.cpp
+
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} -o npush npush.cpp -lncurses
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/npush ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Level* ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${WRKSRC}/readme.txt \
+ ${WRKSRC}/screenshot?.png ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/npush/distinfo b/games/npush/distinfo
new file mode 100644
index 000000000000..2cbdca54b415
--- /dev/null
+++ b/games/npush/distinfo
@@ -0,0 +1,3 @@
+MD5 (npush-0.6.tgz) = 6670aac74dd7db005462c11c5688db52
+SHA256 (npush-0.6.tgz) = a8f2b34e9101e6da82cb11fe5ab7edbed4257a5190faaa2f737641838059e781
+SIZE (npush-0.6.tgz) = 92318
diff --git a/games/npush/pkg-descr b/games/npush/pkg-descr
new file mode 100644
index 000000000000..fa18e1538237
--- /dev/null
+++ b/games/npush/pkg-descr
@@ -0,0 +1,13 @@
+nPush is a logic game similar to Sokoban and Boulder Dash. You need
+to collect all the gold on the level and reach the exit. To make
+it hard there are some rocks that stand in your way, and you also
+have some dynamite to blast them away. Main difference from Sokoban,
+KSokoban and similar games is that you can have multiple player-controlled
+characters you can move on the screen.
+
+nPush is written in C++. The source code is freely available under
+GPL license, version 2 or above. The code is very simple, so if
+you're interested in working on your C++ skills on a simple project,
+please feel free to join in.
+
+WWW: http://npush.sourceforge.net/
diff --git a/games/npush/pkg-plist b/games/npush/pkg-plist
new file mode 100644
index 000000000000..4f740a0324fb
--- /dev/null
+++ b/games/npush/pkg-plist
@@ -0,0 +1,13 @@
+bin/npush
+%%DATADIR%%/Level 01 - Gold and Exit
+%%DATADIR%%/Level 02 - Rocks
+%%DATADIR%%/Level 03 - Dynamite
+%%DATADIR%%/Level 04 - The Show Starts
+%%DATADIR%%/Level 05 - The Triangle
+%%DATADIR%%/Level 06 - Moving along
+%%DATADIR%%/Level 07 - Duality
+%%DATADIR%%/Level 08 - Traps and Treasure
+%%DATADIR%%/Level 09 - Cooperation
+%%DATADIR%%/Level 10 - Golden Age
+%%DATADIR%%/Level 11 - Story of a lifetime
+@dirrm %%DATADIR%%