aboutsummaryrefslogtreecommitdiff
path: root/games/nuclearchess/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-02-22 10:23:38 +0000
committerRene Ladan <rene@FreeBSD.org>2013-02-22 10:23:38 +0000
commitb1ef492919cb1eb10235b4583da72710baa97f8f (patch)
treef994b592e05f97d0f279c79595d0bd1feed40454 /games/nuclearchess/Makefile
parent6a4677c7edc5f5feb5bba6cfcbc86497165d3c9e (diff)
downloadports-b1ef492919cb1eb10235b4583da72710baa97f8f.tar.gz
ports-b1ef492919cb1eb10235b4583da72710baa97f8f.zip
Notes
Diffstat (limited to 'games/nuclearchess/Makefile')
-rw-r--r--games/nuclearchess/Makefile30
1 files changed, 14 insertions, 16 deletions
diff --git a/games/nuclearchess/Makefile b/games/nuclearchess/Makefile
index 4e0a7b898637..3e14f0a6cb86 100644
--- a/games/nuclearchess/Makefile
+++ b/games/nuclearchess/Makefile
@@ -3,44 +3,42 @@
PORTNAME= nuclearchess
PORTVERSION= 1.0.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
-MASTER_SITES= http://www.linux-games.com/nuclearchess/
+MASTER_SITES= http://www.linux-games.com/nuclearchess/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@gmx.ch
COMMENT= Chess variant designed to be short and fun for all players
LICENSE= GPLv2
-BUILD_DEPENDS= pamscale:${PORTSDIR}/graphics/netpbm
-
USE_SDL= sdl image
+USE_GNOME= desktopfileutils
+INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${DATADIR}
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= AUTHORS ChangeLog
-DESKTOP_ENTRIES="NuclearChess" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+DESKTOP_ENTRIES="NuclearChess" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" "Game;BoardGame;" false
.include <bsd.port.options.mk>
-post-build:
- @(cd ${WRKSRC}/gfx && \
- ${LOCALBASE}/bin/pngtopnm atom.png | \
- ${LOCALBASE}/bin/pamscale .22 | ${LOCALBASE}/bin/pnmtopng > nuclearchess.png)
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/gfx/nuclearchess.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
+ @-update-desktop-database
.include <bsd.port.mk>