aboutsummaryrefslogtreecommitdiff
path: root/games/numptyphysics/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/numptyphysics/Makefile
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
Notes
Diffstat (limited to 'games/numptyphysics/Makefile')
-rw-r--r--games/numptyphysics/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/games/numptyphysics/Makefile b/games/numptyphysics/Makefile
index ae9e958fba80..bc9bd06c32a0 100644
--- a/games/numptyphysics/Makefile
+++ b/games/numptyphysics/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: numptyphysics
-# Date created: 04 Jan 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= numptyphysics
DISTVERSION= 0.3.r20090104
@@ -27,12 +23,15 @@ CPPFLAGS+= -I${LOCALBASE}/include -DINSTALL_BASE_PATH=\"\\\"${DATADIR}\\\"\"
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= MOREFPS "More FPS for smoother graphics" on
+OPTIONS_DEFINE= MOREFPS
+MOREFPS_DESC= Smoother graphics support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= MOREFPS
+
+.include <bsd.port.options.mk>
post-patch:
-.if !defined(WITHOUT_MOREFPS)
+.if ${PORT_OPTIONS:MMOREFPS}
@${REINPLACE_CMD} -e '/define RENDER_RATE/ s|20|60|' \
${WRKSRC}/Config.h
.endif
@@ -45,4 +44,4 @@ post-patch:
post-install:
@${STRIP_CMD} ${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>