aboutsummaryrefslogtreecommitdiff
path: root/games/numptyphysics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-01-04 23:02:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-01-04 23:02:42 +0000
commit1e503dcd0a6cc6b2b6bb3b9322edaaf0a4ae984b (patch)
treee74b036c98093b7fbfa45b92b3b425cdcdff1307 /games/numptyphysics
parent9d17bd5ac8a10e64245ee1b5ea89bd9864f9f1b5 (diff)
downloadports-1e503dcd0a6cc6b2b6bb3b9322edaaf0a4ae984b.tar.gz
ports-1e503dcd0a6cc6b2b6bb3b9322edaaf0a4ae984b.zip
Harness gravity with your crayon and set about creating blocks,
ramps, levers, pulleys and whatever else you fancy to get the little red thing to the little yellow thing. Numpty Physics is a drawing puzzle game in the spirit (and style?) of Crayon Physics using the same excellent Box2D engine. WWW: http://numptyphysics.garage.maemo.org/
Notes
Notes: svn path=/head/; revision=225256
Diffstat (limited to 'games/numptyphysics')
-rw-r--r--games/numptyphysics/Makefile38
-rw-r--r--games/numptyphysics/distinfo6
-rw-r--r--games/numptyphysics/pkg-descr8
-rw-r--r--games/numptyphysics/pkg-plist35
4 files changed, 87 insertions, 0 deletions
diff --git a/games/numptyphysics/Makefile b/games/numptyphysics/Makefile
new file mode 100644
index 000000000000..963e7f167aff
--- /dev/null
+++ b/games/numptyphysics/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: numptyphysics
+# Date created: 04 Jan 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= numptyphysics
+DISTVERSION= 0.3.r20090104
+CATEGORIES= games
+MASTER_SITES= http://mirror.amdmi3.ru/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Drawing physics-based puzzle game
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_SDL= sdl image
+INSTALLS_ICONS= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CPPFLAGS="-I${LOCALBASE}/include -DINSTALL_BASE_PATH=\"\\\"${DATADIR}\\\"\""
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${CHMOD} a+x ${WRKSRC}/install-sh
+ @${REINPLACE_CMD} -e 's|\(desktopentrydir=\).*|\1${PREFIX}/share/applications|' \
+ ${WRKSRC}/configure ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e 's|^Exec=.*|Exec=${PORTNAME}|; /^X-Icon-Path/ d' \
+ ${WRKSRC}/data/${PORTNAME}.desktop
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/games/numptyphysics/distinfo b/games/numptyphysics/distinfo
new file mode 100644
index 000000000000..5458d06d9c72
--- /dev/null
+++ b/games/numptyphysics/distinfo
@@ -0,0 +1,6 @@
+MD5 (numptyphysics-0.3.r20090104.tar.bz2) = c72235fa8660d7af5664883a0cec6a88
+SHA256 (numptyphysics-0.3.r20090104.tar.bz2) = a8bc305436fcec730e6b31709e382e84f8af0a5a218bacc47ab064a1c3ae28d8
+SIZE (numptyphysics-0.3.r20090104.tar.bz2) = 374457
+MD5 (numptyphysics-levels-0.3.r20090104.tar.bz2) = c2cffdd45f558b07cbae7037932b9135
+SHA256 (numptyphysics-levels-0.3.r20090104.tar.bz2) = a0a3bd50d0e62cd5611c91577760b40c72e45d5c006c02d584cdfd2f3e08f37c
+SIZE (numptyphysics-levels-0.3.r20090104.tar.bz2) = 392268
diff --git a/games/numptyphysics/pkg-descr b/games/numptyphysics/pkg-descr
new file mode 100644
index 000000000000..0fa2b3584ec5
--- /dev/null
+++ b/games/numptyphysics/pkg-descr
@@ -0,0 +1,8 @@
+Harness gravity with your crayon and set about creating blocks,
+ramps, levers, pulleys and whatever else you fancy to get the little
+red thing to the little yellow thing.
+
+Numpty Physics is a drawing puzzle game in the spirit (and style?)
+of Crayon Physics using the same excellent Box2D engine.
+
+WWW: http://numptyphysics.garage.maemo.org/
diff --git a/games/numptyphysics/pkg-plist b/games/numptyphysics/pkg-plist
new file mode 100644
index 000000000000..5001a1d2c099
--- /dev/null
+++ b/games/numptyphysics/pkg-plist
@@ -0,0 +1,35 @@
+bin/numptyphysics
+share/applications/numptyphysics.desktop
+share/icons/hicolor/26x26/apps/numptyphysics.png
+share/icons/hicolor/64x64/apps/numptyphysics.png
+share/icons/hicolor/scalable/apps/numptyphysics.png
+%%DATADIR%%/L00_title.nph
+%%DATADIR%%/L01_tutorial.nph
+%%DATADIR%%/L05_plane_sailing.nph
+%%DATADIR%%/L10_the_leap.nph
+%%DATADIR%%/L15_trampoline.nph
+%%DATADIR%%/L30_see_saw.nph
+%%DATADIR%%/L35_pendulum.nph
+%%DATADIR%%/L35_pusher.nph
+%%DATADIR%%/L38_box.nph
+%%DATADIR%%/L40_tree_of_life.nph
+%%DATADIR%%/L50_nautilus.nph
+%%DATADIR%%/edit.png
+%%DATADIR%%/next.png
+%%DATADIR%%/next_win32.png
+%%DATADIR%%/numptyphysics.service
+%%DATADIR%%/paper.jpg
+%%DATADIR%%/pause.png
+%%DATADIR%%/play.png
+%%DATADIR%%/record.png
+%%DATADIR%%/theend.png
+@dirrm %%DATADIR%%
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/26x26/apps
+@dirrmtry share/icons/hicolor/26x26
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications