aboutsummaryrefslogtreecommitdiff
path: root/games/oldrunner
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-07-24 21:34:59 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-07-24 21:34:59 +0000
commit034bba9002e38c36e1a5953e84452ce166048fe3 (patch)
tree8ab2488a40b968f854a2dda9d34f6a6aa5155c15 /games/oldrunner
parent5d36bd60ed59cca1a99de088ecf598fce149d444 (diff)
downloadports-034bba9002e38c36e1a5953e84452ce166048fe3.tar.gz
ports-034bba9002e38c36e1a5953e84452ce166048fe3.zip
Notes
Diffstat (limited to 'games/oldrunner')
-rw-r--r--games/oldrunner/Makefile36
-rw-r--r--games/oldrunner/distinfo3
-rw-r--r--games/oldrunner/files/patch-cfg.h7
-rw-r--r--games/oldrunner/pkg-descr4
4 files changed, 50 insertions, 0 deletions
diff --git a/games/oldrunner/Makefile b/games/oldrunner/Makefile
new file mode 100644
index 000000000000..8a9b86eb092e
--- /dev/null
+++ b/games/oldrunner/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: oldrunner
+# Date created: 20 July 2010
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oldrunner
+PORTVERSION= 20100717
+CATEGORIES= games
+MASTER_SITES= ftp://ftp2.culot.org/culot/
+
+MAINTAINER= frederic@culot.org
+COMMENT= A textmode remake of Broderbund's LodeRunner
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+
+MAN6= oldrunner.6
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/oldrunner ${DATADIR_REL}/original.lvl
+PLIST_DIRS= ${DATADIR_REL}
+
+post-patch:
+ ${REINPLACE_CMD} -e '/LEVELS_PATH/s,/usr/local/share/oldrunner,${DATADIR},g' \
+ ${WRKSRC}/cfg.h
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/oldrunner ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/levels/original.lvl ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/oldrunner.6 ${MANPREFIX}/man/man6
+
+.include <bsd.port.mk>
diff --git a/games/oldrunner/distinfo b/games/oldrunner/distinfo
new file mode 100644
index 000000000000..c3603ffaa676
--- /dev/null
+++ b/games/oldrunner/distinfo
@@ -0,0 +1,3 @@
+MD5 (oldrunner-20100717.tar.gz) = f41ae6a41be9b86a3129ff01af47d323
+SHA256 (oldrunner-20100717.tar.gz) = bb10a0ac1d151093f6054f7279c6dd926166c0e42616608361d32f9d0802719e
+SIZE (oldrunner-20100717.tar.gz) = 41258
diff --git a/games/oldrunner/files/patch-cfg.h b/games/oldrunner/files/patch-cfg.h
new file mode 100644
index 000000000000..8e8107a1e20a
--- /dev/null
+++ b/games/oldrunner/files/patch-cfg.h
@@ -0,0 +1,7 @@
+--- cfg.h.orig 2010-07-20 12:04:52.252243199 +0200
++++ cfg.h 2010-07-20 13:51:34.642563477 +0200
+@@ -59,3 +59,4 @@
+ *
+ * #define LEVELS_PATH "/usr/local/share/games/oldrunner/levels"
+ */
++#define LEVELS_PATH "/usr/local/share/oldrunner"
diff --git a/games/oldrunner/pkg-descr b/games/oldrunner/pkg-descr
new file mode 100644
index 000000000000..b83b7c1e247b
--- /dev/null
+++ b/games/oldrunner/pkg-descr
@@ -0,0 +1,4 @@
+Oldrunner is a remake of Broderbund's Loderunner which contains the 150
+original game levels. It is written in C and has a textmode interface.
+
+WWW: http://culot.org/public/Code/oldrunner.html