aboutsummaryrefslogtreecommitdiff
path: root/games/oolite
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-02-03 13:45:49 +0000
committerRene Ladan <rene@FreeBSD.org>2020-02-03 13:45:49 +0000
commit62d06ca20d31fa1337f6ea5e1718f25bb3c60247 (patch)
tree8e0aa90453e272e4adbf902c4306b44f87360e9e /games/oolite
parent664a5424a2d29c57a3fb4063787b9d9b2899912a (diff)
downloadports-62d06ca20d31fa1337f6ea5e1718f25bb3c60247.tar.gz
ports-62d06ca20d31fa1337f6ea5e1718f25bb3c60247.zip
Notes
Diffstat (limited to 'games/oolite')
-rw-r--r--games/oolite/Makefile7
-rw-r--r--games/oolite/files/patch-deps_mozilla_js_src_configure18
-rw-r--r--games/oolite/files/patch-deps_mozilla_js_src_configure.in12
-rw-r--r--games/oolite/files/patch-fixup-python33
4 files changed, 52 insertions, 18 deletions
diff --git a/games/oolite/Makefile b/games/oolite/Makefile
index 87518ec167ec..a17f11833e13 100644
--- a/games/oolite/Makefile
+++ b/games/oolite/Makefile
@@ -12,9 +12,6 @@ DIST_SUBDIR= oolite
MAINTAINER= ports@FreeBSD.org
COMMENT= Trade and combat space simulator, clone of Elite
-DEPRECATED= Unmaintained, uses EOLed python27
-EXPIRATION_DATE= 2020-01-27
-
LICENSE= CC-BY-NC-SA-3.0 GPLv2 ZLIB
LICENSE_COMB= multi
LICENSE_FILE_CC-BY-NC-SA-3.0= ${WRKSRC}/Doc/LICENSE.TXT
@@ -27,13 +24,15 @@ LIB_DEPENDS= libespeak.so:audio/espeak \
libpng.so:graphics/png \
libminizip.so:archivers/minizip
-USES= gl gnustep openal:al perl5 python:2.7,build sdl \
+USES= gl gnustep openal:al perl5 python:3.5+,build sdl \
tar:bzip2 xorg
USE_CXXSTD= gnu++98
USE_GL= gl glu
USE_SDL= sdl
USE_XORG= x11
USE_GNUSTEP= base build
+
+MAKE_ENV= ac_cv_path_PYTHON=${PYTHON_CMD}
# Redefine DO_MAKE_BUILD, because current gnustep in USES overrides MAKEFILE
# without possibility to change it, as it was done in the previous implementation
DO_MAKE_BUILD= ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} Makefile ${_MAKE_JOBS} ${MAKE_ARGS:C,^${DESTDIRNAME}=.*,,g}
diff --git a/games/oolite/files/patch-deps_mozilla_js_src_configure b/games/oolite/files/patch-deps_mozilla_js_src_configure
index bce3004e632c..fd86929bfdfd 100644
--- a/games/oolite/files/patch-deps_mozilla_js_src_configure
+++ b/games/oolite/files/patch-deps_mozilla_js_src_configure
@@ -1,6 +1,20 @@
---- deps/mozilla/js/src/configure.orig 2014-06-30 08:54:39 UTC
+--- deps/mozilla/js/src/configure.orig 2014-05-17 17:57:43 UTC
+++ deps/mozilla/js/src/configure
-@@ -9547,7 +9547,8 @@
+@@ -6490,10 +6490,10 @@ case "$host" in
+ ;;
+ esac
+
+-echo $ac_n "checking for Python version >= $PYTHON_VERSION but not 3.x""... $ac_c" 1>&6
+-echo "configure:6495: checking for Python version >= $PYTHON_VERSION but not 3.x" >&5
++echo $ac_n "checking for Python version >= $PYTHON_VERSION""... $ac_c" 1>&6
++echo "configure:6495: checking for Python version >= $PYTHON_VERSION" >&5
+
+-$PYTHON -c "import sys; sys.exit(sys.version[:3] < sys.argv[1] or sys.version[:2] != '2.')" $PYTHON_VERSION
++$PYTHON -c "import sys; sys.exit(sys.version[:3] < sys.argv[1])" $PYTHON_VERSION
+ _python_res=$?
+
+ if test "$_python_res" != 0; then
+@@ -9547,7 +9547,8 @@ fi
echo "$ac_t""$ac_cv_have_visibility_builtin_bug" 1>&6
if test "$ac_cv_have_visibility_builtin_bug" = "no" -a \
diff --git a/games/oolite/files/patch-deps_mozilla_js_src_configure.in b/games/oolite/files/patch-deps_mozilla_js_src_configure.in
deleted file mode 100644
index a6fb4dad22cb..000000000000
--- a/games/oolite/files/patch-deps_mozilla_js_src_configure.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- deps/mozilla/js/src/configure.in.orig 2014-06-30 08:54:39 UTC
-+++ deps/mozilla/js/src/configure.in
-@@ -3378,7 +3378,8 @@
- rm -f conftest.{c,S}
- ])
- if test "$ac_cv_have_visibility_builtin_bug" = "no" -a \
-- "$ac_cv_have_visibility_class_bug" = "no"; then
-+ "$ac_cv_have_visibility_class_bug" = "no" -a \
-+ "$OS_ARCH" != "FreeBSD" ; then
- VISIBILITY_FLAGS='-I$(DIST)/system_wrappers_js -include $(topsrcdir)/config/gcc_hidden.h'
- WRAP_SYSTEM_INCLUDES=1
- STL_FLAGS='-I$(DIST)/stl_wrappers'
diff --git a/games/oolite/files/patch-fixup-python b/games/oolite/files/patch-fixup-python
new file mode 100644
index 000000000000..0023685ecf5b
--- /dev/null
+++ b/games/oolite/files/patch-fixup-python
@@ -0,0 +1,33 @@
+# Patch for Python 3.x support, created with using 2to3 program.
+
+--- deps/mozilla/js/src/build/cl.py.orig 2014-05-17 17:57:43 UTC
++++ deps/mozilla/js/src/build/cl.py
+@@ -51,7 +51,7 @@ def InvokeClWithDependencyGeneration(cmd
+ break
+
+ if target == None:
+- print >>sys.stderr, "No target set" and sys.exit(1)
++ print("No target set" and sys.exit(1), file=sys.stderr)
+
+ # The deps target lives here
+ depstarget = os.path.basename(target) + ".pp"
+@@ -90,7 +90,7 @@ def InvokeClWithDependencyGeneration(cmd
+
+ f = open(depstarget, "w")
+ for dep in sorted(deps):
+- print >>f, "%s: %s" % (target, dep)
++ print("%s: %s" % (target, dep), file=f)
+
+ if __name__ == "__main__":
+ InvokeClWithDependencyGeneration(sys.argv[1:])
+--- deps/mozilla/js/src/imacro_asm.py.orig 2014-05-17 17:57:43 UTC
++++ deps/mozilla/js/src/imacro_asm.py
+@@ -456,7 +456,7 @@ def assemble(filename, outfile):
+ if __name__ == '__main__':
+ import sys
+ if len(sys.argv) != 3:
+- print "usage: python imacro_asm.py infile.jsasm outfile.c.out"
++ print("usage: python imacro_asm.py infile.jsasm outfile.c.out")
+ sys.exit(1)
+
+ f = open(sys.argv[2], 'w')