aboutsummaryrefslogtreecommitdiff
path: root/games/openalchemist/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-16 18:59:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-16 18:59:51 +0000
commit1b00179852c28e82cb1a0559a78871fd4d6efff0 (patch)
tree328ee20f35b49f80a790e248c7e46777052d8956 /games/openalchemist/Makefile
parent1d28e396f4029b86d80bb8999563f822edb986cc (diff)
downloadports-1b00179852c28e82cb1a0559a78871fd4d6efff0.tar.gz
ports-1b00179852c28e82cb1a0559a78871fd4d6efff0.zip
Notes
Diffstat (limited to 'games/openalchemist/Makefile')
-rw-r--r--games/openalchemist/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index ee28f04e7a21..79e2d3d7b1ea 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openalchemist
-PORTVERSION= 0.2
+PORTVERSION= 0.2.2
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -18,10 +18,11 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib
USE_GNOME= pkgconfig
-MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ DATADIR="${DATADIR}"
# Allow relocation of skins (by default, must be in the skins/ sub-dir)
post-patch:
- @${REINPLACE_CMD} -E -e 's|CL_System::get_exe_path\(\) \+ "skins/|"${PREFIX}/share/games/${PORTNAME}/skins/|g' ${WRKSRC}/src/*.cpp
+ @${REINPLACE_CMD} -E -e 's|CL_System::get_exe_path\(\) \+ "skins/|"${DATADIR}/skins/|g' ${WRKSRC}/src/*.cpp
.include <bsd.port.mk>