aboutsummaryrefslogtreecommitdiff
path: root/games/openarena-data
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-11-25 15:29:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-11-25 15:29:19 +0000
commit3381d497856a32e9669768043567b6de1b24a953 (patch)
tree4bb2d447f8cb3a2961f0b1a994390df14e8bfe2e /games/openarena-data
parente20f6fdb9ffefaf24112f18a2eb97d7108893e38 (diff)
downloadports-3381d497856a32e9669768043567b6de1b24a953.tar.gz
ports-3381d497856a32e9669768043567b6de1b24a953.zip
Notes
Diffstat (limited to 'games/openarena-data')
-rw-r--r--games/openarena-data/Makefile42
-rw-r--r--games/openarena-data/distinfo6
-rw-r--r--games/openarena-data/pkg-descr3
-rw-r--r--games/openarena-data/pkg-plist10
4 files changed, 61 insertions, 0 deletions
diff --git a/games/openarena-data/Makefile b/games/openarena-data/Makefile
new file mode 100644
index 000000000000..1a80e300abdc
--- /dev/null
+++ b/games/openarena-data/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: openarena-data
+# Date created: 15 June 2010
+# Whom: Dominic Fandrey
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+PORTVERSION= 0.8.5
+CATEGORIES= games
+MASTER_SITES= http://openarena.ws/request.php?2\\\#/:data \
+ http://openarena.ws/request.php?3\\\#/:patch
+DISTFILES= ${OA_DATA}:data \
+ ${OA_PATCH}:patch
+EXTRACT_ONLY=
+
+MAINTAINER= kamikaze@bsdforen.de
+COMMENT= OpenArena game data files
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+FETCH_ARGS=
+USE_ZIP= yes
+
+OA_DATA= oa081.zip
+OA_DATA_VER= 0.8.1
+OA_PATCH= oa085p.zip
+OA_PATCH_VER= 0.8.1
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${UNZIP_CMD} -j ${DISTDIR}/${OA_DATA} \
+ ${PKGNAMEPREFIX}${OA_DATA_VER}/${OABASE}/\* \
+ -d ${DATADIR}
+ @${UNZIP_CMD} -j ${DISTDIR}/${OA_PATCH} \
+ ${PKGNAMEPREFIX}${OA_PATCH_VER}/${OABASE}/\* \
+ -d ${DATADIR}
+ @${CHMOD} -R o-w ${DATADIR}
+
+.include "../openarena/Makefile.include"
diff --git a/games/openarena-data/distinfo b/games/openarena-data/distinfo
new file mode 100644
index 000000000000..4c5aca80be87
--- /dev/null
+++ b/games/openarena-data/distinfo
@@ -0,0 +1,6 @@
+MD5 (oa081.zip) = 49006bcb02b4e8ea3d06749e8f4e4887
+SHA256 (oa081.zip) = c96282de8bc2ac5781df58c6adbce4265376e36190af50d7528f51dc739b6d7d
+SIZE (oa081.zip) = 318927645
+MD5 (oa085p.zip) = b2a0437da751cd50dd2351ed9e0c4e9d
+SHA256 (oa085p.zip) = d360c4b095bc3b34d03d9a366b21c12052c3f9e9c57e86b17c8b2c038baa4719
+SIZE (oa085p.zip) = 42528474
diff --git a/games/openarena-data/pkg-descr b/games/openarena-data/pkg-descr
new file mode 100644
index 000000000000..1f77588199b5
--- /dev/null
+++ b/games/openarena-data/pkg-descr
@@ -0,0 +1,3 @@
+This is the game data port for the ioquake3 engine based game OpenArena.
+
+WWW: http://openarena.ws/
diff --git a/games/openarena-data/pkg-plist b/games/openarena-data/pkg-plist
new file mode 100644
index 000000000000..046a011fa386
--- /dev/null
+++ b/games/openarena-data/pkg-plist
@@ -0,0 +1,10 @@
+%%DATADIR%%/pak0.pk3
+%%DATADIR%%/pak1-maps.pk3
+%%DATADIR%%/pak2-players-mature.pk3
+%%DATADIR%%/pak2-players.pk3
+%%DATADIR%%/pak4-textures.pk3
+%%DATADIR%%/pak5-TA.pk3
+%%DATADIR%%/pak6-misc.pk3
+%%DATADIR%%/pak6-patch085.pk3
+@dirrm %%DATADIR%%
+@dirrmtry %%OADIR%%