aboutsummaryrefslogtreecommitdiff
path: root/games/openarena
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-01-25 19:15:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-01-25 19:15:18 +0000
commit14ac881764759575af0262836b114bc66a99657e (patch)
treea7e7d123112721b2a5babd136cee15a4432f25e5 /games/openarena
parente935b9c75650d661139f3fc8612780c824d7ce74 (diff)
downloadports-14ac881764759575af0262836b114bc66a99657e.tar.gz
ports-14ac881764759575af0262836b114bc66a99657e.zip
Notes
Diffstat (limited to 'games/openarena')
-rw-r--r--games/openarena/Makefile4
-rw-r--r--games/openarena/files/patch-code_client_snd_openal.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index aeff19584311..35f03d5c594c 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openarena
PORTVERSION= 0.7.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://openarena.ws/rel/070/:src \
http://download.tuxfamily.net/cooker/openarena/rel070/:data \
@@ -66,7 +66,7 @@ MAKE_ENV+= HAVE_VM_COMPILED=true
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
# OpenAL
. if defined(WITH_OPENAL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if defined(WITH_OPENAL_DLOPEN)
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/openarena/files/patch-code_client_snd_openal.c b/games/openarena/files/patch-code_client_snd_openal.c
new file mode 100644
index 000000000000..4aaf9f885242
--- /dev/null
+++ b/games/openarena/files/patch-code_client_snd_openal.c
@@ -0,0 +1,11 @@
+--- code/client/snd_openal.c.orig 2009-12-26 18:20:08.000000000 +0100
++++ code/client/snd_openal.c 2009-12-26 18:20:27.000000000 +0100
+@@ -1676,7 +1676,7 @@
+ #elif defined(MACOS_X)
+ #define ALDRIVER_DEFAULT "/System/Library/Frameworks/OpenAL.framework/OpenAL"
+ #else
+-#define ALDRIVER_DEFAULT "libopenal.so.0"
++#define ALDRIVER_DEFAULT "libopenal.so"
+ #endif
+
+ /*