aboutsummaryrefslogtreecommitdiff
path: root/games/openarena
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-03-20 21:43:39 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-03-20 21:43:39 +0000
commit2a773c0614013450c8247dc7432c93006df6921b (patch)
treef2f511dc95b1069d1088409da6668089cb927a9c /games/openarena
parented75aa39aa049fb4a71ae445a29dd676313ebbd5 (diff)
downloadports-2a773c0614013450c8247dc7432c93006df6921b.tar.gz
ports-2a773c0614013450c8247dc7432c93006df6921b.zip
Notes
Diffstat (limited to 'games/openarena')
-rw-r--r--games/openarena/Makefile10
-rw-r--r--games/openarena/distinfo4
-rw-r--r--games/openarena/files/patch-code-qcommon-vm_x86.c29
-rw-r--r--games/openarena/files/patch-feature-DEFAULT_LIBDIR71
-rw-r--r--games/openarena/pkg-message4
5 files changed, 34 insertions, 84 deletions
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index 7561c8c1f86d..bc470b31a275 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= openarena
-PORTVERSION= 0.8.5
-DISTVERSION= 1.36_SVN1788+${PORTVERSION}
-PORTREVISION= 1
+PORTVERSION= ${GAMEVERSION}.s${SVNREVISION}
+DISTVERSION= 1.36_SVN${SVNREVISION}+${GAMEVERSION}
+PORTEPOCH= 1
MASTER_SITES= http://files.poulsander.com/~poul19/public_files/oa/dev081/
-DISTNAME= ${PORTNAME}-engine-source-0.8.x-18
+DISTNAME= ${PORTNAME}-engine-source-0.8.x-20
MAINTAINER= kamikaze@bsdforen.de
COMMENT= Quake3 total conversion based on the ioquake3 engine
@@ -22,6 +22,8 @@ USE_ZIP= no
# OpenArena doc is too messy to bother
NOPORTDOCS= yes
+GAMEVERSION= 0.8.5
+SVNREVISION= 1910
Q3TOTALCONV= yes
Q3CLIENT= openarena
Q3SERVER= oa_ded
diff --git a/games/openarena/distinfo b/games/openarena/distinfo
index 5c3865fcb163..c33f278cf2c7 100644
--- a/games/openarena/distinfo
+++ b/games/openarena/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openarena-engine-source-0.8.x-18.tar.bz2) = 77180d70af00134b3cfbc51a3c1371f99665e2f073b2ec5fdbf08f6c93ae1c24
-SIZE (openarena-engine-source-0.8.x-18.tar.bz2) = 7211834
+SHA256 (openarena-engine-source-0.8.x-20.tar.bz2) = 0017ef8d15c2b5f028b0118765059420e0dec7b4100e483b659295efff75afa6
+SIZE (openarena-engine-source-0.8.x-20.tar.bz2) = 7413615
diff --git a/games/openarena/files/patch-code-qcommon-vm_x86.c b/games/openarena/files/patch-code-qcommon-vm_x86.c
deleted file mode 100644
index a24661785255..000000000000
--- a/games/openarena/files/patch-code-qcommon-vm_x86.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- code/qcommon/vm_x86.c.orig 2008-08-18 01:22:06.000000000 +0200
-+++ code/qcommon/vm_x86.c 2010-11-27 14:01:33.000000000 +0100
-@@ -36,7 +36,25 @@
-
- /* need this on NX enabled systems (i386 with PAE kernel or
- * noexec32=on x86_64) */
--#ifdef __linux__
-+// Rambetter's note: I'm adding the test for __FreeBSD__ in addition to the [already
-+// existing] test for __linux__. Here is why. I own a 32 bit FreeBSD 8.0 server with
-+// a PAE kernel. Without VM_X86_MMAP, ioq3ded segfaults shortly after starting
-+// (this should come as no surprise). With VM_X86_MMAP, ioq3ded runs very smoothly.
-+// So, at a very minimum, we need to set VM_X86_MMAP for FreeBSD PAE kernels.
-+// Now, I also happen to own a 32 bit FreeBSD 7.1 server with just the standard kernel
-+// (non-PAE). I have run ioq3ded successfully on it with and without VM_X86_MMAP for many
-+// months. So, in the case of non-PAE FreeBSD, we can go either way - use VM_X86_MMAP or
-+// not use it. The absolute safest fix to this problem is to only set VM_X86_MMAP on
-+// PAE FreeBSD kernels (in addition to Linux); however, I don't know of a way to detect
-+// the PAE kernel easily. Therefore, since using VM_X86_MMAP won't break anything on
-+// non-PAE kernels [apparently], we'll just use it all the time on FreeBSD 32 bit.
-+// Now, you may ask the question: Why not change the entire test for just __unix__?
-+// Unfortunately I cannot say anything about this because I don't have access to every
-+// other system that has __unix__ defined, so I cannot possibly test all those cases to
-+// make sure things work. We'll just leave it with __linux__ and __FreeBSD__ to be safe.
-+// If someone with a different flavor of UNIX running a PAE kernel has this problem too,
-+// they can report the bug and we will adjust the line below accordingly.
-+#if defined(__linux__) || defined(__FreeBSD__)
- #define VM_X86_MMAP
- #endif
-
diff --git a/games/openarena/files/patch-feature-DEFAULT_LIBDIR b/games/openarena/files/patch-feature-DEFAULT_LIBDIR
index e7f0416b9b7c..0e977835024f 100644
--- a/games/openarena/files/patch-feature-DEFAULT_LIBDIR
+++ b/games/openarena/files/patch-feature-DEFAULT_LIBDIR
@@ -1,6 +1,6 @@
---- code/qcommon/files.c.orig 2009-11-09 23:41:42.205886000 +0100
-+++ code/qcommon/files.c 2010-02-16 15:26:18.000000000 +0100
-@@ -242,6 +242,7 @@
+--- code/qcommon/files.c.orig 2011-03-10 02:01:27.599036000 +0100
++++ code/qcommon/files.c 2011-03-19 22:40:42.000000000 +0100
+@@ -250,6 +250,7 @@
#endif
static cvar_t *fs_basepath;
@@ -8,18 +8,29 @@
static cvar_t *fs_basegame;
static cvar_t *fs_gamedirvar;
static searchpath_t *fs_searchpaths;
-@@ -2807,6 +2808,8 @@
+@@ -2956,6 +2957,7 @@
fs_debug = Cvar_Get( "fs_debug", "0", 0 );
- fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT );
+ fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT|CVAR_PROTECTED );
fs_basegame = Cvar_Get ("fs_basegame", "", CVAR_INIT );
+ fs_libpath = Cvar_Get ("fs_libpath", Sys_DefaultLibPath(), CVAR_INIT );
-+
homePath = Sys_DefaultHomePath();
if (!homePath || !homePath[0]) {
homePath = fs_basepath->string;
---- code/qcommon/qcommon.h.orig 2010-02-15 17:20:33.680787000 +0100
-+++ code/qcommon/qcommon.h 2010-02-16 15:26:18.000000000 +0100
-@@ -1085,6 +1085,9 @@
+@@ -2975,6 +2977,11 @@
+ if (fs_apppath->string[0])
+ FS_AddGameDirectory(fs_apppath->string, gameName);
+ #endif
++
++ // Search default library location if given
++ if (fs_libpath->string[0]) {
++ FS_AddGameDirectory ( fs_libpath->string, gameName );
++ }
+
+ // NOTE: same filtering below for mods and basegame
+ if (fs_homepath->string[0] && Q_stricmp(fs_homepath->string,fs_basepath->string)) {
+--- code/qcommon/qcommon.h.orig 2011-03-10 02:01:27.599036000 +0100
++++ code/qcommon/qcommon.h 2011-03-19 22:40:42.000000000 +0100
+@@ -1104,6 +1104,9 @@
char *Sys_DefaultAppPath(void);
#endif
@@ -29,8 +40,8 @@
void Sys_SetDefaultHomePath(const char *path);
char *Sys_DefaultHomePath(void);
const char *Sys_TempPath(void);
---- code/sys/sys_main.c.orig 2010-02-15 17:20:33.680787000 +0100
-+++ code/sys/sys_main.c 2010-02-16 15:26:18.000000000 +0100
+--- code/sys/sys_main.c.orig 2011-02-23 17:17:09.009063000 +0100
++++ code/sys/sys_main.c 2011-03-19 22:40:42.000000000 +0100
@@ -49,6 +49,7 @@
static char binaryPath[ MAX_OSPATH ] = { 0 };
@@ -69,41 +80,7 @@
Sys_DefaultAppPath
=================
*/
-@@ -435,6 +459,7 @@
- Used to load a development dll instead of a virtual machine
- #1 look in fs_homepath
- #2 look in fs_basepath
-+#3 look in fs_libpath
- =================
- */
- void *Sys_LoadDll( const char *name, char *fqpath ,
-@@ -445,6 +470,7 @@
- void (*dllEntry)( intptr_t (*syscallptr)(intptr_t, ...) );
- char fname[MAX_OSPATH];
- char *basepath;
-+ char *libpath;
- char *homepath;
- char *gamedir;
-
-@@ -454,6 +480,7 @@
-
- // TODO: use fs_searchpaths from files.c
- basepath = Cvar_VariableString( "fs_basepath" );
-+ libpath = Cvar_VariableString( "fs_libpath" );
- homepath = Cvar_VariableString( "fs_homepath" );
- gamedir = Cvar_VariableString( "fs_game" );
-
-@@ -462,6 +489,9 @@
- if(!libHandle && basepath)
- libHandle = Sys_TryLibraryLoad(basepath, gamedir, fname, fqpath);
-
-+ if(!libHandle && libpath)
-+ libHandle = Sys_TryLibraryLoad(libpath, gamedir, fname, fqpath);
-+
- if(!libHandle) {
- Com_Printf ( "Sys_LoadDll(%s) failed to load library\n", name );
- return NULL;
-@@ -515,6 +545,14 @@
+@@ -490,6 +514,14 @@
# endif
#endif
@@ -118,7 +95,7 @@
/*
=================
Sys_SigHandler
-@@ -589,6 +627,7 @@
+@@ -564,6 +596,7 @@
Sys_ParseArgs( argc, argv );
Sys_SetBinaryPath( Sys_Dirname( argv[ 0 ] ) );
Sys_SetDefaultInstallPath( DEFAULT_BASEDIR );
diff --git a/games/openarena/pkg-message b/games/openarena/pkg-message
index ced414088790..e81d1bb04c68 100644
--- a/games/openarena/pkg-message
+++ b/games/openarena/pkg-message
@@ -1,6 +1,6 @@
==============================================================================
-Should the game freeze when entering a match, try to change the value of
-com_zoneMegs (e.g. to 48).
+Should the game have trouble meeting com_maxfps, which would result in less
+effective strafe jumping, set com_busywait 1 to restore the old behaviour.
==============================================================================