aboutsummaryrefslogtreecommitdiff
path: root/games/openastromenace
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-03 18:40:21 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-03 18:40:21 +0000
commit0aa2142cbbfb8d59bbbe0a6caa27138055fe6750 (patch)
tree899de8c8c35cfae4294cd83b947e0763388d74d7 /games/openastromenace
parent60bba17b8015d98fc38d566d69864a6597f005be (diff)
Notes
Diffstat (limited to 'games/openastromenace')
-rw-r--r--games/openastromenace/Makefile5
-rw-r--r--games/openastromenace/files/patch-AstroMenaceSource-Core-Base.h17
-rw-r--r--games/openastromenace/files/patch-AstroMenaceSource-Core-VirtualFileSystem-VFS.h10
3 files changed, 32 insertions, 0 deletions
diff --git a/games/openastromenace/Makefile b/games/openastromenace/Makefile
index f7fbde1cfff4..beb62d7653d7 100644
--- a/games/openastromenace/Makefile
+++ b/games/openastromenace/Makefile
@@ -27,6 +27,7 @@ WANT_SDL= yes
USE_SDL= sdl
USE_CMAKE= yes
WRKSRC= ${WRKDIR}/OpenAstroMenaceSVN
+USE_DOS2UNIX= yes
OPTIONS= EN "English language pack" on \
DE "German language pack" off \
@@ -44,6 +45,10 @@ LANGPACK= ru
IGNORE= cannot be build without/with multiple language packs. Please rerun 'make config' and select single language pack
.endif
+.if !defined(WITHOUT_NOUVEAU)
+CFLAGS+= -DOLD_MESA
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/usr/local/share/openastromenace|${DATADIR}|' \
${WRKSRC}/AstroMenaceSource/Main.cpp
diff --git a/games/openastromenace/files/patch-AstroMenaceSource-Core-Base.h b/games/openastromenace/files/patch-AstroMenaceSource-Core-Base.h
new file mode 100644
index 000000000000..0e0c60249027
--- /dev/null
+++ b/games/openastromenace/files/patch-AstroMenaceSource-Core-Base.h
@@ -0,0 +1,17 @@
+--- AstroMenaceSource/Core/Base.h~
++++ AstroMenaceSource/Core/Base.h
+@@ -46,10 +46,14 @@
+ #include <OpenGL/gl.h> // Header File For The OpenGL32 Library
+ #include <OpenGL/glu.h> // Header File For The GLu32 Library
+ #else
++ #ifdef OLD_MESA
+ #define __glext_h_ // Don't let gl.h include glext.h
++ #endif
+ #include <GL/gl.h> // Header File For The OpenGL32 Library
+ #include <GL/glu.h> // Header File For The GLu32 Library
++ #ifdef OLD_MESA
+ #undef __glext_h_
++ #endif
+ #endif
+
+ #include <stdlib.h> // rand, ...
diff --git a/games/openastromenace/files/patch-AstroMenaceSource-Core-VirtualFileSystem-VFS.h b/games/openastromenace/files/patch-AstroMenaceSource-Core-VirtualFileSystem-VFS.h
new file mode 100644
index 000000000000..9c3af7078a64
--- /dev/null
+++ b/games/openastromenace/files/patch-AstroMenaceSource-Core-VirtualFileSystem-VFS.h
@@ -0,0 +1,10 @@
+--- AstroMenaceSource/Core/VirtualFileSystem/VFS.h~
++++ AstroMenaceSource/Core/VirtualFileSystem/VFS.h
+@@ -34,6 +34,7 @@
+ #define VFS_H
+
+
++#include <cstdio>
+ #include "../Base.h"
+
+