aboutsummaryrefslogtreecommitdiff
path: root/games/openastromenace
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-09 07:25:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-09 07:25:19 +0000
commita5347b2176cfe9f5cefdb90d24eceec2c3a57654 (patch)
tree72976c0aba80d660d3e4829938d2c732a299a82b /games/openastromenace
parent85cbee74af4ce16b6926cbf2a5a0c3f4b6c4df59 (diff)
downloadports-a5347b2176cfe9f5cefdb90d24eceec2c3a57654.tar.gz
ports-a5347b2176cfe9f5cefdb90d24eceec2c3a57654.zip
Notes
Diffstat (limited to 'games/openastromenace')
-rw-r--r--games/openastromenace/Makefile95
-rw-r--r--games/openastromenace/distinfo15
-rw-r--r--games/openastromenace/files/pkg-message.in8
-rw-r--r--games/openastromenace/pkg-descr18
-rw-r--r--games/openastromenace/pkg-plist32
5 files changed, 168 insertions, 0 deletions
diff --git a/games/openastromenace/Makefile b/games/openastromenace/Makefile
new file mode 100644
index 000000000000..7f28b04d4a76
--- /dev/null
+++ b/games/openastromenace/Makefile
@@ -0,0 +1,95 @@
+# New ports collection makefile for: openastromenace
+# Date created: 23 Sep 2007
+# Whom: Oleg Alexeenkov
+#
+# $FreeBSD$
+#
+
+PORTNAME= openastromenace
+PORTVERSION= 1.2.0
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= proler@gmail.com
+COMMENT= Hardcore 3D space shooter with spaceship upgrade possibilities
+
+USE_BZIP2= yes
+USE_GL= yes
+WANT_SDL= yes
+USE_SDL= sdl
+
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+SUB_FILES= pkg-message
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/cmake:${PORTSDIR}/devel/cmake \
+
+LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ openal:${PORTSDIR}/audio/openal \
+ alut:${PORTSDIR}/audio/freealut \
+
+OPTIONS= SRC "build src" on \
+ DATA "install data file" on \
+ EN " en lang" on \
+ DE " de lang " on \
+ RU " ru lang " on \
+
+.include <bsd.port.pre.mk>
+
+.undef DISTFILES
+.if defined(WITH_SRC)
+DISTFILES+=oamenace-src-${PORTVERSION}.tar.bz2
+.else
+NO_BUILD= yes
+.endif
+.if defined(WITH_DATA)
+DISTFILES+=oamenace-data-${PORTVERSION}.tar.bz2
+.endif
+.if defined(WITH_EN)
+DISTFILES+=oamenace-lang-en-${PORTVERSION}.tar.bz2
+.endif
+.if defined(WITH_DE)
+DISTFILES+=oamenace-lang-de-${PORTVERSION}.tar.bz2
+.endif
+.if defined(WITH_RU)
+DISTFILES+=oamenace-lang-ru-${PORTVERSION}.tar.bz2
+.endif
+
+do-configure:
+.if defined(WITH_SRC)
+ @(cd ${WRKSRC}; \
+ ${LOCALBASE}/bin/cmake ${CMAKE_ARGS} ${PATCH_WRKSRC})
+.endif
+
+do-install:
+.if defined(WITH_SRC)
+ ${INSTALL_PROGRAM} ${WRKSRC}/AstroMenace ${PREFIX}/bin
+.endif
+ ${MKDIR} ${DATADIR}
+.if defined(WITH_DATA)
+ ${INSTALL_DATA} ${WRKDIR}/gamedata.vfs ${DATADIR}/
+ ${MKDIR} ${DATADIR}/DATA/SCRIPT
+ ${INSTALL_DATA} ${WRKDIR}/DATA/SCRIPT/* ${DATADIR}/DATA/SCRIPT
+.endif
+.if defined(WITH_EN)
+ ${INSTALL_DATA} ${WRKDIR}/gamelang_en.vfs ${DATADIR}/
+ ${LN} -sf ${DATADIR}/gamelang_en.vfs ${DATADIR}/gamelang.vfs
+.endif
+.if defined(WITH_DE)
+ ${INSTALL_DATA} ${WRKDIR}/gamelang_de.vfs ${DATADIR}/
+ ${LN} -sf ${DATADIR}/gamelang_de.vfs ${DATADIR}/gamelang.vfs
+.endif
+.if defined(WITH_RU)
+ ${INSTALL_DATA} ${WRKDIR}/gamelang_ru.vfs ${DATADIR}/
+ ${LN} -sf ${DATADIR}/gamelang_ru.vfs ${DATADIR}/gamelang.vfs
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/openastromenace/distinfo b/games/openastromenace/distinfo
new file mode 100644
index 000000000000..f299f41b43b9
--- /dev/null
+++ b/games/openastromenace/distinfo
@@ -0,0 +1,15 @@
+MD5 (oamenace-src-1.2.0.tar.bz2) = 16d9b4abee736fa91540802a5b600cb4
+SHA256 (oamenace-src-1.2.0.tar.bz2) = 392ea356c15f3b14c2221aebe6fd8bc12f4451ad9174ea9c728f25b24e36bd8d
+SIZE (oamenace-src-1.2.0.tar.bz2) = 562125
+MD5 (oamenace-data-1.2.0.tar.bz2) = a8ad3495f8eac419ebcf93473008484d
+SHA256 (oamenace-data-1.2.0.tar.bz2) = e55fd843b7e6331e3724dd33d160565ae3f154abc790fb95e3566f5fedcb1d3f
+SIZE (oamenace-data-1.2.0.tar.bz2) = 33384465
+MD5 (oamenace-lang-en-1.2.0.tar.bz2) = f137da529da1345a0243f22fb8bf4913
+SHA256 (oamenace-lang-en-1.2.0.tar.bz2) = 7890431ca80a7456dc77b102c58f9dd9a3f6fc41574ffc4234f805e7dae79d88
+SIZE (oamenace-lang-en-1.2.0.tar.bz2) = 1382975
+MD5 (oamenace-lang-de-1.2.0.tar.bz2) = 7bb9109b93c791e36d3356343d98b7ea
+SHA256 (oamenace-lang-de-1.2.0.tar.bz2) = 3c7f4b580c1491c1fe6db521477e644f5139323e3e427bf99effe2da0bd3b7bd
+SIZE (oamenace-lang-de-1.2.0.tar.bz2) = 1656853
+MD5 (oamenace-lang-ru-1.2.0.tar.bz2) = 3be24166852c7de74158e8298d142148
+SHA256 (oamenace-lang-ru-1.2.0.tar.bz2) = bf4231baae0b3e1f3327da249ab9bb50c226c71bf0fd12b98a05820b5646cb5d
+SIZE (oamenace-lang-ru-1.2.0.tar.bz2) = 2344872
diff --git a/games/openastromenace/files/pkg-message.in b/games/openastromenace/files/pkg-message.in
new file mode 100644
index 000000000000..2250d7ca0cee
--- /dev/null
+++ b/games/openastromenace/files/pkg-message.in
@@ -0,0 +1,8 @@
+=======================================================================
+OpenAstroMenace is now installed.
+
+You can run game:
+
+AstroMenace --dir=/usr/local/share/openastromenace
+
+=======================================================================
diff --git a/games/openastromenace/pkg-descr b/games/openastromenace/pkg-descr
new file mode 100644
index 000000000000..75e2f12cdc97
--- /dev/null
+++ b/games/openastromenace/pkg-descr
@@ -0,0 +1,18 @@
+AstroMenace is a brilliant 3d scroll-shooter allowing you to feel the adrenalin
+rush of a fierce space battle against relentless swarms of alien invaders.
+Immerse into a decisive battle against tons of cunning foes, face the
+terrifying bosses and protect your homeland throughout 15 diverse levels of
+the game. The hardcore gameplay of AstroMenace, packed with pure non-stop
+action, will become a full scale test for your basic instinct of survival.
+
+AstroMenace shines with stunning special effects which in combination with
+superb 3d graphics guarantee that the game will feast the eyes of even most
+experienced arcade players. The quality of visuals ensures that the
+demonstration of your superior power and new weaponry will look really
+impressive and awesome, so the destruction of foes is a truly amazing sight.
+
+The game provides a wide variety of armaments and weapon upgrades for
+discharging the retributive wrath upon the hordes of enemies, besides it has
+a great number of improvements for enhancing the defensive abilities of your
+spaceship. Collect money during the combat and invest them into turning your
+spaceship into an ultimate weapon of mass destruction.
diff --git a/games/openastromenace/pkg-plist b/games/openastromenace/pkg-plist
new file mode 100644
index 000000000000..5eb89039b384
--- /dev/null
+++ b/games/openastromenace/pkg-plist
@@ -0,0 +1,32 @@
+bin/AstroMenace
+%%DATADIR%%/DATA/SCRIPT/PoizAI.xml
+%%DATADIR%%/DATA/SCRIPT/aimode.xml
+%%DATADIR%%/DATA/SCRIPT/list.xml
+%%DATADIR%%/DATA/SCRIPT/mis7ex_ai.xml
+%%DATADIR%%/DATA/SCRIPT/mission1.xml
+%%DATADIR%%/DATA/SCRIPT/mission10.xml
+%%DATADIR%%/DATA/SCRIPT/mission11.xml
+%%DATADIR%%/DATA/SCRIPT/mission12.xml
+%%DATADIR%%/DATA/SCRIPT/mission13.xml
+%%DATADIR%%/DATA/SCRIPT/mission14.xml
+%%DATADIR%%/DATA/SCRIPT/mission15.xml
+%%DATADIR%%/DATA/SCRIPT/mission1_5_done.xml
+%%DATADIR%%/DATA/SCRIPT/mission1_7_done.xml
+%%DATADIR%%/DATA/SCRIPT/mission2.xml
+%%DATADIR%%/DATA/SCRIPT/mission3.xml
+%%DATADIR%%/DATA/SCRIPT/mission4.xml
+%%DATADIR%%/DATA/SCRIPT/mission5.xml
+%%DATADIR%%/DATA/SCRIPT/mission6.xml
+%%DATADIR%%/DATA/SCRIPT/mission7.xml
+%%DATADIR%%/DATA/SCRIPT/mission8.xml
+%%DATADIR%%/DATA/SCRIPT/mission9.xml
+%%DATADIR%%/DATA/SCRIPT/mission_1_(realstudent).xml
+%%DATADIR%%/DATA/SCRIPT/my_aimode_7.xml
+%%DATADIR%%/gamedata.vfs
+%%DATADIR%%/gamelang.vfs
+%%DATADIR%%/gamelang_de.vfs
+%%DATADIR%%/gamelang_en.vfs
+%%DATADIR%%/gamelang_ru.vfs
+@dirrm %%DATADIR%%/DATA/SCRIPT
+@dirrm %%DATADIR%%/DATA
+@dirrm %%DATADIR%%