aboutsummaryrefslogtreecommitdiff
path: root/games/openbor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-26 21:33:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-26 21:33:04 +0000
commitb2addc750d4fcbbf2364ad44b218605611420951 (patch)
treeb4e995461a6b39e3783c9cf2b814e2f6a9f3a9e9 /games/openbor
parenta558f1af5ca6a92e94b61fe1d68afe3913f03aa9 (diff)
downloadports-b2addc750d4fcbbf2364ad44b218605611420951.tar.gz
ports-b2addc750d4fcbbf2364ad44b218605611420951.zip
Notes
Diffstat (limited to 'games/openbor')
-rw-r--r--games/openbor/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index ce4c7a08be8c..26b258366ab7 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -23,7 +23,7 @@ MAKE_ENV= BUILD_LINUX=1 SDKPATH="${LOCALBASE}" \
GCC_TARGET="${CONFIGURE_TARGET:S/amd64/x86_64/}"
MAKE_ARGS= CC="${CC}" LIBRARIES="${LOCALBASE}/lib" \
TARGET_ARCH=${ARCH:S/i386/x86/} ARCHFLAGS="" \
- TARGET_FINAL='$(TARGET)'
+ TARGET_FINAL='$(TARGET)' BUILD_MMX=""
LDFLAGS+= -Wl,--as-needed
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
@@ -36,13 +36,11 @@ DESKTOP_ENTRIES="OpenBOR" \
"Game;ArcadeGame;" \
""
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE_i386= MMX
+OPTIONS_DEFAULT_i386= MMX # runtime detection
-.if ${ARCH} == i386
-BUILD_DEPENDS+= yasm:${PORTSDIR}/devel/yasm
-.else
-MAKE_ARGS+= BUILD_MMX=""
-.endif
+MMX_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
+MMX_MAKE_ARGS= BUILD_MMX=1
#
# To update snapshot: make makesum BOOTSTRAP=