aboutsummaryrefslogtreecommitdiff
path: root/games/openbor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-08-26 21:33:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-08-26 21:33:19 +0000
commit455e98e2f3154aeb4ce84e28e1e04904deefbcd8 (patch)
tree0710a3f53bc5ce6ff5f35adcf10b0f138eac582d /games/openbor
parentb2addc750d4fcbbf2364ad44b218605611420951 (diff)
downloadports-455e98e2f3154aeb4ce84e28e1e04904deefbcd8.tar.gz
ports-455e98e2f3154aeb4ce84e28e1e04904deefbcd8.zip
Notes
Diffstat (limited to 'games/openbor')
-rw-r--r--games/openbor/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 26b258366ab7..34fadccf0d07 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
PORTVERSION= 3.0.r4163
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= LOCAL/jbeich \
https://svn.code.sf.net/p/${PORTNAME}/engine/engine/:svn
@@ -12,8 +12,7 @@ COMMENT= Moddable fighting game engine (aka Beats of Rage)
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libvpx.so:${PORTSDIR}/multimedia/libvpx
USES= dos2unix gmake pkgconfig tar:xz
@@ -36,12 +35,18 @@ DESKTOP_ENTRIES="OpenBOR" \
"Game;ArcadeGame;" \
""
+OPTIONS_DEFINE= TREMOR
+OPTIONS_DEFAULT= ${MACHINE_CPU:tu:MSOFTFP:S/SOFTFP/TREMOR/}
OPTIONS_DEFINE_i386= MMX
OPTIONS_DEFAULT_i386= MMX # runtime detection
MMX_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
MMX_MAKE_ARGS= BUILD_MMX=1
+TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_MAKE_ARGS= BUILD_TREMOR=1 BUILD_VORBIS=""
+TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+
#
# To update snapshot: make makesum BOOTSTRAP=
# Specific snapshot: make makesum SVN_FETCH= PORTVERSION=1.0.r1234