aboutsummaryrefslogtreecommitdiff
path: root/games/openbor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-12-06 22:54:15 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-12-06 22:54:15 +0000
commitca42533c8b92ab3b4693258d7ca4298d8eeaeb96 (patch)
tree6ab90eff1c9537f147aaa9cc45e6ee92b0c2eeed /games/openbor
parent5eee56ce729eeb3a6f1ee04cff078e16e2d6c473 (diff)
downloadports-ca42533c8b92ab3b4693258d7ca4298d8eeaeb96.tar.gz
ports-ca42533c8b92ab3b4693258d7ca4298d8eeaeb96.zip
Notes
Diffstat (limited to 'games/openbor')
-rw-r--r--games/openbor/Makefile2
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-source_webmlib_halloc39
3 files changed, 4 insertions, 43 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 0cf47ee51d11..a034af20b38d 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= openbor
-PORTVERSION= 3.0.r4235
+PORTVERSION= 3.0.r4390
CATEGORIES= games
MASTER_SITES= LOCAL/jbeich \
https://svn.code.sf.net/p/${PORTNAME}/engine/engine/:svn
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index 06bfcd901c93..c0e536ec29cd 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477548721
-SHA256 (openbor-3.0.r4235.tar.xz) = 4874e12da206caebdc0e7a5cd16dd047ed03769885b5a774fb430ab2e308b91b
-SIZE (openbor-3.0.r4235.tar.xz) = 3926436
+TIMESTAMP = 1480986407
+SHA256 (openbor-3.0.r4390.tar.xz) = d4d42a93db1ccde0c57a5459d42aac7e239ae4e3c4a13fe0eb0aa0174d1ed26d
+SIZE (openbor-3.0.r4390.tar.xz) = 3946520
diff --git a/games/openbor/files/patch-source_webmlib_halloc b/games/openbor/files/patch-source_webmlib_halloc
deleted file mode 100644
index 41b2971ddef8..000000000000
--- a/games/openbor/files/patch-source_webmlib_halloc
+++ /dev/null
@@ -1,39 +0,0 @@
-C11 defines different max_align_t in stddef.h. It may either come from
-compiler (GCC, Clang) or provided by the system (DragonFly, musl libc).
-FreeBSD's Clang has neither due to bug 193594.
-
-So, keep the old behavior by renaming the type here to avoid building
-with -ansi (upstream nestegg) or -std=gnu89 (SUSE).
-
- In file included from source/webmlib/halloc/halloc.c:19:0:
- source/webmlib/halloc/align.h:42:25: error: conflicting types for 'max_align_t'
- typedef union max_align max_align_t;
- ^
- In file included from source/webmlib/halloc/halloc.h:18:0,
- from source/webmlib/halloc/halloc.c:18:
- /usr/local/lib/gcc5/**/include/stddef.h:429:3: note: previous declaration of 'max_align_t' was here
- } max_align_t;
- ^
-
---- source/webmlib/halloc/align.h.orig 2015-04-09 22:13:36 UTC
-+++ source/webmlib/halloc/align.h
-@@ -39,7 +39,7 @@ union max_align
- void (*q)(void);
- };
-
--typedef union max_align max_align_t;
-+typedef union max_align halloc_max_align_t;
-
- #endif
-
---- source/webmlib/halloc/halloc.c.orig 2015-04-09 22:13:36 UTC
-+++ source/webmlib/halloc/halloc.c
-@@ -30,7 +30,7 @@ typedef struct hblock
- #endif
- hlist_item_t siblings; /* 2 pointers */
- hlist_head_t children; /* 1 pointer */
-- max_align_t data[1]; /* not allocated, see below */
-+ halloc_max_align_t data[1]; /* not allocated, see below */
-
- } hblock_t;
-