aboutsummaryrefslogtreecommitdiff
path: root/games/opencity
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-29 21:11:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-29 21:11:11 +0000
commitdcee56338965ee2fd275a7b98dea301b3186d0b8 (patch)
treeb61803246ff351daf37a8cee6aa24e4c916bd62f /games/opencity
parent812e89cab4d4d4f7d058bf3c5d1b01f72412e61c (diff)
downloadports-dcee56338965ee2fd275a7b98dea301b3186d0b8.tar.gz
ports-dcee56338965ee2fd275a7b98dea301b3186d0b8.zip
Notes
Diffstat (limited to 'games/opencity')
-rw-r--r--games/opencity/Makefile3
-rw-r--r--games/opencity/files/patch-src__tinyxpath__node_set.cpp12
2 files changed, 13 insertions, 2 deletions
diff --git a/games/opencity/Makefile b/games/opencity/Makefile
index afb125e78982..bd16216354c5 100644
--- a/games/opencity/Makefile
+++ b/games/opencity/Makefile
@@ -11,9 +11,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}stable
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free 3D city simulator
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= tar:bzip2 gmake pkgconfig
USE_SDL= sdl mixer image net
USE_GL= gl glu
USE_GCC= any
diff --git a/games/opencity/files/patch-src__tinyxpath__node_set.cpp b/games/opencity/files/patch-src__tinyxpath__node_set.cpp
new file mode 100644
index 000000000000..4cdbcde1a5ec
--- /dev/null
+++ b/games/opencity/files/patch-src__tinyxpath__node_set.cpp
@@ -0,0 +1,12 @@
+--- src/tinyxpath/node_set.cpp.orig 2011-07-03 20:36:33.000000000 +0400
++++ src/tinyxpath/node_set.cpp 2014-03-28 20:44:24.828732644 +0400
+@@ -23,9 +23,7 @@
+ */
+
+ #include "node_set.h"
+-#ifdef HAVE_STDINT_H
+ #include "stdint.h" // for intptr_t (32/64 bits void* pointer compatibility)
+-#endif
+
+ namespace TinyXPath
+ {