aboutsummaryrefslogtreecommitdiff
path: root/games/openclaw
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-22 20:04:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-22 20:04:01 +0000
commit29b3d06ab68e56f77bd8c6612cdcb8b9538e2c8d (patch)
treee2a2bbe88749bd0c19427f3c79e2705d8899ff33 /games/openclaw
parentb28382f9144e8d60279d81884535c782f8d60b56 (diff)
downloadports-29b3d06ab68e56f77bd8c6612cdcb8b9538e2c8d.tar.gz
ports-29b3d06ab68e56f77bd8c6612cdcb8b9538e2c8d.zip
Notes
Diffstat (limited to 'games/openclaw')
-rw-r--r--games/openclaw/Makefile73
-rw-r--r--games/openclaw/distinfo3
-rw-r--r--games/openclaw/files/pkg-message.in6
-rw-r--r--games/openclaw/pkg-descr4
4 files changed, 86 insertions, 0 deletions
diff --git a/games/openclaw/Makefile b/games/openclaw/Makefile
new file mode 100644
index 000000000000..1a04c1cdac70
--- /dev/null
+++ b/games/openclaw/Makefile
@@ -0,0 +1,73 @@
+# $FreeBSD$
+
+PORTNAME= OpenClaw
+DISTVERSION= 0.0-51
+DISTVERSIONSUFFIX= -gbac7730
+CATEGORIES= games
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Reimplementation of Captain Claw (1997) platformer
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libtinyxml.so:textproc/tinyxml
+
+USES= cmake:outsource compiler:c++11-lib pkgconfig localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= pjasicek
+USE_SDL= gfx2 image2 mixer2 ttf2
+
+PLIST_FILES= bin/openclaw
+PORTDATA= ASSETS.ZIP SAVES.XML clacon.ttf config.xml console02.tga
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= LAUNCHER
+OPTIONS_DEFAULT= LAUNCHER
+
+LAUNCHER_DESC= Install launcher to manage game settings
+LAUNCHER_USES= mono
+LAUNCHER_BUILD_DEPENDS= convert:graphics/ImageMagick
+LAUNCHER_PLIST_FILES= bin/ClawLauncher.exe bin/clawlauncher
+LAUNCHER_DESKTOP_ENTRIES= \
+ "${GH_PROJECT}" \
+ "" \
+ "${PORTNAME:tl}" \
+ "clawlauncher" \
+ "Game;ArcadeGame;" \
+ ""
+
+post-patch:
+ @${REINPLACE_CMD} '/CMAKE_RUNTIME_OUTPUT_DIRECTORY/d; s| -O2 -g||' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|/usr/share/openclaw|${DATADIR}|g' \
+ ${WRKSRC}/Build_Release/clawlauncher \
+ ${WRKSRC}/Build_Release/config_linux_release.xml
+
+pre-build:
+ @cd ${WRKSRC}/Build_Release && ${CP} config_linux_release.xml config.xml
+
+post-build-LAUNCHER-on:
+ @convert -verbose -set filename:size %wx%h \
+ ${WRKSRC}/ClawLauncher/Resources/launcher_icon.ico \
+ ${WRKDIR}/launcher_icon_%\[filename:size].png
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME:tl} \
+ ${STAGEDIR}${PREFIX}/bin
+ @cd ${WRKSRC}/Build_Release && ${COPYTREE_SHARE} \
+ "${PORTDATA}" ${STAGEDIR}${DATADIR}
+
+do-install-LAUNCHER-on:
+ ${INSTALL_SCRIPT} ${WRKSRC}/Build_Release/ClawLauncher.exe \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/Build_Release/clawlauncher \
+ ${STAGEDIR}${PREFIX}/bin
+.for size in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 192x192 256x256
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}/apps
+ ${INSTALL_DATA} ${WRKDIR}/launcher_icon_${size}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}/apps/${PORTNAME:tl}.png
+ @${ECHO_CMD} share/icons/hicolor/${size}/apps/${PORTNAME:tl}.png >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/openclaw/distinfo b/games/openclaw/distinfo
new file mode 100644
index 000000000000..eb778e326bea
--- /dev/null
+++ b/games/openclaw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511143151
+SHA256 (pjasicek-OpenClaw-0.0-51-gbac7730_GH0.tar.gz) = 61f5e4d440615a08369591562e2d9489235676bee4bd0182050768eb6ca48af2
+SIZE (pjasicek-OpenClaw-0.0-51-gbac7730_GH0.tar.gz) = 26516775
diff --git a/games/openclaw/files/pkg-message.in b/games/openclaw/files/pkg-message.in
new file mode 100644
index 000000000000..9ffd3aea46fe
--- /dev/null
+++ b/games/openclaw/files/pkg-message.in
@@ -0,0 +1,6 @@
+==============================================================================
+To complete the installation of this port you need to copy the file
+"CLAW.REZ" from the original Captain Claw distribution to
+%%DATADIR%%.
+==============================================================================
+
diff --git a/games/openclaw/pkg-descr b/games/openclaw/pkg-descr
new file mode 100644
index 000000000000..7fd92d318ac3
--- /dev/null
+++ b/games/openclaw/pkg-descr
@@ -0,0 +1,4 @@
+A multiplatform C++ reimplementation of original Captain Claw (1997) platformer
+game using SDL2 and Box2D.
+
+WWW: https://github.com/pjasicek/OpenClaw