aboutsummaryrefslogtreecommitdiff
path: root/games/opendungeons
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-17 07:57:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-17 07:57:12 +0000
commitac217b2c317e773ed468ca8c2ae1effbf688e3f8 (patch)
treee9822a412aa9ec97cc2c74e8ca003cd674ad781c /games/opendungeons
parent570c4aaa4317270ccc9517da8e8ac80c1e4435a3 (diff)
downloadports-ac217b2c317e773ed468ca8c2ae1effbf688e3f8.tar.gz
ports-ac217b2c317e773ed468ca8c2ae1effbf688e3f8.zip
games/opendungeons: unbreak with boost 1.67
/usr/bin/ld: undefined reference to symbol `pthread_condattr_init@@FBSD_1.0' (try adding -lthr) PR: 227427 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=467570
Diffstat (limited to 'games/opendungeons')
-rw-r--r--games/opendungeons/files/patch-boost-1.6713
1 files changed, 13 insertions, 0 deletions
diff --git a/games/opendungeons/files/patch-boost-1.67 b/games/opendungeons/files/patch-boost-1.67
new file mode 100644
index 000000000000..6b1208c57138
--- /dev/null
+++ b/games/opendungeons/files/patch-boost-1.67
@@ -0,0 +1,13 @@
+https://github.com/OpenDungeons/OpenDungeons/pull/1287
+
+--- CMakeLists.txt.orig 2016-08-24 19:52:29 UTC
++++ CMakeLists.txt
+@@ -634,7 +634,7 @@ endif()
+
+ # MSVC automatically links boost
+ if(NOT MSVC)
+- target_link_libraries(${PROJECT_BINARY_NAME} ${Boost_LIBRARIES})
++ target_link_libraries(${PROJECT_BINARY_NAME} ${Boost_LIBRARIES} Threads::Threads)
+ endif()
+
+ # Link sfml