aboutsummaryrefslogtreecommitdiff
path: root/games/openlierox/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-11-04 02:48:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-11-04 02:48:41 +0000
commit4b8b8e4df0588d161d13bbaa900af53416c4d6d7 (patch)
tree09c9f454b845e53ed375a414823e0be8e21f2a83 /games/openlierox/Makefile
parent42aa0e22d5d90d885ff26d70770d509091687532 (diff)
downloadports-4b8b8e4df0588d161d13bbaa900af53416c4d6d7.tar.gz
ports-4b8b8e4df0588d161d13bbaa900af53416c4d6d7.zip
Notes
Diffstat (limited to 'games/openlierox/Makefile')
-rw-r--r--games/openlierox/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 4c7051ba06a2..1c973360c4d5 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
USE_BZIP2= yes
USE_SDL= sdl image
USE_GNOME= libxml2
+MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include/libxml2
CXXFLAGS+= -I${LOCALBASE}/include/libxml2
@@ -52,6 +53,8 @@ post-patch:
${WRKSRC}/src/main.cpp ${WRKSRC}/include/FindFile.h
@${REINPLACE_CMD} -e 's|DATADIR|"${DATADIR}"|' \
${WRKSRC}/src/main.cpp
+ @${REINPLACE_CMD} -e 's|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|' \
+ ${WRKSRC}/CMakeLists.txt
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/openlierox ${PREFIX}/bin