aboutsummaryrefslogtreecommitdiff
path: root/games/openmortal
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
commit3037cb61c7f1ac5ae9a15cee2365daa2d4036028 (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /games/openmortal
parent28eb882aa04c420b3fe972dd8748b80c90c5cd82 (diff)
downloadports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.tar.gz
ports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.zip
Notes
Diffstat (limited to 'games/openmortal')
-rw-r--r--games/openmortal/Makefile9
-rw-r--r--games/openmortal/files/patch-src_gfx.cpp16
2 files changed, 11 insertions, 14 deletions
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index 9b702f4701ed..9828a4b74f46 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openmortal
-# Date created: 20 Apr 2004
-# Whom: krion@FreeBSD.org
-#
+# Created by: krion@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= openmortal
PORTVERSION= 0.7
@@ -14,11 +10,12 @@ MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A parody of the once popular coin-up fighting game, Mortal Kombat
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_PERL5= yes
USE_SDL= mixer image sdl net
+USE_DOS2UNIX= src/gfx.cpp
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
diff --git a/games/openmortal/files/patch-src_gfx.cpp b/games/openmortal/files/patch-src_gfx.cpp
index c1c21476c0a1..c2ceba1442ca 100644
--- a/games/openmortal/files/patch-src_gfx.cpp
+++ b/games/openmortal/files/patch-src_gfx.cpp
@@ -1,11 +1,11 @@
--- src/gfx.cpp.orig Tue Sep 12 18:28:52 2006
+++ src/gfx.cpp Tue Sep 12 18:29:04 2006
@@ -7,7 +7,7 @@
- ***************************************************************************/
-
- #include <string.h>
--#include <malloc.h>
-+#include <stdlib.h>
-
-
- #include "SDL.h"
+ ***************************************************************************/
+
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+
+ #include "SDL.h"