aboutsummaryrefslogtreecommitdiff
path: root/games/opensonic/Makefile
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-02-03 09:10:37 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-02-03 09:10:37 +0000
commit27610faa1a97892ba2bc3066c422a2509c680e11 (patch)
tree6f8684b899970e75125b2f3c2c5bfbfd7808c214 /games/opensonic/Makefile
parent7fe92f57f83a3e3f04b1c9ceca8e3e1827b0e9eb (diff)
downloadports-27610faa1a97892ba2bc3066c422a2509c680e11.tar.gz
ports-27610faa1a97892ba2bc3066c422a2509c680e11.zip
Notes
Diffstat (limited to 'games/opensonic/Makefile')
-rw-r--r--games/opensonic/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/games/opensonic/Makefile b/games/opensonic/Makefile
new file mode 100644
index 000000000000..8c466357b1ab
--- /dev/null
+++ b/games/opensonic/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: games/opensonic
+# Date created: 27 Aug 2009
+# Whom: Stas Timokhin <stast@bsdportal.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opensonic
+PORTVERSION= 0.1.2
+CATEGORIES= games
+MASTER_SITES= SF/opensnc/Open%20Sonic/${PORTVERSION}
+DISTNAME= opensnc-src${PORTVERSION}
+
+MAINTAINER= devel@stasyan.com
+COMMENT= Game based on the "Sonic the Hedgehog" universe
+
+DESKTOP_ENTRIES="${PORTNAME}" \
+ "Sonic the Hedgehog" \
+ "${DATADIR}/images/icon.png" \
+ "${PORTNAME}_launcher" \
+ "Game;KidsGame;" \
+ "false"
+
+USE_CMAKE= yes
+CMAKE_ENV+= OPENSNC_ALLEGRO_LIBS="`allegro-config --libs`" OPENSNC_ALLEGRO_VERSION="`allegro-config --version`"
+
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= CFLAGS="${CFLAGS}"
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libaldmb.a:${PORTSDIR}/audio/dumb-allegro \
+ alpng>=1.3:${PORTSDIR}/graphics/alpng
+RUN_DEPENDS+= ${LOCALBASE}/lib/libaldmb.a:${PORTSDIR}/audio/dumb-allegro \
+ alpng>=1.3:${PORTSDIR}/graphics/alpng
+LIB_DEPENDS+= alleg.42:${PORTSDIR}/devel/allegro \
+ ogg.6:${PORTSDIR}/audio/libogg \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin,${LOCALBASE}/bin,g' \
+ ${PATCH_WRKSRC}/CMakeLists.txt ${PATCH_WRKSRC}/src/global.h
+ @${REINPLACE_CMD} -e 's,/usr/share,${LOCALBASE}/share,g' \
+ ${PATCH_WRKSRC}/src/global.h
+ @${REINPLACE_CMD} -e 's,%%GAME_DIR%%,${DATADIR},g' \
+ ${PATCH_WRKSRC}/src/misc/opensonic ${PATCH_WRKSRC}/src/misc/opensonic_launcher
+
+.include <bsd.port.post.mk>