aboutsummaryrefslogtreecommitdiff
path: root/games/openttd
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-11-24 06:13:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-11-24 06:13:07 +0000
commita5f8c38445145c2ffe6a46c00b5b4e55800467fc (patch)
tree002e8cd93e705ac50c95f502848e511183f5bd53 /games/openttd
parent66b5b71a451402517762b04caf5dd1699cce0111 (diff)
downloadports-a5f8c38445145c2ffe6a46c00b5b4e55800467fc.tar.gz
ports-a5f8c38445145c2ffe6a46c00b5b4e55800467fc.zip
Notes
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile22
-rw-r--r--games/openttd/distinfo5
-rw-r--r--games/openttd/files/openttd.in30
-rw-r--r--games/openttd/pkg-plist1
4 files changed, 48 insertions, 10 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 46ffd078febf..bc9b671b7374 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openttd
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.5
CATEGORIES= games
MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
#SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -14,6 +14,8 @@ MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
MAINTAINER= danfe@FreeBSD.org
COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
+LICENSE= GPLv2
+
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
lzo2.2:${PORTSDIR}/archivers/lzo2
@@ -36,7 +38,8 @@ CONFIGURE_ARGS+= --with-midi-arg=${WITH_MIDI_PLAYER_ARGS}
.if defined(WITH_DEDICATED_SERVER_ONLY)
CONFIGURE_ARGS+= --enable-dedicated
# Aid it to find lzo2 headers; client build gets it via sdl-config
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include"
+CXXFLAGS+= -I${LOCALBASE}/include
+USE_RC_SUBR= ${PORTNAME}
.else
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
@@ -44,10 +47,10 @@ USE_SDL= sdl
.endif
SUB_FILES= pkg-message
-MAN6= openttd.6
+MAN6= ${PORTNAME}.6
-DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "openttd" "openttd" \
- "Game;Simulation;StrategyGame;" false
+DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
+ "Game;Simulation;StrategyGame;" ${FALSE}
PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt elrail.svg \
elrail_tile.png elrail_track.png landscape.html \
@@ -67,8 +70,13 @@ pre-everything::
.endif
post-patch:
-# Remove extra (vendor-provided) CFLAGS and LDFLAGS
- @${REINPLACE_CMD} -e '1250,1252d' ${WRKSRC}/config.lib
+# Remove extra (vendor-provided) CFLAGS and LDFLAGS and make the port more
+# LOCALBASE safe
+ @${REINPLACE_CMD} -e '1250,1252d ; s,/usr/local,${LOCALBASE},' \
+ ${WRKSRC}/config.lib
+# FreeBSD has strndup(3) since 701101
+ @${REINPLACE_CMD} -e '/__NetBSD_Version__/s,$$, || (defined(__FreeBSD_version) \&\& __FreeBSD_version > 701100),' \
+ ${WRKSRC}/src/string_func.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
index c9b4bd63f5e6..92511b0c5114 100644
--- a/games/openttd/distinfo
+++ b/games/openttd/distinfo
@@ -1,3 +1,2 @@
-MD5 (openttd-1.0.3-source.tar.bz2) = cff60c624913a491ed3c91474e845722
-SHA256 (openttd-1.0.3-source.tar.bz2) = f52f2381c678de024d26ee465c8203323eb3484300c4dc182c0d68c439ee8c57
-SIZE (openttd-1.0.3-source.tar.bz2) = 5395672
+SHA256 (openttd-1.0.5-source.tar.bz2) = c353626b16b4b781db3c3c61f0ad651f5701e50f87439c4005b4456b63db09f8
+SIZE (openttd-1.0.5-source.tar.bz2) = 5684796
diff --git a/games/openttd/files/openttd.in b/games/openttd/files/openttd.in
new file mode 100644
index 000000000000..a2b5e0e6e786
--- /dev/null
+++ b/games/openttd/files/openttd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: openttd
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable openttd server:
+#
+# openttd_enable="YES" (bool): Set to "NO" by default
+# Set it to "YES" to enable openttd
+# openttd_flags="" (string): Set to "" by default
+# Extra flags passed to start command
+#
+# Note: flags -D and -f are set by default.
+#
+
+. /etc/rc.subr
+
+name="openttd"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/${name}"
+command_args="-s null -m null -v null -b null -D -f"
+
+load_rc_config ${name}
+
+: ${openttd_enable="NO"}
+
+run_rc_command "$1"
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
index 04e9e917ae64..b38c4a59bfa1 100644
--- a/games/openttd/pkg-plist
+++ b/games/openttd/pkg-plist
@@ -19,6 +19,7 @@ share/pixmaps/openttd.32.xpm
%%DATADIR%%/lang/afrikaans.lng
%%DATADIR%%/lang/arabic_egypt.lng
%%DATADIR%%/lang/brazilian_portuguese.lng
+%%DATADIR%%/lang/belarusian.lng
%%DATADIR%%/lang/bulgarian.lng
%%DATADIR%%/lang/catalan.lng
%%DATADIR%%/lang/croatian.lng