aboutsummaryrefslogtreecommitdiff
path: root/games/openttd
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-05-19 10:01:04 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-05-19 10:01:04 +0000
commit806173ee01eb94fcd840de1dc16cc19b3bfbba35 (patch)
tree6a5a29312d37a8e6cae0b7576d80fcf07b7a4f0f /games/openttd
parentf5b7ad02802808e190dba809da93568ad07198ca (diff)
downloadports-806173ee01eb94fcd840de1dc16cc19b3bfbba35.tar.gz
ports-806173ee01eb94fcd840de1dc16cc19b3bfbba35.zip
Notes
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 689f5a27fad6..495b478925cc 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -23,15 +23,17 @@ LICENSE= GPLv2
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
lzo2.2:${PORTSDIR}/archivers/lzo2
+USE_XZ= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix-dir="${PREFIX}" --data-dir="${DATADIR_REL}"
-USE_XZ= yes
USE_GMAKE= yes
+MAKE_ARGS= VERBOSE=1 # We want to see what's going on
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
DISTVERSIONSUFFIX= -source
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CXXFLAGS= # Set to empty as OpenTTD treats it as an addition to CFLAGS
.if defined(WITH_MIDI_PLAYER)
CONFIGURE_ARGS+= --with-midi=${WITH_MIDI_PLAYER}
@@ -40,9 +42,10 @@ CONFIGURE_ARGS+= --with-midi=${WITH_MIDI_PLAYER}
CONFIGURE_ARGS+= --with-midi-arg=${WITH_MIDI_PLAYER_ARGS}
.endif
.if defined(WITH_DEDICATED_SERVER_ONLY)
+USE_GNOME= pkgconfig # Needed for liblzma support
CONFIGURE_ARGS+= --enable-dedicated
# Aid it to find lzo2 headers; client build gets it via sdl-config
-CXXFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
USE_RC_SUBR= ${PORTNAME}
.else
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
@@ -54,7 +57,7 @@ SUB_FILES= pkg-message
MAN6= ${PORTNAME}.6
DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
- "Game;Simulation;StrategyGame;" ${FALSE}
+ "Game;Simulation;StrategyGame;" false
PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt admin_network.txt \
elrail.svg elrail_tile.png elrail_track.png landscape.html \
@@ -77,14 +80,14 @@ pre-everything::
post-patch:
# Remove extra (vendor-provided) CFLAGS and LDFLAGS and make the port more
-# LOCALBASE safe
- @${REINPLACE_CMD} -e '1355,1355d ; s,/usr/local,${LOCALBASE},' \
+# LOCALBASE safe (don't forget to update XXXX,YYYYd part when upgrading!)
+ @${REINPLACE_CMD} -e '1360,1361d ; s,/usr/local,${LOCALBASE},' \
${WRKSRC}/config.lib
-# Use custom libzma.pc for when we use libzma from base.
+# Use custom liblzma.pc for when we use liblzma from base
.if ${OSVERSION} >= 900012 || (${OSVERSION} >= 800505 && ${OSVERSION} < 900000)
- @${REINPLACE_CMD} \
- -e 's|pkg-config liblzma|pkg-config ${FILESDIR}/liblzma.pc|g' \
- ${WRKSRC}/config.lib
+ @${REINPLACE_CMD} -e \
+ 's,pkg-config liblzma,pkg-config ${FILESDIR}/liblzma.pc,' \
+ ${WRKSRC}/config.lib
.else
LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
.endif