aboutsummaryrefslogtreecommitdiff
path: root/games/openttd
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-03 00:56:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-03 00:56:26 +0000
commit6d5d6429d5880f9fdf4b4b54c0fb53e44b3927f9 (patch)
treedb7a5d68a7b148f62f63c9562391af1272e3f376 /games/openttd
parent91d87ad6cea9c90bdf179910d1ab72b833a67768 (diff)
downloadports-6d5d6429d5880f9fdf4b4b54c0fb53e44b3927f9.tar.gz
ports-6d5d6429d5880f9fdf4b4b54c0fb53e44b3927f9.zip
Notes
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile1
-rw-r--r--games/openttd/files/patch-icu6817
2 files changed, 18 insertions, 0 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 03db20a90083..145e976b38e8 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openttd
DISTVERSION= 1.10.3
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= https://proxy.binaries.openttd.org/openttd-releases/${DISTVERSION}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-source
diff --git a/games/openttd/files/patch-icu68 b/games/openttd/files/patch-icu68
new file mode 100644
index 000000000000..1c2fa15cf409
--- /dev/null
+++ b/games/openttd/files/patch-icu68
@@ -0,0 +1,17 @@
+Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
+
+src/gfx_layout.cpp:119:9: error: use of undeclared identifier 'FALSE'
+ return FALSE;
+ ^
+
+--- src/gfx_layout.cpp.orig 2020-08-09 17:56:38 UTC
++++ src/gfx_layout.cpp
+@@ -116,7 +116,7 @@ void Font::getGlyphAdvance(LEGlyphID glyph, LEPoint &a
+
+ le_bool Font::getGlyphPoint(LEGlyphID glyph, le_int32 pointNumber, LEPoint &point) const
+ {
+- return FALSE;
++ return false;
+ }
+
+ /**