aboutsummaryrefslogtreecommitdiff
path: root/games/openttd
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-17 14:38:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-12-17 14:38:00 +0000
commit8ed1e74326a0e1e309182a108ea00412d3fbb60f (patch)
tree3c04cd8579ced5b6174d019eef914b107318995d /games/openttd
parentbc713acfba65db56f6a6d4e435c2226f7a8ebb22 (diff)
downloadports-8ed1e74326a0e1e309182a108ea00412d3fbb60f.tar.gz
ports-8ed1e74326a0e1e309182a108ea00412d3fbb60f.zip
Notes
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile65
-rw-r--r--games/openttd/distinfo2
-rw-r--r--games/openttd/pkg-descr5
-rw-r--r--games/openttd/pkg-message16
-rw-r--r--games/openttd/pkg-plist35
5 files changed, 123 insertions, 0 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
new file mode 100644
index 000000000000..67d4972e237b
--- /dev/null
+++ b/games/openttd/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: OpenTTD
+# Date created: 16 Dec 2004
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openttd
+PORTVERSION= 0.3.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
+
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_SDL= sdl
+
+post-extract:
+ @${REINPLACE_CMD} -e 's|-O2 $$(WARNING_DISPLAY)|${CFLAGS} $$(WARNING_DISPLAY)|' \
+ -e 's|`$$(SDL-CONFIG) --cflags`|$$(shell $$(SDL-CONFIG) --cflags)|' \
+ -e 's|`$$(SDL-CONFIG) --libs`|$$(shell $$(SDL-CONFIG) --libs)|' \
+ -e 's|CC=|CC\?=|; s|CXX=|CXX\?=|; s|x86_64|amd64|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' ${WRKSRC}/extmidi.c
+
+MAKE_ARGS+= RELEASE=${PORTVERSION} GAME_DATA_DIR=${DATADIR}/ \
+ USE_HOMEDIR=1 PERSONAL_DIR=.openttd
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+pre-everything::
+.if !defined(WITH_MIDI_PLAYER)
+ @${ECHO_MSG} "Define WITH_MIDI_PLAYER=/path/to/player to build with external MIDI player"
+.else
+MAKE_ARGS+= MIDI=${WITH_MIDI_PLAYER}
+.endif
+.if !defined(WITH_NETWORK)
+ @${ECHO_MSG} "Define WITH_NETWORK to enable networking (EXPERIMENTAL!)"
+.else
+MAKE_ARGS+= WITH_NETWORK=1
+.endif
+
+do-install:
+ @${MKDIR} ${DATADIR}/data ${DATADIR}/lang
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/lang/*.lng ${DATADIR}/lang
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in Howto_compile_lng_files_from_CLI.txt Manual.txt console.txt landscape.html \
+ multiplayer.txt ottd-colour-palette.gif textcolor.txt tileh.png
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+. endfor
+.endif
+
+post-install:
+ @${SED} -e 's|$${DATADIR}|${DATADIR}|' ${.CURDIR}/pkg-message >${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/openttd/distinfo b/games/openttd/distinfo
new file mode 100644
index 000000000000..1dc58d2f8561
--- /dev/null
+++ b/games/openttd/distinfo
@@ -0,0 +1,2 @@
+MD5 (openttd-0.3.4.tar.bz2) = 14a4761593ac31418454c9cc1fe8a8bb
+SIZE (openttd-0.3.4.tar.bz2) = 1394627
diff --git a/games/openttd/pkg-descr b/games/openttd/pkg-descr
new file mode 100644
index 000000000000..98b3bff29641
--- /dev/null
+++ b/games/openttd/pkg-descr
@@ -0,0 +1,5 @@
+OpenTTD is a clone of Transport Tycoon Deluxe, a popular Microprose game
+originally written by Chris Sawyer. It attempts to mimic the original game
+as closely as possible while extending it with new features.
+
+WWW: http://www.openttd.org/
diff --git a/games/openttd/pkg-message b/games/openttd/pkg-message
new file mode 100644
index 000000000000..d6fad80077ec
--- /dev/null
+++ b/games/openttd/pkg-message
@@ -0,0 +1,16 @@
+==========================================================================
+
+ OpenTTD requires the original Windows version of "Transport Tycoon
+ Deluxe" data files in order to function. Copy the following files
+ to ${DATADIR}/data/ directory:
+
+ sample.cat
+ trg1r.grf
+ trgcr.grf
+ trghr.grf
+ trgir.grf
+ trgtr.grf
+
+ Enjoy!!
+
+==========================================================================
diff --git a/games/openttd/pkg-plist b/games/openttd/pkg-plist
new file mode 100644
index 000000000000..a38a285559e2
--- /dev/null
+++ b/games/openttd/pkg-plist
@@ -0,0 +1,35 @@
+bin/openttd
+%%DATADIR%%/data/canalsw.grf
+%%DATADIR%%/data/openttd.grf
+%%DATADIR%%/data/opntitle.dat
+%%DATADIR%%/data/signalsw.grf
+%%DATADIR%%/data/trkfoundw.grf
+@dirrm %%DATADIR%%/data
+%%DATADIR%%/lang/american.lng
+%%DATADIR%%/lang/czech.lng
+%%DATADIR%%/lang/danish.lng
+%%DATADIR%%/lang/dutch.lng
+%%DATADIR%%/lang/english.lng
+%%DATADIR%%/lang/finnish.lng
+%%DATADIR%%/lang/french.lng
+%%DATADIR%%/lang/galician.lng
+%%DATADIR%%/lang/german.lng
+%%DATADIR%%/lang/hungarian.lng
+%%DATADIR%%/lang/italian.lng
+%%DATADIR%%/lang/norwegian.lng
+%%DATADIR%%/lang/origveh.lng
+%%DATADIR%%/lang/polish.lng
+%%DATADIR%%/lang/romanian.lng
+%%DATADIR%%/lang/slovak.lng
+%%DATADIR%%/lang/swedish.lng
+@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/Howto_compile_lng_files_from_CLI.txt
+%%PORTDOCS%%%%DOCSDIR%%/Manual.txt
+%%PORTDOCS%%%%DOCSDIR%%/console.txt
+%%PORTDOCS%%%%DOCSDIR%%/landscape.html
+%%PORTDOCS%%%%DOCSDIR%%/multiplayer.txt
+%%PORTDOCS%%%%DOCSDIR%%/ottd-colour-palette.gif
+%%PORTDOCS%%%%DOCSDIR%%/textcolor.txt
+%%PORTDOCS%%%%DOCSDIR%%/tileh.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%