aboutsummaryrefslogtreecommitdiff
path: root/games/optimax/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:30:52 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:30:52 +0000
commit386d5e74205a195bfddd593a2bdcfb248c4b929f (patch)
treee001264e5a1889a8836e8667259b2699883f0933 /games/optimax/Makefile
parent9ac5382ccbc413b496bcd9c2aeff256755986f94 (diff)
Notes
Diffstat (limited to 'games/optimax/Makefile')
-rw-r--r--games/optimax/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/games/optimax/Makefile b/games/optimax/Makefile
new file mode 100644
index 000000000000..40d12cbba2e4
--- /dev/null
+++ b/games/optimax/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: optimax
+# Date created: 2008-01-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= optimax
+PORTVERSION= 0.63
+CATEGORIES= games
+MASTER_SITES= http://www.corewar.info/optimax/dload/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}_unix
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ fsh94nop0.3.zip \
+ fsh88.zip \
+ fsh94draft01.zip
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= A Core War optimizer written in Perl
+
+RUN_DEPENDS= ${SITE_PERL}/mach/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+
+USE_ZIP= yes
+USE_PERL5_RUN= yes
+WRKSRC= ${WRKDIR}/publish_${PORTVERSION:S/.//}
+BUILD_WRKSRC= ${WRKSRC}/optimars/optimars_0.1
+ALL_TARGET= exmars
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/fsh94nop0.2
+ @${MV} ${WRKDIR}/fsh* ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O6|${CFLAGS} -O3|' ${BUILD_WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -i "" -e 's|^#!/.*|#!${PERL}|' ${WRKSRC}/*.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/opti06_3.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/remote.pl ${PREFIX}/bin/${PORTNAME}-remote
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/optimars ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/optitools.pm ${SITE_PERL}
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${CP} -r *.red fsh* templates phase3.lst tables \
+ ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.unix ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>