aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-Bingo
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-24 14:55:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-24 14:55:49 +0000
commit864f1fb6507ce67e4462709c6123e14f1be8abb6 (patch)
treef02cd672cf2eb3aac67807fa7bae2036b8947de6 /games/p5-Games-Bingo
parent4fbf31e94a3afa45f384b4721921920359379dcf (diff)
Notes
Diffstat (limited to 'games/p5-Games-Bingo')
-rw-r--r--games/p5-Games-Bingo/Makefile15
-rw-r--r--games/p5-Games-Bingo/distinfo2
-rw-r--r--games/p5-Games-Bingo/files/patch-Constants.pm20
3 files changed, 34 insertions, 3 deletions
diff --git a/games/p5-Games-Bingo/Makefile b/games/p5-Games-Bingo/Makefile
index dfeccb79fd2d..571ee9ded29c 100644
--- a/games/p5-Games-Bingo/Makefile
+++ b/games/p5-Games-Bingo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Games-Bingo
-PORTVERSION= 0.09
+PORTVERSION= 0.10
CATEGORIES= games perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Games
@@ -23,6 +23,17 @@ MAN3= Games::Bingo.3 \
Games::Bingo::ColumnCollection.3 \
Games::Bingo::Constants.3
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${FIND} ${WRKSRC} -name \*.orig -delete
+
+.if ${PERL_LEVEL} < 500601
+# damn old MakeMaker...
+post-configure:
+ ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
+.endif
+
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing example for ${PKGNAME}"
@@ -30,4 +41,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/bingo.pl ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/p5-Games-Bingo/distinfo b/games/p5-Games-Bingo/distinfo
index d274bbe44471..4513ec6d0b3d 100644
--- a/games/p5-Games-Bingo/distinfo
+++ b/games/p5-Games-Bingo/distinfo
@@ -1 +1 @@
-MD5 (Games-Bingo-0.09.tar.gz) = d4c13035b19b362a625685f7c18955ad
+MD5 (Games-Bingo-0.10.tar.gz) = 56b5e8752918b50e9d704a8e5be03950
diff --git a/games/p5-Games-Bingo/files/patch-Constants.pm b/games/p5-Games-Bingo/files/patch-Constants.pm
new file mode 100644
index 000000000000..9d20d4ad267b
--- /dev/null
+++ b/games/p5-Games-Bingo/files/patch-Constants.pm
@@ -0,0 +1,20 @@
+--- lib/Games/Bingo/Constants.pm.orig Sat Jan 24 12:44:38 2004
++++ lib/Games/Bingo/Constants.pm Sat Jan 24 12:44:50 2004
+@@ -23,8 +23,8 @@
+
+ use constant NUMBER_OF_ROWS_IN_CARD => 3;
+ use constant NUMBER_OF_COLUMNS_IN_CARD => 9;
+-use constant NUMBER_OF_NUMBERS_IN_CARD
+- => (NUMBER_OF_NUMBERS_IN_ROW * NUMBER_OF_ROWS_IN_CARD);
++use constant NUMBER_OF_NUMBERS_IN_CARD =>
++ (NUMBER_OF_NUMBERS_IN_ROW * NUMBER_OF_ROWS_IN_CARD);
+
+
+ 1;
+@@ -109,4 +109,4 @@
+ Games::Bingo is (C) 2003-2004 Jonas B. Nielsen (jonasbn)
+ E<lt>jonasbn@cpan.orgE<gt>
+
+-=cut
+\ No newline at end of file
++=cut