aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-GuessWord
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-12-23 11:01:17 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-12-23 11:01:17 +0000
commitaefa8399ced9768f5dc9a9c20fbe82c39e835afb (patch)
tree53080d1a1c0009d4142fcd26a69b5f2ab7df58a7 /games/p5-Games-GuessWord
parent6ca001f57dc03df8e47b90e9b6ece832826629b3 (diff)
downloadports-aefa8399ced9768f5dc9a9c20fbe82c39e835afb.tar.gz
ports-aefa8399ced9768f5dc9a9c20fbe82c39e835afb.zip
Notes
Diffstat (limited to 'games/p5-Games-GuessWord')
-rw-r--r--games/p5-Games-GuessWord/Makefile28
-rw-r--r--games/p5-Games-GuessWord/distinfo3
-rw-r--r--games/p5-Games-GuessWord/pkg-descr6
-rw-r--r--games/p5-Games-GuessWord/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/games/p5-Games-GuessWord/Makefile b/games/p5-Games-GuessWord/Makefile
new file mode 100644
index 000000000000..0e4f636c9e67
--- /dev/null
+++ b/games/p5-Games-GuessWord/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Games-GuessWord
+# Date created: 23 Dec 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-GuessWord
+PORTVERSION= 0.15
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Guess the letters in a word (ie Hangman)
+
+MAN3= Games::GuessWord.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/p5-Games-GuessWord/distinfo b/games/p5-Games-GuessWord/distinfo
new file mode 100644
index 000000000000..646a5d630085
--- /dev/null
+++ b/games/p5-Games-GuessWord/distinfo
@@ -0,0 +1,3 @@
+MD5 (Games-GuessWord-0.15.tar.gz) = dc0a7d1a9d3dbddb2d8eadc72de8f39c
+SHA256 (Games-GuessWord-0.15.tar.gz) = 6131c6537793b9c37ea3a1df1f6d4888f0e69e1ba999c1661d4faf3081e96bbe
+SIZE (Games-GuessWord-0.15.tar.gz) = 3874
diff --git a/games/p5-Games-GuessWord/pkg-descr b/games/p5-Games-GuessWord/pkg-descr
new file mode 100644
index 000000000000..ff74da01042c
--- /dev/null
+++ b/games/p5-Games-GuessWord/pkg-descr
@@ -0,0 +1,6 @@
+This module is a simple wrapper around a word guessing game. You have to
+guess the word by guessing letters in the word, and is otherwise known as
+Hangman.
+
+WWW: http://search.cpan.org/dist/Games-GuessWord
+Author: Leon Brocard <acme@astray.com>
diff --git a/games/p5-Games-GuessWord/pkg-plist b/games/p5-Games-GuessWord/pkg-plist
new file mode 100644
index 000000000000..e9c3ef3303ab
--- /dev/null
+++ b/games/p5-Games-GuessWord/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Games/GuessWord.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/GuessWord/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/GuessWord
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games
+@dirrmtry %%SITE_PERL%%/Games