aboutsummaryrefslogtreecommitdiff
path: root/games/pacmanarena
diff options
context:
space:
mode:
authorGlen Barber <gjb@FreeBSD.org>2012-09-01 15:14:51 +0000
committerGlen Barber <gjb@FreeBSD.org>2012-09-01 15:14:51 +0000
commit6db3c0ebaeb0946bfa6a677b4b07d30080024d50 (patch)
tree2f8fc7e24a5648e03b4276bf45bb69f092c3b77d /games/pacmanarena
parent022132c3302455b485c276f8d51b2eb6effb3118 (diff)
downloadports-6db3c0ebaeb0946bfa6a677b4b07d30080024d50.tar.gz
ports-6db3c0ebaeb0946bfa6a677b4b07d30080024d50.zip
Notes
Diffstat (limited to 'games/pacmanarena')
-rw-r--r--games/pacmanarena/Makefile59
-rw-r--r--games/pacmanarena/distinfo6
-rw-r--r--games/pacmanarena/pkg-descr10
3 files changed, 75 insertions, 0 deletions
diff --git a/games/pacmanarena/Makefile b/games/pacmanarena/Makefile
new file mode 100644
index 000000000000..3291af7d6159
--- /dev/null
+++ b/games/pacmanarena/Makefile
@@ -0,0 +1,59 @@
+# $FreeBSD$
+
+PORTNAME= pacmanarena
+PORTVERSION= 0.15
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v0.0/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${DISTNAME:S/na/n-a/}.tar.bz2 \
+ ${PORTNAME:S/arena/-data/}-0.0.zip \
+ ${PORTNAME}_icons.tar.gz:icons
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= A Pacman clone in full 3D with a few surprises
+
+LICENSE= GPLv2
+
+EXTRACT_DEPENDS=zip:${PORTSDIR}/archivers/zip
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/arena//}
+
+USE_AUTOTOOLS= aclocal ${AUTOMAKE} ${AUTOCONF}
+USE_SDL= mixer net sdl
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}_48.png \
+ share/pixmaps/${PORTNAME}_64.png \
+ share/pixmaps/${PORTNAME}_72.png \
+ share/pixmaps/${PORTNAME}_96.png
+
+PORTDATA= *
+PORTDOCS= README
+
+post-patch:
+# Fix data location
+ @${REINPLACE_CMD} -e 's|@prefix@|${DATADIR}|' \
+ -e 's|@datadir@/pacman|${DATADIR}|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.options.mk>
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME:S/arena//} ${PREFIX}/bin/${PORTNAME}
+
+# Data
+ ${MKDIR} ${DATADIR}
+.for d in gfx sfx
+ @(cd ${WRKSRC}/../ && ${COPYTREE_SHARE} ${d} ${DATADIR})
+.endfor
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/pacmanarena/distinfo b/games/pacmanarena/distinfo
new file mode 100644
index 000000000000..0921b53e8e9a
--- /dev/null
+++ b/games/pacmanarena/distinfo
@@ -0,0 +1,6 @@
+SHA256 (pacman-arena-0.15.tar.bz2) = 3f151518f3d4a9595ea03f9ef681e8a8829e88e76fb5d39bab0249906121fc23
+SIZE (pacman-arena-0.15.tar.bz2) = 100112
+SHA256 (pacman-data-0.0.zip) = 7949f080ca0ba4c02d737c5bb365856c3e66f103838329be8c1857d6c297b9b8
+SIZE (pacman-data-0.0.zip) = 11994364
+SHA256 (pacmanarena_icons.tar.gz) = 55a6e8e4144f4fc3c49597a11bb9482ff980935d43f993da9080db837fdcc3d7
+SIZE (pacmanarena_icons.tar.gz) = 14848
diff --git a/games/pacmanarena/pkg-descr b/games/pacmanarena/pkg-descr
new file mode 100644
index 000000000000..f134eaeafbe7
--- /dev/null
+++ b/games/pacmanarena/pkg-descr
@@ -0,0 +1,10 @@
+Pacman Arena is a Pacman clone in full 3D with a few surprises.
+Rockets, bombs and explosions abound.
+
+A Pacman clone gone mad
+
+Yes, it's Pacman. With rockets. And bombs. And spoiled gameplay. And in full 3D.
+Finally, a version of Pacman which will bring your shiny new machine
+down to it's knees.
+
+WWW: http://pacmanarena.sourceforge.net/