aboutsummaryrefslogtreecommitdiff
path: root/games/peg-e
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-01-30 18:46:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-01-30 18:46:33 +0000
commitb23fcc25c6ef0ef27c1a70f7d5024aea6c12b505 (patch)
tree7221c2ba6ef025cb577f3f3ec3bf8d395a5878ca /games/peg-e
parent3b4bf548af5819c1d6386df7dfb8e67b71b52267 (diff)
downloadports-b23fcc25c6ef0ef27c1a70f7d5024aea6c12b505.tar.gz
ports-b23fcc25c6ef0ef27c1a70f7d5024aea6c12b505.zip
Notes
Diffstat (limited to 'games/peg-e')
-rw-r--r--games/peg-e/Makefile32
-rw-r--r--games/peg-e/distinfo3
-rw-r--r--games/peg-e/pkg-descr7
-rw-r--r--games/peg-e/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/games/peg-e/Makefile b/games/peg-e/Makefile
new file mode 100644
index 000000000000..9c4b3be4fb7f
--- /dev/null
+++ b/games/peg-e/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: peg-e
+# Date created: 28 Jan 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= peg-e
+PORTVERSION= 1.0.0
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/peg-e/ \
+ http://mirror.amdmi3.ru/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Peg elimination game
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+
+QT_COMPONENTS= corelib gui moc_build opengl qmake_build rcc_build xml
+QT_COMPONENTS= corelib gui moc_build qmake_build rcc_build
+WANT_GNOME= yes
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ PREFIX=${PREFIX} -spec ${QMAKESPEC} ${PORTNAME}.pro
+
+.include <bsd.port.mk>
diff --git a/games/peg-e/distinfo b/games/peg-e/distinfo
new file mode 100644
index 000000000000..39e51eff95fd
--- /dev/null
+++ b/games/peg-e/distinfo
@@ -0,0 +1,3 @@
+MD5 (peg-e-1.0.0-src.tar.bz2) = 93bba1a3ac85b0be370998359ddbed91
+SHA256 (peg-e-1.0.0-src.tar.bz2) = 23c8ceb68c9ed42b09df5612a153e5a07ea7c14c88275858794df3db569a234f
+SIZE (peg-e-1.0.0-src.tar.bz2) = 51363
diff --git a/games/peg-e/pkg-descr b/games/peg-e/pkg-descr
new file mode 100644
index 000000000000..9c1ba2dec411
--- /dev/null
+++ b/games/peg-e/pkg-descr
@@ -0,0 +1,7 @@
+Peg-E is a peg solitaire game in which you jump over pieces in order
+to remove them from the board, ultimately trying to eliminate all
+but one. The boards are randomly generated, with 100 levels of
+difficulty. The game auto-saves, and has undo-redo capability.
+Pieces can move horizontally, vertically, and diagonally.
+
+WWW: http://gottcode.org/peg-e/
diff --git a/games/peg-e/pkg-plist b/games/peg-e/pkg-plist
new file mode 100644
index 000000000000..961b34a2551a
--- /dev/null
+++ b/games/peg-e/pkg-plist
@@ -0,0 +1,8 @@
+bin/peg-e
+share/applications/peg-e.desktop
+share/icons/hicolor/48x48/apps/peg-e.png
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications