aboutsummaryrefslogtreecommitdiff
path: root/games/phalanx
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
commit4aed6f1e6536c2d3be11d0ac7596e10b27791cb5 (patch)
tree021f61372fc74d69c6dbb086d15d03b8a2cae67e /games/phalanx
parent77140e508e938432f22e37e787489915e2d78661 (diff)
downloadports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.tar.gz
ports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.zip
Notes
Diffstat (limited to 'games/phalanx')
-rw-r--r--games/phalanx/Makefile38
-rw-r--r--games/phalanx/distinfo2
-rw-r--r--games/phalanx/files/patch-aa32
-rw-r--r--games/phalanx/pkg-descr2
-rw-r--r--games/phalanx/pkg-plist1
5 files changed, 31 insertions, 44 deletions
diff --git a/games/phalanx/Makefile b/games/phalanx/Makefile
index 1099c3ec1c86..218b0948779e 100644
--- a/games/phalanx/Makefile
+++ b/games/phalanx/Makefile
@@ -1,37 +1,33 @@
# New ports collection makefile for: phalanx
-# Version required: 21
+# Version required: 22
# Date created: 2 May 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
-DISTNAME= phalanx-21
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- ftp://ftp.math.muni.cz/pub/math/people/Dobes/
-MASTER_SITE_SUBDIR= games/strategy
+DISTNAME= phalanx-22
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.math.muni.cz/pub/math/people/Dobes/ \
+ http://www.crosswinds.net/~dobes/phalanx/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-WRKSRC= ${WRKDIR}/Phalanx-XXI
-USE_GMAKE= yes
-ALL_TARGET=
-MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/Phalanx-XXII
+USE_GMAKE= yes
+ALL_TARGET= # empty
+MAKEFILE= makefile
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/phalanx ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/pbook.phalanx ${PREFIX}/share/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/sbook.phalanx ${PREFIX}/share/phalanx
-
-post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/phalanx ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/phalanx
+ ${INSTALL_DATA} ${WRKSRC}/pbook.phalanx ${PREFIX}/share/phalanx
+ ${INSTALL_DATA} ${WRKSRC}/sbook.phalanx ${PREFIX}/share/phalanx
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/phalanx
+ @${MKDIR} ${PREFIX}/share/doc/phalanx
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/phalanx
.endif
.include <bsd.port.mk>
diff --git a/games/phalanx/distinfo b/games/phalanx/distinfo
index 7bb6e46b7f19..e8d671e62b5f 100644
--- a/games/phalanx/distinfo
+++ b/games/phalanx/distinfo
@@ -1 +1 @@
-MD5 (phalanx-21.tar.gz) = ab1ae987833c25cf8ce00ca8cf2b5b8c
+MD5 (phalanx-22.tar.gz) = 8120f6383bb6d19e0c06ea47f69c2bda
diff --git a/games/phalanx/files/patch-aa b/games/phalanx/files/patch-aa
index ce2d009e2c83..c512328124cb 100644
--- a/games/phalanx/files/patch-aa
+++ b/games/phalanx/files/patch-aa
@@ -1,33 +1,23 @@
---- makefile Sat Jan 30 00:26:13 1999
-+++ /home/andy/tmp/wrk/makefile Sun May 2 16:46:44 1999
-@@ -1,9 +1,10 @@
+--- makefile.orig Mon Jan 17 06:30:49 2000
++++ makefile Thu Mar 30 01:42:40 2000
+@@ -1,9 +1,9 @@
-CC = gcc
-+#CC = gcc
++CC ?= gcc
####### choose the line that makes the binary faster on your machine
# CFLAGS = -O3 -Wall -fomit-frame-pointer -funroll-loops
--CFLAGS = -O -fomit-frame-pointer
-+#CFLAGS = -O -fomit-frame-pointer
-+CFLAGS+= -I${LOCALBASE}/include
+-CFLAGS = -O -Wall -fomit-frame-pointer
++CFLAGS += -I${LOCALBASE}/include
####### debug/tuning options for developers
# CFLAGS = -O -Wall -g3 -static
-@@ -20,7 +21,7 @@
- ### -DLEARN_DIR=\"/var/local/lib\"
+@@ -21,7 +21,7 @@
### -DQCAPSONLY
--DEFINES = -DGNUFUN
-+DEFINES = -DGNUFUN -DPBOOK_DIR=\"${PREFIX}/share/phalanx\" -DSBOOK_DIR=\"${PREFIX}/share/phalanx\"
- LDFLAGS =
+ DEFINES = -DGNUFUN
+-LDFLAGS =
++LDFLAGS = -L${LOCALBASE}/lib -lgnugetopt
OBJ = .o/phalanx.o .o/bcreate.o .o/search.o .o/io.o .o/data.o \
-@@ -28,7 +29,7 @@
- .o/levels.o .o/book.o .o/killers.o .o/endgame.o .o/learn.o
-
- phalanx: .o $(OBJ)
-- $(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $(OBJ) -o phalanx
-+ $(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $(OBJ) -o phalanx -L${LOCALBASE}/lib -lgnugetopt
- strip phalanx
-
- .o/%.o: makefile %.c
+ .o/evaluate.o .o/genmoves.o .o/moving.o .o/hash.o .o/static.o \
diff --git a/games/phalanx/pkg-descr b/games/phalanx/pkg-descr
index 7c42d3f7fec1..445e6841963f 100644
--- a/games/phalanx/pkg-descr
+++ b/games/phalanx/pkg-descr
@@ -9,3 +9,5 @@ one CPU.
It's also possible to run phalanx without xboard. Do "phalanx -h" to get
a list of command line options. One important command of phalanx's ASCII
interface is "help".
+
+WWW: http://www.crosswinds.net/~dobes/phalanx/
diff --git a/games/phalanx/pkg-plist b/games/phalanx/pkg-plist
index 087358edc4f7..309dd924ecdf 100644
--- a/games/phalanx/pkg-plist
+++ b/games/phalanx/pkg-plist
@@ -1,5 +1,4 @@
bin/phalanx
-share/doc/phalanx/COPYING
share/doc/phalanx/README
share/phalanx/pbook.phalanx
share/phalanx/sbook.phalanx