aboutsummaryrefslogtreecommitdiff
path: root/games/phlipple/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-10-31 21:09:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-10-31 21:09:49 +0000
commitdb5cf7797da9b552878ca71f48f1e0c7536f24e6 (patch)
treecb96f1f5edb0a3e78120a9a7c2c1dd0324d82ae4 /games/phlipple/Makefile
parent8bcc0d1381df703d7c50f0bb59d2910cf5cd5f0b (diff)
downloadports-db5cf7797da9b552878ca71f48f1e0c7536f24e6.tar.gz
ports-db5cf7797da9b552878ca71f48f1e0c7536f24e6.zip
Notes
Diffstat (limited to 'games/phlipple/Makefile')
-rw-r--r--games/phlipple/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/phlipple/Makefile b/games/phlipple/Makefile
new file mode 100644
index 000000000000..5791641b658a
--- /dev/null
+++ b/games/phlipple/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: phlipple
+# Date created: 01 Nov 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phlipple
+PORTVERSION= 0.8.1
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Flipping squares will never be the same
+
+LIB_DEPENDS= ogg.7:${PORTSDIR}/audio/libogg \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ GLEW.1:${PORTSDIR}/graphics/glew
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl mixer image
+USE_GL= gl glu
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/*.c
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/install-data-am:/ s|install-dist_docDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>