aboutsummaryrefslogtreecommitdiff
path: root/games/phlipple
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-10-31 21:09:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-10-31 21:09:49 +0000
commitdb5cf7797da9b552878ca71f48f1e0c7536f24e6 (patch)
treecb96f1f5edb0a3e78120a9a7c2c1dd0324d82ae4 /games/phlipple
parent8bcc0d1381df703d7c50f0bb59d2910cf5cd5f0b (diff)
downloadports-db5cf7797da9b552878ca71f48f1e0c7536f24e6.tar.gz
ports-db5cf7797da9b552878ca71f48f1e0c7536f24e6.zip
Notes
Diffstat (limited to 'games/phlipple')
-rw-r--r--games/phlipple/Makefile37
-rw-r--r--games/phlipple/distinfo2
-rw-r--r--games/phlipple/pkg-descr9
-rw-r--r--games/phlipple/pkg-plist81
4 files changed, 129 insertions, 0 deletions
diff --git a/games/phlipple/Makefile b/games/phlipple/Makefile
new file mode 100644
index 000000000000..5791641b658a
--- /dev/null
+++ b/games/phlipple/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: phlipple
+# Date created: 01 Nov 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phlipple
+PORTVERSION= 0.8.1
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Flipping squares will never be the same
+
+LIB_DEPENDS= ogg.7:${PORTSDIR}/audio/libogg \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ GLEW.1:${PORTSDIR}/graphics/glew
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl mixer image
+USE_GL= gl glu
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/*.c
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/install-data-am:/ s|install-dist_docDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/phlipple/distinfo b/games/phlipple/distinfo
new file mode 100644
index 000000000000..a83b010ab911
--- /dev/null
+++ b/games/phlipple/distinfo
@@ -0,0 +1,2 @@
+SHA256 (phlipple-0.8.1.tar.gz) = b1d2389366559cd0784edf1aa0c220a1a3132ac5aab12bf351140ebeb3ac519d
+SIZE (phlipple-0.8.1.tar.gz) = 2747179
diff --git a/games/phlipple/pkg-descr b/games/phlipple/pkg-descr
new file mode 100644
index 000000000000..18f2eb38cb18
--- /dev/null
+++ b/games/phlipple/pkg-descr
@@ -0,0 +1,9 @@
+Phlipple is a unique puzzle game. The goal of every level is to
+reduce a 3D shape to a single square. Elimination of squares is
+done by flipping edges around just like in a cardboard box.
+
+It starts off relatively easy to teach the basics just to later on
+serve hours of brain tickling fun. It's a great way to train memory
+as well as orientation in 3D.
+
+WWW: http://phuzzboxmedia.com/games/phlipple
diff --git a/games/phlipple/pkg-plist b/games/phlipple/pkg-plist
new file mode 100644
index 000000000000..6f855d58b2ab
--- /dev/null
+++ b/games/phlipple/pkg-plist
@@ -0,0 +1,81 @@
+bin/phlipple
+share/applications/phlipple.desktop
+%%DATADIR%%/audiooff.png
+%%DATADIR%%/audioon.png
+%%DATADIR%%/click.ogg
+%%DATADIR%%/click2.ogg
+%%DATADIR%%/copyright.txt
+%%DATADIR%%/failure.ogg
+%%DATADIR%%/glitch.ogg
+%%DATADIR%%/leftright.png
+%%DATADIR%%/level001
+%%DATADIR%%/level002
+%%DATADIR%%/level003
+%%DATADIR%%/level004
+%%DATADIR%%/level005
+%%DATADIR%%/level006
+%%DATADIR%%/level007
+%%DATADIR%%/level008
+%%DATADIR%%/level009
+%%DATADIR%%/level010
+%%DATADIR%%/level011
+%%DATADIR%%/level012
+%%DATADIR%%/level013
+%%DATADIR%%/level014
+%%DATADIR%%/level016
+%%DATADIR%%/level017
+%%DATADIR%%/level018
+%%DATADIR%%/level019
+%%DATADIR%%/level020
+%%DATADIR%%/level021
+%%DATADIR%%/level022
+%%DATADIR%%/level023
+%%DATADIR%%/level025
+%%DATADIR%%/level026
+%%DATADIR%%/level027
+%%DATADIR%%/level028
+%%DATADIR%%/level029
+%%DATADIR%%/level030
+%%DATADIR%%/level031
+%%DATADIR%%/level032
+%%DATADIR%%/level033
+%%DATADIR%%/level034
+%%DATADIR%%/level035
+%%DATADIR%%/level037
+%%DATADIR%%/level038
+%%DATADIR%%/level041
+%%DATADIR%%/level042
+%%DATADIR%%/level044
+%%DATADIR%%/level045
+%%DATADIR%%/level046
+%%DATADIR%%/level047
+%%DATADIR%%/level048
+%%DATADIR%%/level049
+%%DATADIR%%/level050
+%%DATADIR%%/level060
+%%DATADIR%%/level064
+%%DATADIR%%/level065
+%%DATADIR%%/level066
+%%DATADIR%%/level076
+%%DATADIR%%/level094
+%%DATADIR%%/levels.txt
+%%DATADIR%%/logo.png
+%%DATADIR%%/menu.png
+%%DATADIR%%/next.png
+%%DATADIR%%/pause.png
+%%DATADIR%%/phlip.ogg
+%%DATADIR%%/quit.png
+%%DATADIR%%/reset.png
+%%DATADIR%%/start.png
+%%DATADIR%%/success.ogg
+%%DATADIR%%/support_android.png
+%%DATADIR%%/support_apple.png
+%%DATADIR%%/theme.ogg
+%%DATADIR%%/tut1.png
+%%DATADIR%%/tut2.png
+%%DATADIR%%/tut3.png
+%%DATADIR%%/ubuntu.fnt
+%%DATADIR%%/ubuntu_0.png
+share/pixmaps/phlipple.png
+@dirrm %%DATADIR%%
+@dirrmtry share/applications