aboutsummaryrefslogtreecommitdiff
path: root/games/phpua-cod
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-10 12:45:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-10 12:45:38 +0000
commitbb47469b97066360804e438678f23041e2ed36b7 (patch)
treedf2e987579c62980ca76a1c117cee05de48afb02 /games/phpua-cod
parent9add59958cfc0eed3b7e5b52a15c3ffcfda59038 (diff)
downloadports-bb47469b97066360804e438678f23041e2ed36b7.tar.gz
ports-bb47469b97066360804e438678f23041e2ed36b7.zip
Notes
Diffstat (limited to 'games/phpua-cod')
-rw-r--r--games/phpua-cod/Makefile53
-rw-r--r--games/phpua-cod/distinfo2
-rw-r--r--games/phpua-cod/files/pkg-opts10
-rw-r--r--games/phpua-cod/pkg-descr11
-rw-r--r--games/phpua-cod/pkg-plist31
5 files changed, 107 insertions, 0 deletions
diff --git a/games/phpua-cod/Makefile b/games/phpua-cod/Makefile
new file mode 100644
index 000000000000..4ec9c3614ec8
--- /dev/null
+++ b/games/phpua-cod/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: phpua-plugin_cod
+# Date created: 11 March 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpua-plugin_cod
+PORTVERSION= 1.1.0b
+CATEGORIES= games www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpua
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= A Call of Duty plugin for phpUA
+
+RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+
+# Some variables you can change
+PHPUA?= www/data/phpua
+USER?= www
+GROUP?= www
+
+# Static Variables
+PKGOPTS= ${FILESDIR}/pkg-opts
+
+NO_BUILD= yes
+
+PLIST_SUB+= PHPUA=${PHPUA}
+
+options:
+ @ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
+ @ ${CAT} ${PKGOPTS}
+
+pre-everything::
+.if !defined(BATCH)
+ @ ${TEST} -r ${PKGOPTS} && \
+ (${ECHO_MSG} '-------------------------------------------------------------------------'; \
+ ${ECHO_MSG} 'Perform a "make options" to see a list of available installation options.'; \
+ ${ECHO_MSG} '-------------------------------------------------------------------------')
+.endif
+
+do-install:
+ @ ${CP} -R ${WRKDIR}/images ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
+ @ ${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/${PHPUA}
+ @ ${ECHO_MSG} ""
+ @ ${ECHO_MSG} "* Files have been installed in"
+ @ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
+ @ ${ECHO_MSG} "*"
+
+.include <bsd.port.mk>
diff --git a/games/phpua-cod/distinfo b/games/phpua-cod/distinfo
new file mode 100644
index 000000000000..6623baf756e3
--- /dev/null
+++ b/games/phpua-cod/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpua-plugin_cod-1.1.0b.tar.gz) = 6489dfd30e13e93daeab65a5002f43f0
+SIZE (phpua-plugin_cod-1.1.0b.tar.gz) = 379149
diff --git a/games/phpua-cod/files/pkg-opts b/games/phpua-cod/files/pkg-opts
new file mode 100644
index 000000000000..60e0b3999572
--- /dev/null
+++ b/games/phpua-cod/files/pkg-opts
@@ -0,0 +1,10 @@
+
+> PHPUA [www/data/phpua]
+ The DocumentRoot for your webserver under ${PREFIX}
+
+> USER [www]
+ The user ID under which your webserver runs
+
+> GROUP [www]
+ The group ID under which your webserver runs
+
diff --git a/games/phpua-cod/pkg-descr b/games/phpua-cod/pkg-descr
new file mode 100644
index 000000000000..f2931d593a45
--- /dev/null
+++ b/games/phpua-cod/pkg-descr
@@ -0,0 +1,11 @@
+phpUA is a PHP script that enables gaming server administrators
+to manage their servers via a website interface and to display
+server information including live statistics to the public.
+Plug-ins allow for game, language and website design compatibility.
+
+This is a plug-in for Call of Duty.
+
+WWW: http://phpua.sourceforge.net/
+
+- Hideki
+hido@neojapangz.com
diff --git a/games/phpua-cod/pkg-plist b/games/phpua-cod/pkg-plist
new file mode 100644
index 000000000000..ab1394c028c1
--- /dev/null
+++ b/games/phpua-cod/pkg-plist
@@ -0,0 +1,31 @@
+%%PHPUA%%/images/plugin_cod/maps/mp_brecourt.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_carentan.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_chateau.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_dawnville.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_depot.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_harbor.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_hurtgen.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_pavlov.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_powcamp.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_railyard.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_rocket.jpg
+%%PHPUA%%/images/plugin_cod/maps/mp_ship.jpg
+%%PHPUA%%/images/templates/default/plugin_cod/unavailable.jpg
+%%PHPUA%%/plugins/plugin_cod/plugin_cod.inc
+%%PHPUA%%/plugins/plugin_cod/plugin_cod_mode_info.inc
+%%PHPUA%%/plugins/plugin_cod/plugin_cod_mode_rules.inc
+%%PHPUA%%/plugins/plugin_cod/plugin_cod_mode_watch.inc
+%%PHPUA%%/templates/default/plugin_cod/info.tpl
+%%PHPUA%%/templates/default/plugin_cod/rules.tpl
+%%PHPUA%%/templates/default/plugin_cod/watch.js
+%%PHPUA%%/templates/default/plugin_cod/watch.tpl
+%%PHPUA%%/templates/default/plugin_cod/x.js
+%%PHPUA%%/templates/javascript/plugin_cod/info.tpl
+%%PHPUA%%/templates/wap/plugin_cod/info.tpl
+@dirrm %%PHPUA%%/templates/wap/plugin_cod
+@dirrm %%PHPUA%%/templates/javascript/plugin_cod
+@dirrm %%PHPUA%%/templates/default/plugin_cod
+@dirrm %%PHPUA%%/plugins/plugin_cod
+@dirrm %%PHPUA%%/images/templates/default/plugin_cod
+@dirrm %%PHPUA%%/images/plugin_cod/maps
+@dirrm %%PHPUA%%/images/plugin_cod