aboutsummaryrefslogtreecommitdiff
path: root/games/phpua-hl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-10 11:59:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-10 11:59:56 +0000
commit36bcc51537bcba1df18a7b92785e06fc8bdb7018 (patch)
tree35a53969f662e54515613081a85e062959b91c9a /games/phpua-hl
parent771d9c7e324ae4aaba2e0772f4505e1c764ae7f7 (diff)
downloadports-36bcc51537bcba1df18a7b92785e06fc8bdb7018.tar.gz
ports-36bcc51537bcba1df18a7b92785e06fc8bdb7018.zip
Notes
Diffstat (limited to 'games/phpua-hl')
-rw-r--r--games/phpua-hl/Makefile53
-rw-r--r--games/phpua-hl/distinfo2
-rw-r--r--games/phpua-hl/files/pkg-opts10
-rw-r--r--games/phpua-hl/pkg-descr11
-rw-r--r--games/phpua-hl/pkg-plist60
5 files changed, 136 insertions, 0 deletions
diff --git a/games/phpua-hl/Makefile b/games/phpua-hl/Makefile
new file mode 100644
index 000000000000..d0689200563a
--- /dev/null
+++ b/games/phpua-hl/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: phpua-plugin_hl
+# Date created: 29 March 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpua-plugin_hl
+PORTVERSION= 1.1.0b
+CATEGORIES= games www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpua
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= A Half-Life plugin for phpUA
+
+RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+
+# Some variables you can change
+PHPUA?= www/data/phpua
+USER?= www
+GROUP?= www
+
+# Static Variables
+PKGOPTS= ${FILESDIR}/pkg-opts
+
+NO_BUILD= yes
+
+PLIST_SUB+= PHPUA=${PHPUA}
+
+options:
+ @ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
+ @ ${CAT} ${PKGOPTS}
+
+pre-everything::
+.if !defined(BATCH)
+ @ ${TEST} -r ${PKGOPTS} && \
+ (${ECHO_MSG} '-------------------------------------------------------------------------'; \
+ ${ECHO_MSG} 'Perform a "make options" to see a list of available installation options.'; \
+ ${ECHO_MSG} '-------------------------------------------------------------------------')
+.endif
+
+do-install:
+ @ ${CP} -R ${WRKDIR}/images ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
+ @ ${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/${PHPUA}
+ @ ${ECHO_MSG} ""
+ @ ${ECHO_MSG} "* Files have been installed in"
+ @ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
+ @ ${ECHO_MSG} "*"
+
+.include <bsd.port.mk>
diff --git a/games/phpua-hl/distinfo b/games/phpua-hl/distinfo
new file mode 100644
index 000000000000..af53dd56752f
--- /dev/null
+++ b/games/phpua-hl/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpua-plugin_hl-1.1.0b.tar.gz) = 5be2d0b2c313c5c74b137636cb8954d2
+SIZE (phpua-plugin_hl-1.1.0b.tar.gz) = 37656
diff --git a/games/phpua-hl/files/pkg-opts b/games/phpua-hl/files/pkg-opts
new file mode 100644
index 000000000000..60e0b3999572
--- /dev/null
+++ b/games/phpua-hl/files/pkg-opts
@@ -0,0 +1,10 @@
+
+> PHPUA [www/data/phpua]
+ The DocumentRoot for your webserver under ${PREFIX}
+
+> USER [www]
+ The user ID under which your webserver runs
+
+> GROUP [www]
+ The group ID under which your webserver runs
+
diff --git a/games/phpua-hl/pkg-descr b/games/phpua-hl/pkg-descr
new file mode 100644
index 000000000000..d1d4fa66ac0a
--- /dev/null
+++ b/games/phpua-hl/pkg-descr
@@ -0,0 +1,11 @@
+phpUA is a PHP script that enables gaming server administrators
+to manage their servers via a website interface and to display
+server information including live statistics to the public.
+Plug-ins allow for game, language and website design compatibility.
+
+This is a plug-in for Half Life.
+
+WWW: http://phpua.sourceforge.net/
+
+- Hideki
+hido@neojapangz.com
diff --git a/games/phpua-hl/pkg-plist b/games/phpua-hl/pkg-plist
new file mode 100644
index 000000000000..4de19d669ed1
--- /dev/null
+++ b/games/phpua-hl/pkg-plist
@@ -0,0 +1,60 @@
+%%PHPUA%%/images/templates/default/plugin_hl/bomb.png
+%%PHPUA%%/images/templates/default/plugin_hl/bomb_planted.png
+%%PHPUA%%/images/templates/default/plugin_hl/dispenser.png
+%%PHPUA%%/images/templates/default/plugin_hl/flag_blue.gif
+%%PHPUA%%/images/templates/default/plugin_hl/flag_gray.gif
+%%PHPUA%%/images/templates/default/plugin_hl/flag_green.gif
+%%PHPUA%%/images/templates/default/plugin_hl/flag_red.gif
+%%PHPUA%%/images/templates/default/plugin_hl/flag_yellow.gif
+%%PHPUA%%/images/templates/default/plugin_hl/icon_blue.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_command.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_dead.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_green.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_hive.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_hostage.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_red.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_resource_alien.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_resource_marine.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_vip.png
+%%PHPUA%%/images/templates/default/plugin_hl/icon_yellow.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry1_0.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry1_1.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry1_2.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry1_3.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry2_0.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry2_1.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry2_2.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry2_3.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry3_0.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry3_1.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry3_2.png
+%%PHPUA%%/images/templates/default/plugin_hl/sentry3_3.png
+%%PHPUA%%/images/templates/default/plugin_hl/teleporter0.png
+%%PHPUA%%/images/templates/default/plugin_hl/teleporter1.png
+%%PHPUA%%/images/templates/default/plugin_hl/teleporter2.png
+%%PHPUA%%/images/templates/default/plugin_hl/teleporter3.png
+%%PHPUA%%/images/templates/default/plugin_hl/unavailable.jpg
+%%PHPUA%%/images/templates/wap/plugin_hl/unavailable.jpg
+%%PHPUA%%/plugins/plugin_hl/plugin_hl.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_mm.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_mode_info.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_mode_rules.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_mode_watch.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_mode_watch_mm.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_mode_watch_query.inc
+%%PHPUA%%/plugins/plugin_hl/plugin_hl_query.inc
+%%PHPUA%%/templates/default/plugin_hl/info.tpl
+%%PHPUA%%/templates/default/plugin_hl/rules.tpl
+%%PHPUA%%/templates/default/plugin_hl/watch_mm.js
+%%PHPUA%%/templates/default/plugin_hl/watch_mm.tpl
+%%PHPUA%%/templates/default/plugin_hl/watch_query.js
+%%PHPUA%%/templates/default/plugin_hl/watch_query.tpl
+%%PHPUA%%/templates/default/plugin_hl/x.js
+%%PHPUA%%/templates/javascript/plugin_hl/info.tpl
+%%PHPUA%%/templates/wap/plugin_hl/info.tpl
+@dirrm %%PHPUA%%/templates/wap/plugin_hl
+@dirrm %%PHPUA%%/templates/javascript/plugin_hl
+@dirrm %%PHPUA%%/templates/default/plugin_hl
+@dirrm %%PHPUA%%/plugins/plugin_hl
+@dirrm %%PHPUA%%/images/templates/wap/plugin_hl
+@dirrm %%PHPUA%%/images/templates/default/plugin_hl