aboutsummaryrefslogtreecommitdiff
path: root/games/pinball/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/pinball/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'games/pinball/Makefile')
-rw-r--r--games/pinball/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index e13b1b7e04d9..327cb1384fad 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -9,8 +9,7 @@ PORTNAME= pinball
PORTVERSION= 0.3.1
PORTREVISION= 8
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= thierry@FreeBSD.org
COMMENT= Emilia Pinball is a free pinball game
@@ -25,9 +24,9 @@ LIB_DEPENDS= alleg.42:${PORTSDIR}/devel/allegro
USE_SDL= image mixer sdl
USE_GMAKE= yes
-USE_GL= yes
+USE_GL= gl
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
@@ -35,8 +34,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
CONFIGURE_ARGS+= --with-allegro
EXTRA_LIBS= -lGL -lGLU
.endif
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include -DRZR_LIBSTATIC" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${EXTRA_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -DRZR_LIBSTATIC" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${EXTRA_LIBS}"
ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
DOCS= README