aboutsummaryrefslogtreecommitdiff
path: root/games/pinball
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-17 09:31:35 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-17 09:31:35 +0000
commit2867c8f35530fb271626f0c6e64fa96be21c6432 (patch)
treec350844f7997283855b0e084eb63a6fc655768b5 /games/pinball
parent17adfe871e2cf63139da0ff7a664a3180b8238dc (diff)
downloadports-2867c8f35530fb271626f0c6e64fa96be21c6432.tar.gz
ports-2867c8f35530fb271626f0c6e64fa96be21c6432.zip
Notes
Diffstat (limited to 'games/pinball')
-rw-r--r--games/pinball/Makefile14
-rw-r--r--games/pinball/distinfo2
-rw-r--r--games/pinball/files/patch-base::TextureUtil.cpp27
-rw-r--r--games/pinball/files/patch-configure50
-rw-r--r--games/pinball/files/patch-data::tux::ModuleTux.cpp18
-rw-r--r--games/pinball/files/patch-src::EyeBehavior.cpp16
-rw-r--r--games/pinball/files/patch-src::Loader.cpp18
-rw-r--r--games/pinball/pkg-plist159
8 files changed, 160 insertions, 144 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index d28144b4aeed..5d4c99e15217 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pinball
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,12 +14,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= thierry@pompo.net
COMMENT= Emilia Pinball is a free pinball game
-PATCH_DEPENDS= ${DOS2UNIX}:${PORTSDIR}/converters/unix2dos
.if !defined(WITH_ALLEGRO)
BUILD_DEPENDS= ${SDL_CONFIG}:${PORTSDIR}/devel/sdl12
LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
.else
+BROKEN= "support with Allegro is (temporarily) broken as of version 0.31"
BUILD_DEPENDS= ${ALLEGRO_CONFIG}:${PORTSDIR}/devel/allegro
LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
.endif
@@ -31,7 +31,7 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
.if defined(WITH_ALLEGRO)
CONFIGURE_ARGS+= --with-allegro
EXTRA_LIBS= -lGL -lGLU
@@ -41,17 +41,9 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include
SDL_CONFIG="${SDL_CONFIG}"
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
-DOS2UNIX= ${LOCALBASE}/bin/dos2unix
DOCS= README
-DOS2TR= base/Private.h
-
-post-patch:
-.for FILE in ${DOS2TR}
- @${DOS2UNIX} ${WRKSRC}/${FILE}
-.endfor
-
post-install:
@${MV} ${PREFIX}/bin/${MACHINE_ARCH}-unknown-freebsd${OSREL}-pinball \
${PREFIX}/bin/pinball
diff --git a/games/pinball/distinfo b/games/pinball/distinfo
index e15879448ca5..e7acfd816ba3 100644
--- a/games/pinball/distinfo
+++ b/games/pinball/distinfo
@@ -1 +1 @@
-MD5 (pinball-0.3.0.tar.gz) = b81a062874e541914e258ddb9c1cc941
+MD5 (pinball-0.3.1.tar.gz) = f28e8f49e0db8e9491e4d9f0c13c36c6
diff --git a/games/pinball/files/patch-base::TextureUtil.cpp b/games/pinball/files/patch-base::TextureUtil.cpp
index a8ebfcb07049..507c733c0f46 100644
--- a/games/pinball/files/patch-base::TextureUtil.cpp
+++ b/games/pinball/files/patch-base::TextureUtil.cpp
@@ -1,6 +1,6 @@
---- base/TextureUtil.cpp.orig Wed May 14 14:42:22 2003
-+++ base/TextureUtil.cpp Sun Jun 8 22:02:21 2003
-@@ -58,6 +58,7 @@
+--- ./base/TextureUtil.cpp.orig Thu Nov 20 17:46:16 2003
++++ ./base/TextureUtil.cpp Fri Dec 12 21:14:17 2003
+@@ -54,6 +54,7 @@
#if EM_USE_ALLEGRO
#include <allegro.h>
@@ -8,12 +8,15 @@
BITMAP * backbuffer = NULL;
ZBUFFER * zbuffer = NULL;
#endif // EM_USE_ALLEGRO
-@@ -92,7 +93,7 @@
- for ( i = m_hImageName.begin();
- i != m_hImageName.end();
- i++) {
-- glDeleteTextures (1, (*i).first ); //is that correct ?
-+ glDeleteTextures (1, (GLuint *) (*i).first ); //is that correct ?
- delete (*i).first ; // (*i).first = 0;
- }
- m_hImageName.erase ( m_hImageName.begin() , m_hImageName.end() );
+@@ -333,9 +334,10 @@
+ EmTexture * const texture)
+ {
+ //cout<<"+ Texture::genTexture : "<<filename<<endl;
+- *texture = 0;
+
+ #if EM_USE_SDL
++ *texture = 0;
++
+ // Load Texture
+ struct_image* image = 0;
+
diff --git a/games/pinball/files/patch-configure b/games/pinball/files/patch-configure
index 09cc573370d1..4807393a4535 100644
--- a/games/pinball/files/patch-configure
+++ b/games/pinball/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Thu May 29 06:47:26 2003
-+++ configure Thu Jun 5 22:11:02 2003
-@@ -419,7 +419,7 @@
- PACKAGE_STRING='pinball 0.3.0'
+--- configure.orig Wed Dec 10 12:34:54 2003
++++ configure Thu Dec 11 20:59:05 2003
+@@ -431,7 +431,7 @@
+ PACKAGE_STRING='pinball 0.3.1'
PACKAGE_BUGREPORT='henqvist@users.sourceforge.net'
-ac_subdirs_all="$ac_subdirs_all libltdl"
@@ -9,7 +9,7 @@
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
-@@ -1879,12 +1879,12 @@
+@@ -1954,12 +1954,12 @@
@@ -25,7 +25,7 @@
ac_ext=c
-@@ -3258,16 +3258,6 @@
+@@ -3439,18 +3439,6 @@
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
@@ -37,12 +37,14 @@
- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
- esac
- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
-- INCLTDL='-I${top_srcdir}/''libltdl'
+- LTDLINCL='-I${top_srcdir}/''libltdl'
+- # For backwards non-gettext consistent compatibility...
+- INCLTDL="$LTDLINCL"
-
# Check whether --enable-shared or --disable-shared was given.
if test "${enable_shared+set}" = set; then
enableval="$enable_shared"
-@@ -7866,7 +7856,8 @@
+@@ -8303,7 +8291,8 @@
# This can be used to rebuild libtool when needed
@@ -52,25 +54,7 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -7963,7 +7954,7 @@
- use_allegro="no"
- fi;
-
--if test x"$use_allegro" == "xno"; then
-+if test x"$use_allegro" = "xno"; then
-
-
- cat >>confdefs.h <<\_ACEOF
-@@ -9996,7 +9987,7 @@
- use_unittest="no"
- fi;
-
--if test x"$use_unittest" == "xyes"; then
-+if test x"$use_unittest" = "xyes"; then
-
-
-
-@@ -10517,14 +10508,14 @@
+@@ -11061,7 +11050,7 @@
# Check whether --with-debug or --without-debug was given.
@@ -79,17 +63,9 @@
withval="$with_debug"
use_debug="yes"
else
- use_debug="no"
- fi;
-
--if test x"$use_debug" == "xyes"; then
-+if test x"$use_debug" = "xyes"; then
-
- cat >>confdefs.h <<\_ACEOF
- #define EM_DEBUG 1
-@@ -11187,8 +11178,8 @@
- s,@ac_ct_RANLIB@,$ac_ct_RANLIB,;t t
+@@ -11788,8 +11777,8 @@
s,@CPP@,$CPP,;t t
+ s,@EGREP@,$EGREP,;t t
s,@LIBTOOL@,$LIBTOOL,;t t
-s,@INCLTDL@,$INCLTDL,;t t
-s,@LIBLTDL@,$LIBLTDL,;t t
diff --git a/games/pinball/files/patch-data::tux::ModuleTux.cpp b/games/pinball/files/patch-data::tux::ModuleTux.cpp
new file mode 100644
index 000000000000..f6d45d46493c
--- /dev/null
+++ b/games/pinball/files/patch-data::tux::ModuleTux.cpp
@@ -0,0 +1,18 @@
+--- data/tux/ModuleTux.cpp.orig Thu Nov 20 17:46:17 2003
++++ data/tux/ModuleTux.cpp Fri Dec 12 21:30:15 2003
+@@ -7,6 +7,7 @@
+ ***************************************************************************/
+
+ #include "Private.h"
++#include "Config.h"
+ #include "Behavior.h"
+ #include "Group.h"
+ #include "Pinball.h"
+@@ -15,7 +16,6 @@
+ #include "Score.h"
+ #include "Keyboard.h"
+ #include "Table.h"
+-#include "Config.h"
+
+ #define MISSION_TEXT_TIMEOUT 6000
+ #define INFO_TEXT_TIME 600
diff --git a/games/pinball/files/patch-src::EyeBehavior.cpp b/games/pinball/files/patch-src::EyeBehavior.cpp
index cf8ab2d7b6e9..53e85792c157 100644
--- a/games/pinball/files/patch-src::EyeBehavior.cpp
+++ b/games/pinball/files/patch-src::EyeBehavior.cpp
@@ -1,15 +1,15 @@
---- ./src/EyeBehavior.cpp.orig Mon May 26 08:38:02 2003
-+++ ./src/EyeBehavior.cpp Sun Jun 8 22:14:17 2003
-@@ -55,6 +55,7 @@
+--- src/EyeBehavior.cpp.orig Thu Nov 20 17:46:17 2003
++++ src/EyeBehavior.cpp Thu Dec 11 21:02:38 2003
+@@ -56,6 +56,7 @@
EmAssert(table->getBall(2) != NULL, "Ball3 group NULL");
EmAssert(this->getParent() != NULL, "Parent group NULL");
+#if EM_USE_SDL
- // short cuts for changing view F1, F2, F2, F4
- if (Keyboard::isKeyDown(SDLK_F1)) {
- Config::getInstance()->setView(0);
-@@ -65,6 +66,7 @@
- } else if (Keyboard::isKeyDown(SDLK_F4)) {
+ // shortcuts for changing view F1, F2, F2, F4 // now F5 F6 F7 F8
+ // I changed to F5 F6 F7 F8 to use the Alt+F4 quit shortcut //!rzr
+ if (Keyboard::isKeyDown(SDLK_F5)) {
+@@ -67,6 +68,7 @@
+ } else if (Keyboard::isKeyDown(SDLK_F8)) {
Config::getInstance()->setView(3);
}
+#endif
diff --git a/games/pinball/files/patch-src::Loader.cpp b/games/pinball/files/patch-src::Loader.cpp
new file mode 100644
index 000000000000..f74923316e7d
--- /dev/null
+++ b/games/pinball/files/patch-src::Loader.cpp
@@ -0,0 +1,18 @@
+--- ./src/Loader.cpp.orig Thu Nov 20 17:46:17 2003
++++ ./src/Loader.cpp Fri Dec 12 21:31:48 2003
+@@ -17,6 +17,7 @@
+ #include <iostream>
+
+ #include "Private.h"
++#include "Config.h"
+ #include "Loader.h"
+ #include "Pinball.h"
+ #include "Keyboard.h"
+@@ -39,7 +40,6 @@
+ #include "SoundUtil.h"
+ #include "Score.h"
+ #include "StdAnimation.h"
+-#include "Config.h"
+ #include "StateBehavior.h"
+ #include "Script.h"
+ #include "FakeModuleBehavior.h"
diff --git a/games/pinball/pkg-plist b/games/pinball/pkg-plist
index 3b7623a33d76..ef3e763cd000 100644
--- a/games/pinball/pkg-plist
+++ b/games/pinball/pkg-plist
@@ -1,115 +1,124 @@
bin/pinball
bin/pinball-config
-include/pinball/BigSphere.h
-include/pinball/ColorBehavior.h
-include/pinball/Cone.h
-include/pinball/Cube.h
-include/pinball/Cylinder.h
-include/pinball/Grid.h
-include/pinball/KeyBehavior.h
-include/pinball/KeyRotBehavior.h
-include/pinball/Menu.h
-include/pinball/Sphere.h
-include/pinball/StdAnimation.h
-include/pinball/TexAnimation.h
include/pinball/AlignVisitor.h
include/pinball/AllegroVisitor.h
include/pinball/AmbientLightVisitor.h
+include/pinball/ArmBehavior.h
+include/pinball/BallGroup.h
include/pinball/BaseTest.h
include/pinball/Behavior.h
include/pinball/BehaviorVisitor.h
+include/pinball/BigSphere.h
include/pinball/BillBoard.h
+include/pinball/BounceBehavior.h
+include/pinball/BumperBehavior.h
include/pinball/Camera.h
include/pinball/CollisionBounds.h
-include/pinball/Config.h
include/pinball/CollisionVisitor.h
+include/pinball/ColorBehavior.h
+include/pinball/Cone.h
+include/pinball/Config.h
+include/pinball/Cube.h
+include/pinball/Cylinder.h
include/pinball/EMath.h
include/pinball/EmFont.h
include/pinball/Engine.h
+include/pinball/EyeBehavior.h
+include/pinball/FakeModuleBehavior.h
+include/pinball/Grid.h
include/pinball/Group.h
+include/pinball/KeyBehavior.h
+include/pinball/KeyRotBehavior.h
include/pinball/Keyboard.h
include/pinball/Light.h
+include/pinball/Loader.h
+include/pinball/LoaderModule.h
+include/pinball/Menu.h
include/pinball/Node.h
+include/pinball/Obj3dsUtil.h
include/pinball/OctTree.h
include/pinball/OpenGLVisitor.h
+include/pinball/Pinball.h
+include/pinball/PlungerBehavior.h
include/pinball/PointLightVisitor.h
include/pinball/Polygon.h
include/pinball/Private.h
include/pinball/Profiler.h
+include/pinball/Score.h
+include/pinball/Script.h
include/pinball/Shape3D.h
include/pinball/SignalSender.h
include/pinball/Sound.h
include/pinball/SoundUtil.h
include/pinball/SoundVisitor.h
+include/pinball/Sphere.h
+include/pinball/SrcTest.h
+include/pinball/StateBehavior.h
include/pinball/StateMachine.h
+include/pinball/StdAnimation.h
+include/pinball/Table.h
+include/pinball/TexAnimation.h
include/pinball/TextureUtil.h
include/pinball/TransformVisitor.h
include/pinball/Visitor.h
-include/pinball/ArmBehavior.h
-include/pinball/BallGroup.h
-include/pinball/BounceBehavior.h
-include/pinball/BumperBehavior.h
-include/pinball/EyeBehavior.h
-include/pinball/FakeModuleBehavior.h
-include/pinball/LoaderModule.h
-include/pinball/Loader.h
-include/pinball/Obj3dsUtil.h
-include/pinball/Pinball.h
-include/pinball/PlungerBehavior.h
-include/pinball/Score.h
-include/pinball/Script.h
-include/pinball/SrcTest.h
-include/pinball/StateBehavior.h
-include/pinball/Table.h
include/pinball/pinconfig.h
+lib/pinball/libModuleProfessor.a
+lib/pinball/libModuleProfessor.so
+lib/pinball/libModuleProfessor.so.0
+lib/pinball/libModuleTest.a
+lib/pinball/libModuleTest.so
+lib/pinball/libModuleTest.so.0
+lib/pinball/libModuleTux.a
+lib/pinball/libModuleTux.so
+lib/pinball/libModuleTux.so.0
lib/pinball/libemilia_addon.a
lib/pinball/libemilia_base.a
-lib/pinball/libModuleTux.so.0
-lib/pinball/libModuleTux.so
-lib/pinball/libModuleTux.a
-lib/pinball/libModuleProfessor.so.0
-lib/pinball/libModuleProfessor.so
-lib/pinball/libModuleProfessor.a
lib/pinball/libemilia_pin.a
-lib/pinball/libModuleTest.so.0
-lib/pinball/libModuleTest.so
-lib/pinball/libModuleTest.a
-%%PORTDOCS%%share/doc/pinball/README
-share/pinball/tux/bumphard.wav
-share/pinball/tux/bumpsoft.wav
-share/pinball/tux/bump.wav
-share/pinball/tux/face.png
-share/pinball/tux/face.png.pcx
-share/pinball/tux/flip.wav
-share/pinball/tux/floor2.png
-share/pinball/tux/floor2.png.pcx
-share/pinball/tux/game.mid
-share/pinball/tux/gameover.wav
-share/pinball/tux/intro.mid
-share/pinball/tux/lock.wav
-share/pinball/tux/loop.wav
-share/pinball/tux/floor.pbl
-share/pinball/tux/multiball.mid
-share/pinball/tux/nudge.wav
-share/pinball/tux/opentux.wav
-share/pinball/tux/pinball.pbl
-share/pinball/tux/shoot.wav
-share/pinball/tux/tiles.png
-share/pinball/tux/tiles.png.pcx
-share/pinball/tux/up.wav
-share/pinball/professor/floor.png
-share/pinball/professor/floor.png.pcx
-share/pinball/professor/pinball.pbl
-share/pinball/professor/professor.mid
-share/pinball/professor/professor.png
-share/pinball/font_34.png
-share/pinball/font_35.pcx
-share/pinball/pinball.xpm
-share/pinball/splash.png
-share/pinball/splash.png.pcx
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/font_34.png
+%%DATADIR%%/font_35.pcx
+%%DATADIR%%/pinball.xpm
+%%DATADIR%%/professor/bump.wav
+%%DATADIR%%/professor/bumphard.wav
+%%DATADIR%%/professor/bumpsoft.wav
+%%DATADIR%%/professor/flip.wav
+%%DATADIR%%/professor/floor.png
+%%DATADIR%%/professor/floor.png.pcx
+%%DATADIR%%/professor/gameover.wav
+%%DATADIR%%/professor/introp.ogg
+%%DATADIR%%/professor/nudge.wav
+%%DATADIR%%/professor/pinball.pbl
+%%DATADIR%%/professor/professor.ogg
+%%DATADIR%%/professor/professor.png
+%%DATADIR%%/splash.png
+%%DATADIR%%/splash.png.pcx
+%%DATADIR%%/tux/bump.wav
+%%DATADIR%%/tux/bumphard.wav
+%%DATADIR%%/tux/bumpsoft.wav
+%%DATADIR%%/tux/face.png.pcx
+%%DATADIR%%/tux/face2.png
+%%DATADIR%%/tux/flip.wav
+%%DATADIR%%/tux/floor.pbl
+%%DATADIR%%/tux/floor2.png
+%%DATADIR%%/tux/floor2.png.pcx
+%%DATADIR%%/tux/floor3.png
+%%DATADIR%%/tux/game.ogg
+%%DATADIR%%/tux/gameover.wav
+%%DATADIR%%/tux/intro.mid
+%%DATADIR%%/tux/intro.ogg
+%%DATADIR%%/tux/lock.wav
+%%DATADIR%%/tux/loop.wav
+%%DATADIR%%/tux/multiball.ogg
+%%DATADIR%%/tux/nudge.wav
+%%DATADIR%%/tux/opentux.wav
+%%DATADIR%%/tux/pinball.pbl
+%%DATADIR%%/tux/shoot.wav
+%%DATADIR%%/tux/tiles.png
+%%DATADIR%%/tux/tiles.png.pcx
+%%DATADIR%%/tux/up.wav
@dirrm include/pinball
@dirrm lib/pinball
-%%PORTDOCS%%@dirrm share/doc/pinball
-@dirrm share/pinball/tux
-@dirrm share/pinball/professor
-@dirrm share/pinball
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/tux
+@dirrm %%DATADIR%%/professor
+@dirrm %%DATADIR%%