aboutsummaryrefslogtreecommitdiff
path: root/games/pingus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-06 06:42:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-06 06:42:55 +0000
commite8073f33bc52b7e44d5099701bff6d9712cc3729 (patch)
treed6e20c4700e435a1ee4996f966a7d5ce224a0a21 /games/pingus
parentef978159f3cd6d7f906918e4efd75c08af0a7f96 (diff)
Notes
Diffstat (limited to 'games/pingus')
-rw-r--r--games/pingus/Makefile46
-rw-r--r--games/pingus/distinfo3
-rw-r--r--games/pingus/files/patch-SConstruct13
-rw-r--r--games/pingus/files/patch-src-tinygettext_iconv.cpp11
-rw-r--r--games/pingus/files/pkg-message.in12
-rw-r--r--games/pingus/pkg-descr5
6 files changed, 90 insertions, 0 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
new file mode 100644
index 000000000000..a8f98322e774
--- /dev/null
+++ b/games/pingus/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: pingus
+# Date created: 2007-10-05
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pingus
+PORTVERSION= 0.7.1
+CATEGORIES= games
+MASTER_SITES= http://pingus.seul.org/files/
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Lemmings-like game
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ boost_regex.4:${PORTSDIR}/devel/boost \
+ physfs-1.0.1:${PORTSDIR}/devel/physfs
+
+USE_BZIP2= yes
+USE_ICONV= yes
+USE_SCONS= yes
+USE_SDL= sdl image mixer
+
+PLIST= ${WRKDIR}/pkg-plist
+SUB_FILES= pkg-message
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/pingus/distinfo b/games/pingus/distinfo
new file mode 100644
index 000000000000..5768e92f76cf
--- /dev/null
+++ b/games/pingus/distinfo
@@ -0,0 +1,3 @@
+MD5 (pingus-0.7.1.tar.bz2) = b4fcf66d0dc5e1d6148447988f87d3b1
+SHA256 (pingus-0.7.1.tar.bz2) = 90772f82bc1b9655541feb6471573fcbe375a633a858fcf5798ad8160ae89fb5
+SIZE (pingus-0.7.1.tar.bz2) = 10648862
diff --git a/games/pingus/files/patch-SConstruct b/games/pingus/files/patch-SConstruct
new file mode 100644
index 000000000000..54bc2acce18c
--- /dev/null
+++ b/games/pingus/files/patch-SConstruct
@@ -0,0 +1,13 @@
+--- SConstruct.orig 2007-10-05 10:46:32.000000000 -0500
++++ SConstruct 2007-10-05 11:09:38.000000000 -0500
+@@ -337,7 +337,9 @@
+ if os.environ.has_key('PKG_CONFIG_PATH'):
+ env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
+
+- env['CPPPATH'] += ['.', 'src/']
++
++ env['CPPPATH'] = Split(env['CPPPATH'])
++ env['LIBPATH'] = Split(env['LIBPATH'])
+
+ config_h_defines = []
+
diff --git a/games/pingus/files/patch-src-tinygettext_iconv.cpp b/games/pingus/files/patch-src-tinygettext_iconv.cpp
new file mode 100644
index 000000000000..d1017aaa549f
--- /dev/null
+++ b/games/pingus/files/patch-src-tinygettext_iconv.cpp
@@ -0,0 +1,11 @@
+--- src/tinygettext/iconv.cpp 2007-10-05 11:17:23.000000000 -0500
++++ src/tinygettext/iconv.cpp 2007-10-05 11:17:35.000000000 -0500
+@@ -78,7 +78,7 @@
+ size_t in_size = text.size();
+ size_t out_size = 4*in_size; // Worst case scenario: ASCII -> UTF-32?
+ std::string result(out_size, ' ');
+- ICONV_CONST char* in_str = &text[0];
++ const char* in_str = &text[0];
+ char* out_str = &result[0];
+
+ // Try to convert the text.
diff --git a/games/pingus/files/pkg-message.in b/games/pingus/files/pkg-message.in
new file mode 100644
index 000000000000..dfb75ed5d2cf
--- /dev/null
+++ b/games/pingus/files/pkg-message.in
@@ -0,0 +1,12 @@
+###############################################################################
+
+The Pingus game was installed
+
+1) Use the --datadir option to the correct path of pingus data
+
+ # pingus --datadir %%DATADIR%%
+
+2) Enjoy it
+
+###############################################################################
+
diff --git a/games/pingus/pkg-descr b/games/pingus/pkg-descr
new file mode 100644
index 000000000000..4c813635cda2
--- /dev/null
+++ b/games/pingus/pkg-descr
@@ -0,0 +1,5 @@
+Pingus is a free Lemmings-like game covered under the GNU GPL. It features
+currently 22 playable levels and runs under a wide variety of operating systems
+(FreeBSD, Linux, Windows, etc.)
+
+WWW: http://pingus.seul.org/