aboutsummaryrefslogtreecommitdiff
path: root/games/pioneer/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-10 11:17:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-10 11:17:38 +0000
commit5580f8029cc58e3a5996441e612ef6431afd804e (patch)
tree314a8a801e06ae18a838d9e2806fabc3d91231f2 /games/pioneer/Makefile
parent09ef9b523b8322e308898908d09fed2db9fa30b5 (diff)
downloadports-5580f8029cc58e3a5996441e612ef6431afd804e.tar.gz
ports-5580f8029cc58e3a5996441e612ef6431afd804e.zip
Notes
Diffstat (limited to 'games/pioneer/Makefile')
-rw-r--r--games/pioneer/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index a21673595378..08e66b96a04b 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pioneer
-PORTVERSION= 0.0.${GH_TAGNAME}
-PORTREVISION= 1
+DISTVERSION= 0.0.${GH_TAGNAME}
CATEGORIES= games
MAINTAINER= lightside@gmx.com
@@ -35,11 +34,9 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libassimp.so:multimedia/assimp
USES= autoreconf compiler:c++11-lib gmake pkgconfig
-
USE_GITHUB= yes
GH_ACCOUNT= pioneerspacesim
-GH_TAGNAME= 20171001
-
+GH_TAGNAME= 20180203
USE_GL= gl
USE_SDL= image2 sdl2
@@ -62,9 +59,8 @@ SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS MODELCOMPILER NOGPUJOBS PROFILER SERVERAGENT
OPTIONS_DEFAULT= MODELCOMPILER
-DOCS_SUB_LIST= QUICKSTART_PATH="${DOCSDIR}"
-DOCS_SUB_LIST_OFF= \
- QUICKSTART_PATH="https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}"
+DOCS_SUB_LIST= QUICKSTART_PATH="${DOCSDIR}"
+DOCS_SUB_LIST_OFF= QUICKSTART_PATH="https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}"
MODELCOMPILER_DESC= Build/install modelcompiler tool
MODELCOMPILER_PLIST_FILES= bin/${PORTNAME}-modelcompiler
NOGPUJOBS_DESC= Disable EnableGPUJobs for config.ini by default