aboutsummaryrefslogtreecommitdiff
path: root/games/pipenightdreams
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2003-02-10 13:26:24 +0000
committerMark Pulford <markp@FreeBSD.org>2003-02-10 13:26:24 +0000
commit42540ee9b95a9dd61d47d75433f004000b5cc9f8 (patch)
treed99051deec66bcc3228d0e82f60b956025aa3570 /games/pipenightdreams
parent8e73e0336eef42d29488d9cf78b39b921f2edf69 (diff)
downloadports-42540ee9b95a9dd61d47d75433f004000b5cc9f8.tar.gz
ports-42540ee9b95a9dd61d47d75433f004000b5cc9f8.zip
Notes
Diffstat (limited to 'games/pipenightdreams')
-rw-r--r--games/pipenightdreams/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/pipenightdreams/Makefile b/games/pipenightdreams/Makefile
index 027276eccb0d..8b5cb4d2b09c 100644
--- a/games/pipenightdreams/Makefile
+++ b/games/pipenightdreams/Makefile
@@ -19,16 +19,18 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
+USE_REINPLACE= yes
MAN6= pipenightdreams.6
-pre-patch:
- @${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g; \
+post-patch:
+ ${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g; \
s|SDL_LIBSS|SDL_LIBS|g; s|datadir/games|datadir|;' \
${WRKSRC}/configure
- @find ${WRKSRC} -name Makefile.in | \
- xargs ${PERL} -pi -e 's|/games/|/|g; \
+ ${FIND} ${WRKSRC} -name Makefile.in | \
+ ${XARGS} ${REINPLACE_CMD} 's|/games/|/|g; \
s/^pipenightdreams_LDADD.+//g;'
- @${PERL} -pi -e "s|/usr/share/games|${LOCALBASE}/share|g" ${WRKSRC}/src/main.cpp
+ ${REINPLACE_CMD} "s|/usr/share/games|${LOCALBASE}/share|g" \
+ ${WRKSRC}/src/main.cpp
.include <bsd.port.mk>