aboutsummaryrefslogtreecommitdiff
path: root/games/plee-the-bear
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:30:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:30:48 +0000
commitb26f95bb8318c1a3c0a69ae0f0135d42b5013dfd (patch)
tree9fc14b5525ea303df23b19b0c216d4b78f846de9 /games/plee-the-bear
parentdf3e0ace6af777817df6426cae08de4587fa20ca (diff)
downloadports-b26f95bb8318c1a3c0a69ae0f0135d42b5013dfd.tar.gz
ports-b26f95bb8318c1a3c0a69ae0f0135d42b5013dfd.zip
Notes
Diffstat (limited to 'games/plee-the-bear')
-rw-r--r--games/plee-the-bear/Makefile37
-rw-r--r--games/plee-the-bear/distinfo3
-rw-r--r--games/plee-the-bear/pkg-descr6
-rw-r--r--games/plee-the-bear/pkg-plist163
4 files changed, 209 insertions, 0 deletions
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
new file mode 100644
index 000000000000..33a67e67e55c
--- /dev/null
+++ b/games/plee-the-bear/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: plee-the-bear
+# Date created: 28 Mar 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plee-the-bear
+PORTVERSION= 0.2.1
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-light
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= 2D platform jump and run game
+
+LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/bin/claw-config:${PORTSDIR}/devel/libclaw
+RUN_DEPENDS= ${LOCALBASE}/bin/claw-config:${PORTSDIR}/devel/libclaw
+
+USE_BZIP2= yes
+USE_SDL= sdl mixer
+USE_GL= gl glu
+WANT_GNOME= yes
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+
+USE_CMAKE= yes
+CMAKE_ARGS= -DCMAKE_MODULE_PATH="${LOCALBASE}/lib/claw/"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"stats.dat"|get_custom_game_file(&).c_str()| ' \
+ ${WRKSRC}/dev/bear_engine/src/core/engine/code/game.cpp
+
+.include <bsd.port.mk>
diff --git a/games/plee-the-bear/distinfo b/games/plee-the-bear/distinfo
new file mode 100644
index 000000000000..33f8e58233c7
--- /dev/null
+++ b/games/plee-the-bear/distinfo
@@ -0,0 +1,3 @@
+MD5 (plee-the-bear-0.2.1-light.tar.bz2) = b7530ca6d0cfcd1ce391dcb7307a8ad3
+SHA256 (plee-the-bear-0.2.1-light.tar.bz2) = b5e4f21dadd6c42b2ea7ff934ccae0767c49818062c0cc63a4dcdeb914e02ae2
+SIZE (plee-the-bear-0.2.1-light.tar.bz2) = 8179245
diff --git a/games/plee-the-bear/pkg-descr b/games/plee-the-bear/pkg-descr
new file mode 100644
index 000000000000..dc4198be88a3
--- /dev/null
+++ b/games/plee-the-bear/pkg-descr
@@ -0,0 +1,6 @@
+Plee The Bear will be a 2D platform jump and run game, as fun as
+the best platform games of the 90's (the golden age of this kind
+of games). You're a bear, trying to catch his son, which ran away
+after he ate all your honey.
+
+WWW: http://plee-the-bear.sourceforge.net/
diff --git a/games/plee-the-bear/pkg-plist b/games/plee-the-bear/pkg-plist
new file mode 100644
index 000000000000..997cb700694d
--- /dev/null
+++ b/games/plee-the-bear/pkg-plist
@@ -0,0 +1,163 @@
+bin/plee-the-bear
+bin/running-bear
+lib/libbear_audio.so
+lib/libbear_communication.so
+lib/libbear_engine.so
+lib/libbear_generic_items.so
+lib/libbear_gui.so
+lib/libbear_input.so
+lib/libbear_text.so
+lib/libbear_time.so
+lib/libbear_universe.so
+lib/libbear_visual.so
+lib/plee-the-bear/libplee_the_bear.so
+share/applications/plee-the-bear.desktop
+share/icons/hicolor/128x128/apps/ptb.png
+share/icons/hicolor/16x16/apps/ptb.png
+share/icons/hicolor/24x24/apps/ptb.png
+share/icons/hicolor/32x32/apps/ptb.png
+share/icons/hicolor/48x48/apps/ptb.png
+share/icons/hicolor/64x64/apps/ptb.png
+share/menu/plee-the-bear
+share/pixmaps/ptb.png
+share/pixmaps/ptb.xpm
+%%DATADIR%%/font/fixed_red-14x28.png
+%%DATADIR%%/font/fixed_white-7x12.tga
+%%DATADIR%%/font/fixed_yellow-10x20.png
+%%DATADIR%%/font/fixed_yellow-14x28.png
+%%DATADIR%%/font/fixed_yellow-19x39.tga
+%%DATADIR%%/font/level_name-42x50.png
+%%DATADIR%%/font/speech-10x14.png
+%%DATADIR%%/game_description
+%%DATADIR%%/gfx/balloon.png
+%%DATADIR%%/gfx/color/black.png
+%%DATADIR%%/gfx/color/darkred.png
+%%DATADIR%%/gfx/demo/demo00.png
+%%DATADIR%%/gfx/demo/demo01.png
+%%DATADIR%%/gfx/demo/demo02.png
+%%DATADIR%%/gfx/demo/demo03.png
+%%DATADIR%%/gfx/demo/demo04.png
+%%DATADIR%%/gfx/demo/demo05.png
+%%DATADIR%%/gfx/demo/demo06.png
+%%DATADIR%%/gfx/demo/demo07.png
+%%DATADIR%%/gfx/demo/demo08.png
+%%DATADIR%%/gfx/demo/demo09.png
+%%DATADIR%%/gfx/demo/demo10.png
+%%DATADIR%%/gfx/demo/demo11.png
+%%DATADIR%%/gfx/flag/default.png
+%%DATADIR%%/gfx/flag/english.png
+%%DATADIR%%/gfx/flag/francais.png
+%%DATADIR%%/gfx/forest/bk/bk_00.png
+%%DATADIR%%/gfx/forest/bk/bk_01.png
+%%DATADIR%%/gfx/forest/bk/bk_02.png
+%%DATADIR%%/gfx/forest/bk/bk_03.png
+%%DATADIR%%/gfx/forest/bk/bk_04.png
+%%DATADIR%%/gfx/forest/bk/bk_05.png
+%%DATADIR%%/gfx/forest/bk/bk_06.png
+%%DATADIR%%/gfx/forest/bk/bk_07.png
+%%DATADIR%%/gfx/forest/bk/bk_08.png
+%%DATADIR%%/gfx/forest/bk/bk_09.png
+%%DATADIR%%/gfx/forest/bk/bk_10.png
+%%DATADIR%%/gfx/forest/bk/bk_11.png
+%%DATADIR%%/gfx/forest/bk/bk_12.png
+%%DATADIR%%/gfx/forest/bk/bk_13.png
+%%DATADIR%%/gfx/forest/bk/bk_14.png
+%%DATADIR%%/gfx/forest/bk/bk_15.png
+%%DATADIR%%/gfx/forest/bk/bk_16.png
+%%DATADIR%%/gfx/forest/bk/bk_17.png
+%%DATADIR%%/gfx/forest/bk/bk_18.png
+%%DATADIR%%/gfx/forest/bk/bk_19.png
+%%DATADIR%%/gfx/forest/bridge.png
+%%DATADIR%%/gfx/forest/end-notice.tga
+%%DATADIR%%/gfx/forest/ground-ceiling.png
+%%DATADIR%%/gfx/forest/hollow-trunk.png
+%%DATADIR%%/gfx/forest/platform.png
+%%DATADIR%%/gfx/forest/tree_1.png
+%%DATADIR%%/gfx/forest/tree_2.png
+%%DATADIR%%/gfx/forest/tree_3.png
+%%DATADIR%%/gfx/forest/tree_4.png
+%%DATADIR%%/gfx/forest/wall-corner.png
+%%DATADIR%%/gfx/forest/wall-fill.png
+%%DATADIR%%/gfx/forest/wasp/sting.tga
+%%DATADIR%%/gfx/forest/wasp/wasp-shooting-1.png
+%%DATADIR%%/gfx/forest/wasp/wasp-shooting-2.png
+%%DATADIR%%/gfx/forest/wasp/wasp-shooting-3.png
+%%DATADIR%%/gfx/forest/wasp/wasp.png
+%%DATADIR%%/gfx/frame.tga
+%%DATADIR%%/gfx/gamned.png
+%%DATADIR%%/gfx/headstone.png
+%%DATADIR%%/gfx/info-board.png
+%%DATADIR%%/gfx/plee/halo.png
+%%DATADIR%%/gfx/plee/plee-1.png
+%%DATADIR%%/gfx/plee/plee-2.png
+%%DATADIR%%/gfx/splash.png
+%%DATADIR%%/gfx/status.tga
+%%DATADIR%%/gfx/stone.tga
+%%DATADIR%%/gfx/thumb/tutorial.png
+%%DATADIR%%/gfx/title_screen/background_00.png
+%%DATADIR%%/gfx/title_screen/background_01.png
+%%DATADIR%%/gfx/title_screen/background_02.png
+%%DATADIR%%/gfx/title_screen/background_03.png
+%%DATADIR%%/gfx/title_screen/background_04.png
+%%DATADIR%%/gfx/title_screen/background_05.png
+%%DATADIR%%/gfx/title_screen/background_06.png
+%%DATADIR%%/gfx/title_screen/background_07.png
+%%DATADIR%%/gfx/title_screen/background_08.png
+%%DATADIR%%/gfx/title_screen/background_09.png
+%%DATADIR%%/gfx/title_screen/background_10.png
+%%DATADIR%%/gfx/title_screen/background_11.png
+%%DATADIR%%/gfx/water.tga
+%%DATADIR%%/lang/english.lng
+%%DATADIR%%/lang/francais.lng
+%%DATADIR%%/lang/list.txt
+%%DATADIR%%/level/demo.cl
+%%DATADIR%%/level/gamned.cl
+%%DATADIR%%/level/title_screen.cl
+%%DATADIR%%/level/tutorial.cl
+%%DATADIR%%/model/headstone.cm
+%%DATADIR%%/model/player_1.cm
+%%DATADIR%%/model/player_2.cm
+%%DATADIR%%/model/sting.cm
+%%DATADIR%%/model/stone.cm
+%%DATADIR%%/model/wasp.cm
+%%DATADIR%%/music/castle-1.ogg
+%%DATADIR%%/music/forest-1.ogg
+%%DATADIR%%/sound/grr.wav
+%%DATADIR%%/sound/jump.ogg
+%%DATADIR%%/sound/splash1.ogg
+%%DATADIR%%/sound/splash2.ogg
+%%DATADIR%%/sound/sting.ogg
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/model
+@dirrm %%DATADIR%%/level
+@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%/gfx/title_screen
+@dirrm %%DATADIR%%/gfx/thumb
+@dirrm %%DATADIR%%/gfx/plee
+@dirrm %%DATADIR%%/gfx/forest/wasp
+@dirrm %%DATADIR%%/gfx/forest/bk
+@dirrm %%DATADIR%%/gfx/forest
+@dirrm %%DATADIR%%/gfx/flag
+@dirrm %%DATADIR%%/gfx/demo
+@dirrm %%DATADIR%%/gfx/color
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/font
+@dirrm %%DATADIR%%
+@dirrmtry share/menu
+@dirrm share/icons/hicolor/64x64/apps
+@dirrm share/icons/hicolor/64x64
+@dirrm share/icons/hicolor/48x48/apps
+@dirrm share/icons/hicolor/48x48
+@dirrm share/icons/hicolor/32x32/apps
+@dirrm share/icons/hicolor/32x32
+@dirrm share/icons/hicolor/24x24/apps
+@dirrm share/icons/hicolor/24x24
+@dirrm share/icons/hicolor/16x16/apps
+@dirrm share/icons/hicolor/16x16
+@dirrm share/icons/hicolor/128x128/apps
+@dirrm share/icons/hicolor/128x128
+@dirrm share/icons/hicolor
+@dirrm share/icons
+@dirrmtry share/applications
+@dirrm lib/plee-the-bear