aboutsummaryrefslogtreecommitdiff
path: root/games/plutocracy
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/plutocracy
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'games/plutocracy')
-rw-r--r--games/plutocracy/Makefile4
-rw-r--r--games/plutocracy/files/patch-r_surface.c20
2 files changed, 23 insertions, 1 deletions
diff --git a/games/plutocracy/Makefile b/games/plutocracy/Makefile
index 7d60a409b670..14d57869dc98 100644
--- a/games/plutocracy/Makefile
+++ b/games/plutocracy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= plutocracy
PORTVERSION= 0.0.20081229
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
@@ -16,6 +16,8 @@ COMMENT= Multiplayer 3D economy/trade-based RTS
LICENSE= GPLv2
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+
USE_BZIP2= yes
USE_SDL= sdl pango
USE_GL= gl glu
diff --git a/games/plutocracy/files/patch-r_surface.c b/games/plutocracy/files/patch-r_surface.c
new file mode 100644
index 000000000000..c11b0240c375
--- /dev/null
+++ b/games/plutocracy/files/patch-r_surface.c
@@ -0,0 +1,20 @@
+--- src/render/r_surface.c.orig 2008-12-26 20:15:17.000000000 +0100
++++ src/render/r_surface.c 2012-05-09 12:14:42.000000000 +0200
+@@ -269,7 +269,7 @@
+ png_set_read_fn(png_ptr, (voidp)&file, (png_rw_ptr)user_png_read);
+
+ /* If an error occurs in libpng, it will longjmp back here */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ C_warning("Error loading PNG '%s'", filename);
+ goto cleanup;
+ }
+@@ -397,7 +397,7 @@
+ (png_flush_ptr)user_png_flush);
+
+ /* If an error occurs in libpng, it will longjmp back here */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ C_warning("Error saving PNG '%s'", filename);
+ goto cleanup;
+ }