aboutsummaryrefslogtreecommitdiff
path: root/games/pmars/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-02 04:10:14 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-02 04:10:14 +0000
commit6a42820fe3c9c577973e68c300de2910995c8cc9 (patch)
treeaa80804728d4c270125908666641f2f6fea1a273 /games/pmars/Makefile
parentaf02358e3ddae2c07a2d37de54baea60bdaae792 (diff)
downloadports-6a42820fe3c9c577973e68c300de2910995c8cc9.tar.gz
ports-6a42820fe3c9c577973e68c300de2910995c8cc9.zip
Notes
Diffstat (limited to 'games/pmars/Makefile')
-rw-r--r--games/pmars/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/games/pmars/Makefile b/games/pmars/Makefile
new file mode 100644
index 000000000000..80919c38cecb
--- /dev/null
+++ b/games/pmars/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: games/pmars
+# Version required: pmars v0.8
+# Date created: 15 Feb 1999
+# Whom: gmarco@scotty.masternet.it
+#
+# $Id$
+#
+
+DISTNAME= pmars08s
+PKGNAME= pmars-0.8
+CATEGORIES= games
+MASTER_SITES= http://www.koth.org/pmars/ \
+ http://www.giovannelli.it/~gmarco/files/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= freebsd@scotty.masternet.it
+
+USE_XLIB= yes
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile
+MAN6= pmars.6
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/games
+ @${MKDIR} ${PREFIX}/share/games/corewars
+ @${INSTALL_PROGRAM} ${WRKSRC}/pmars ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/pmars.6 ${PREFIX}/man/man6
+ @${INSTALL_DATA} ${WRKSRC}/*.red ${PREFIX}/share/games/corewars
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/games/corewars
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can try something like :"
+ @${ECHO_MSG} "pmars -v 603 ${PREFIX}/share/games/corewars/rave.red ${PREFIX}/share/games/corewars/aeka.red"
+ @${ECHO_MSG} "to see how the simulator works (rave.red and aeka.red are two sample warriors)"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Some other warriors are installed in : ${PREFIX}/share/games/corewars"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Plase read also ${PREFIX}/share/games/corewars/README file for more infos"
+ @${ECHO_MSG} "on corewars and on the current version of pmars"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>