aboutsummaryrefslogtreecommitdiff
path: root/games/pmars
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-02 04:10:14 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-02 04:10:14 +0000
commit6a42820fe3c9c577973e68c300de2910995c8cc9 (patch)
treeaa80804728d4c270125908666641f2f6fea1a273 /games/pmars
parentaf02358e3ddae2c07a2d37de54baea60bdaae792 (diff)
downloadports-6a42820fe3c9c577973e68c300de2910995c8cc9.tar.gz
ports-6a42820fe3c9c577973e68c300de2910995c8cc9.zip
Notes
Diffstat (limited to 'games/pmars')
-rw-r--r--games/pmars/Makefile41
-rw-r--r--games/pmars/distinfo1
-rw-r--r--games/pmars/files/patch-aa25
-rw-r--r--games/pmars/pkg-comment1
-rw-r--r--games/pmars/pkg-descr18
-rw-r--r--games/pmars/pkg-plist8
6 files changed, 94 insertions, 0 deletions
diff --git a/games/pmars/Makefile b/games/pmars/Makefile
new file mode 100644
index 000000000000..80919c38cecb
--- /dev/null
+++ b/games/pmars/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: games/pmars
+# Version required: pmars v0.8
+# Date created: 15 Feb 1999
+# Whom: gmarco@scotty.masternet.it
+#
+# $Id$
+#
+
+DISTNAME= pmars08s
+PKGNAME= pmars-0.8
+CATEGORIES= games
+MASTER_SITES= http://www.koth.org/pmars/ \
+ http://www.giovannelli.it/~gmarco/files/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= freebsd@scotty.masternet.it
+
+USE_XLIB= yes
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile
+MAN6= pmars.6
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/games
+ @${MKDIR} ${PREFIX}/share/games/corewars
+ @${INSTALL_PROGRAM} ${WRKSRC}/pmars ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/pmars.6 ${PREFIX}/man/man6
+ @${INSTALL_DATA} ${WRKSRC}/*.red ${PREFIX}/share/games/corewars
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/games/corewars
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can try something like :"
+ @${ECHO_MSG} "pmars -v 603 ${PREFIX}/share/games/corewars/rave.red ${PREFIX}/share/games/corewars/aeka.red"
+ @${ECHO_MSG} "to see how the simulator works (rave.red and aeka.red are two sample warriors)"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Some other warriors are installed in : ${PREFIX}/share/games/corewars"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Plase read also ${PREFIX}/share/games/corewars/README file for more infos"
+ @${ECHO_MSG} "on corewars and on the current version of pmars"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/games/pmars/distinfo b/games/pmars/distinfo
new file mode 100644
index 000000000000..54e4578cf450
--- /dev/null
+++ b/games/pmars/distinfo
@@ -0,0 +1 @@
+MD5 (pmars08s.tar.Z) = ad1869ea0a388f5c5070c4cd33b09d25
diff --git a/games/pmars/files/patch-aa b/games/pmars/files/patch-aa
new file mode 100644
index 000000000000..e78137733e4e
--- /dev/null
+++ b/games/pmars/files/patch-aa
@@ -0,0 +1,25 @@
+--- makefile.orig Mon Feb 15 17:07:29 1999
++++ makefile Mon Feb 15 17:07:39 1999
+@@ -15,11 +15,11 @@
+ # (5) -DSMALLMEM 16-bit addresses, less memory
+ # (6) -DXWINGRAPHX 1 X-Windows graphics (UNIX)
+
+-CFLAGS = -O -DEXT94
++CFLAGS = -O -I/usr/X11R6/include -DEXT94 -DGRAPHX -DXWINGRAPHX
+ LFLAGS = -x
+ LIB = -lcurses -ltermlib # enable this one for curses display
+ # LIB = -lvgagl -lvga # enable this one for Linux/SVGA
+-# LIB = -lX11 # enable this one for X11
++LIB = -L/usr/X11R6/lib -lX11 # enable this one for X11
+
+ .SUFFIXES: .o .c .c~ .man .doc .6
+ MAINFILE = pmars
+@@ -30,7 +30,7 @@
+ OBJ2 = clparse.o global.o token.o
+ OBJ3 = str_eng.o
+
+-ALL: flags $(MAINFILE) man doc
++all: flags $(MAINFILE) man doc
+
+ flags:
+ @echo Making $(MAINFILE) with compiler flags $(CFLAGS)
diff --git a/games/pmars/pkg-comment b/games/pmars/pkg-comment
new file mode 100644
index 000000000000..834b800cb47d
--- /dev/null
+++ b/games/pmars/pkg-comment
@@ -0,0 +1 @@
+A portable corewar system with ICWS'94 extensions.
diff --git a/games/pmars/pkg-descr b/games/pmars/pkg-descr
new file mode 100644
index 000000000000..a736bdb5743c
--- /dev/null
+++ b/games/pmars/pkg-descr
@@ -0,0 +1,18 @@
+pMARS (portable Memory Array Redcode Simulator) is a corewar
+interpreter with multi-platform support.
+pMARS implements the ICWS'94 draft standard, but can also be
+used in ICWS'88 mode.
+The base system includes a graphical core display for UNIX (curses,
+X11 and Linux svgalib), PC/DOS, and the Mac.
+A line-oriented debugger is included to help in writing warriors.
+
+Contributors:
+ * Albert Ma (ama@mit.edu)
+ * Na'ndor Sieben (sieben@imap1.asu.edu)
+ * Stefan Strack (stst@vuse.vanderbilt.edu)
+ * Mintardjo Wangsawidjaja (wangsawm@kira.csos.orst.edu)
+
+distfile: pmars08s.tar.Z (about 220kb)
+home page: http://www.koth.org/pmars
+
+- ported to FreeBSD by Gianmarco (gmarco@giovannelli.it)
diff --git a/games/pmars/pkg-plist b/games/pmars/pkg-plist
new file mode 100644
index 000000000000..050e17cb9689
--- /dev/null
+++ b/games/pmars/pkg-plist
@@ -0,0 +1,8 @@
+bin/pmars
+share/games/corewars/aeka.red
+share/games/corewars/pspace.red
+share/games/corewars/validate.red
+share/games/corewars/rave.red
+share/games/corewars/flashpaper.red
+share/games/corewars/README
+@dirrm share/games/corewars