aboutsummaryrefslogtreecommitdiff
path: root/games/pokerth
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-04-21 16:22:44 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-04-21 16:22:44 +0000
commit07661a758702bcdbaed581fb6ce6eb1110bdfffd (patch)
tree8fdf3c4571071185197d7b65cdadb8dbd339289a /games/pokerth
parent6cdcfd3606b5ad5de3eb9a29e73c3257432676a4 (diff)
Update to 1.0.1
Feature safe: yes
Notes
Notes: svn path=/head/; revision=316186
Diffstat (limited to 'games/pokerth')
-rw-r--r--games/pokerth/Makefile5
-rw-r--r--games/pokerth/distinfo4
-rw-r--r--games/pokerth/files/patch-src_net_common_ircthread.cpp18
3 files changed, 17 insertions, 10 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index 74b90935a488..ef8c7075e122 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= pokerth
-PORTVERSION= 1.0
-PORTREVISION= 3
+PORTVERSION= 1.0.1
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.0
DISTNAME= PokerTH-${PORTVERSION}-src
MAINTAINER= madpilot@FreeBSD.org
diff --git a/games/pokerth/distinfo b/games/pokerth/distinfo
index 4b522bcfed2c..321c8847dd4f 100644
--- a/games/pokerth/distinfo
+++ b/games/pokerth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PokerTH-1.0-src.tar.bz2) = 5aaaf913a7696f12afe18f9b2da55c84f7343bf8afb45b25f7852a25fd1a6c10
-SIZE (PokerTH-1.0-src.tar.bz2) = 19125507
+SHA256 (PokerTH-1.0.1-src.tar.bz2) = 29c359028a27fad0d30e11a9295e610593d23e34bffdb71de488f63f459e3d5d
+SIZE (PokerTH-1.0.1-src.tar.bz2) = 19201790
diff --git a/games/pokerth/files/patch-src_net_common_ircthread.cpp b/games/pokerth/files/patch-src_net_common_ircthread.cpp
index c4a6a890820b..98b680005f13 100644
--- a/games/pokerth/files/patch-src_net_common_ircthread.cpp
+++ b/games/pokerth/files/patch-src_net_common_ircthread.cpp
@@ -1,12 +1,20 @@
---- src/net/common/ircthread.cpp.orig 2012-02-11 17:57:34.000000000 +0100
-+++ src/net/common/ircthread.cpp 2012-03-07 11:03:40.501681051 +0100
-@@ -19,7 +19,8 @@
+--- src/net/common/ircthread.cpp.orig 2013-04-07 14:04:27.006209000 +0200
++++ src/net/common/ircthread.cpp 2013-04-21 11:26:39.764765351 +0200
+@@ -32,14 +32,15 @@
#include <net/socket_helper.h>
#include <net/ircthread.h>
#include <net/socket_msg.h>
-#include <libircclient/libircclient.h>
+#include <libircclient.h>
+#include <libirc_rfcnumeric.h>
+
+ // We need to do the following to handle different versions of libircclient.
+ // Sadly, libircclient doesn't have actual definitions for its versions in its headers.
+ // However, we can use a definition that appeared in the same version we need
+ // to check for. Hacky, but hey, it works.
+ #ifdef LIBIRC_OPTION_SSL_NO_VERIFY
+-#include <libircclient/libirc_rfcnumeric.h>
++#include <libirc_rfcnumeric.h>
+ #endif
+
#include <boost/algorithm/string/predicate.hpp>
- #include <queue>
- #include <sstream>