aboutsummaryrefslogtreecommitdiff
path: root/games/pokerth
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 10:47:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 10:47:17 +0000
commitf5ea0501c5e321176a316ef456bce5862d9e5389 (patch)
treec0642f0ff45a5d10ffa00c749f813dfaf5524171 /games/pokerth
parent76283fd6bb9d4356069a84d7ae6ff1ba56c9cbea (diff)
downloadports-f5ea0501c5e321176a316ef456bce5862d9e5389.tar.gz
ports-f5ea0501c5e321176a316ef456bce5862d9e5389.zip
Notes
Diffstat (limited to 'games/pokerth')
-rw-r--r--games/pokerth/Makefile30
-rw-r--r--games/pokerth/distinfo6
-rw-r--r--games/pokerth/files/patch-src-core-linux-convhelper.cpp20
3 files changed, 43 insertions, 13 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index a72d76275652..47e4fd4e84c8 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= pokerth
-PORTVERSION= 0.5
-PORTREVISION= 1
+PORTVERSION= 0.6
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= PokerTH-${PORTVERSION}-src
+MASTER_SITES= SF
+DISTNAME= PokerTH-${PORTVERSION}-1.src
MAINTAINER= relaxbsd@gmail.com
COMMENT= A poker game written in C++/QT4
@@ -21,6 +19,7 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
MANUAL_PACKAGE_BUILD= requires large memory to build
+USE_ICONV= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_QT_VER= 4
@@ -29,10 +28,14 @@ USE_SDL= mixer
WRKSRC= ${WRKDIR}/PokerTH-${PORTVERSION}
-PLIST_FILES= bin/pokerth share/pixmaps/pokerth.png
+PLIST_FILES= bin/pokerth %%DATADIR%%/pokerth share/pixmaps/pokerth.png
PORTDOCS= COPYING ChangeLog INSTALL TODO
+PORTDATA= data
+
+MAN1= pokerth.1
+
DESKTOP_ENTRIES= "PokerTH" \
"A poker game written in C++/Qt 4" \
"pokerth.png" \
@@ -43,16 +46,23 @@ DESKTOP_ENTRIES= "PokerTH" \
MAKE_ENV+= QTDIR="${QT_PREFIX}"
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/|${PREFIX}|g' \
- -e 's|boost_thread-mt|boost_thread|g' \
- ${WRKSRC}/pokerth.pro
+ @${REINPLACE_CMD} -E \
+ -e 's|/usr/([a-z|/]+)|${LOCALBASE}/\1|g' \
+ -e 's|(-lcrypto)|\1 -liconv|g' \
+ -e 's:boost_([a-z]+)-[-|a-z|0-9|_]*:boost_\1:g' \
+ ${WRKSRC}/*.pro
do-configure:
@cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -unix pokerth.pro
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/pokerth ${PREFIX}/bin/pokerth
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/pokerth ${DATADIR}/pokerth
+ @${CP} -R ${WRKSRC}/${PORTDATA} ${DATADIR}
+ @${ECHO_CMD} "exec ${DATADIR}/pokerth" > ${WRKSRC}/pokerth.sh
+ @${INSTALL_SCRIPT} ${WRKSRC}/pokerth.sh ${PREFIX}/bin/pokerth
@${INSTALL_DATA} ${WRKSRC}/pokerth.png ${PREFIX}/share/pixmaps/pokerth.png
+ @${INSTALL_MAN} ${WRKSRC}/docs/${MAN1} ${MANPREFIX}/man/man1/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
diff --git a/games/pokerth/distinfo b/games/pokerth/distinfo
index cbe31624a55e..ab3b9f7f93e5 100644
--- a/games/pokerth/distinfo
+++ b/games/pokerth/distinfo
@@ -1,3 +1,3 @@
-MD5 (PokerTH-0.5-src.tar.bz2) = 1009e927b5d26b4eeb89d00cd4b624f7
-SHA256 (PokerTH-0.5-src.tar.bz2) = a521aa9f4e47741c132ce5023b07e594ee267d1b3d99fa9b5e0d78b39502239d
-SIZE (PokerTH-0.5-src.tar.bz2) = 4123606
+MD5 (PokerTH-0.6-1.src.tar.bz2) = a30a19487319a61e033dd7be94b29e7d
+SHA256 (PokerTH-0.6-1.src.tar.bz2) = e2f8f84887d59de507425ad9e98c43d9e3f0f60c255e111b35cdeb9845a39086
+SIZE (PokerTH-0.6-1.src.tar.bz2) = 4276017
diff --git a/games/pokerth/files/patch-src-core-linux-convhelper.cpp b/games/pokerth/files/patch-src-core-linux-convhelper.cpp
new file mode 100644
index 000000000000..d5e9c574809d
--- /dev/null
+++ b/games/pokerth/files/patch-src-core-linux-convhelper.cpp
@@ -0,0 +1,20 @@
+--- src/core/linux/convhelper.cpp.orig 2008-01-20 13:32:07.000000000 +0100
++++ src/core/linux/convhelper.cpp 2008-01-20 12:56:03.000000000 +0100
+@@ -39,7 +39,7 @@
+ #ifdef __APPLE__
+ const char *inbuf = inStr.data();
+ #else
+- char *inbuf = const_cast<char *>(inStr.data());
++ const char *inbuf = const_cast<char *>(inStr.data());
+ #endif
+
+ const size_t c_outsize = insize * 6; // max size of utf-8 char is 6 per input char
+@@ -74,7 +74,7 @@
+ #ifdef __APPLE__
+ const char *inbuf = inStr.data();
+ #else
+- char *inbuf = const_cast<char *>(inStr.data());
++ const char *inbuf = const_cast<char *>(inStr.data());
+ #endif
+
+ const size_t c_outsize = insize;