aboutsummaryrefslogtreecommitdiff
path: root/games/pokerth
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-07 12:16:53 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-07 12:16:53 +0000
commit223129e3444e996dcb3dfb9409398b4ac38924bb (patch)
treebb4d68684c01db5cfd444359adffa02a3737b40a /games/pokerth
parente440194dc3665ac0ef3ab9f46da985dd3349b5ca (diff)
downloadports-223129e3444e996dcb3dfb9409398b4ac38924bb.tar.gz
ports-223129e3444e996dcb3dfb9409398b4ac38924bb.zip
Notes
Diffstat (limited to 'games/pokerth')
-rw-r--r--games/pokerth/Makefile62
-rw-r--r--games/pokerth/distinfo3
-rw-r--r--games/pokerth/pkg-descr5
3 files changed, 70 insertions, 0 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
new file mode 100644
index 000000000000..0906fb16dcd3
--- /dev/null
+++ b/games/pokerth/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: pokerth
+# Date created: 24 Jun 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pokerth
+PORTVERSION= 0.5
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= PokerTH-${PORTVERSION}-src
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A poker game written in C++/QT4
+
+LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost \
+ mikmod.2:${PORTSDIR}/audio/libmikmod
+
+MANUAL_PACKAGE_BUILD= requires large memory to build
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui corelib qmake moc rcc uic
+USE_SDL= mixer
+
+WRKSRC= ${WRKDIR}/PokerTH-${PORTVERSION}
+
+PLIST_FILES= bin/pokerth share/pixmaps/pokerth.png
+
+PORTDOCS= COPYING ChangeLog INSTALL TODO
+
+DESKTOP_ENTRIES= "PokerTH" \
+ "A poker game written in C++/Qt 4" \
+ "pokerth.png" \
+ "pokerth" \
+ "Application;Game;CardGame;" \
+ "false"
+
+MAKE_ENV+= QTDIR="${QT_PREFIX}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/|${PREFIX}|g' \
+ -e 's|boost_thread-mt|boost_thread|g' \
+ ${WRKSRC}/pokerth.pro
+
+do-configure:
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -unix pokerth.pro
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/pokerth ${PREFIX}/bin/pokerth
+ @${INSTALL_DATA} ${WRKSRC}/pokerth.png ${PREFIX}/share/pixmaps/pokerth.png
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/pokerth/distinfo b/games/pokerth/distinfo
new file mode 100644
index 000000000000..cbe31624a55e
--- /dev/null
+++ b/games/pokerth/distinfo
@@ -0,0 +1,3 @@
+MD5 (PokerTH-0.5-src.tar.bz2) = 1009e927b5d26b4eeb89d00cd4b624f7
+SHA256 (PokerTH-0.5-src.tar.bz2) = a521aa9f4e47741c132ce5023b07e594ee267d1b3d99fa9b5e0d78b39502239d
+SIZE (PokerTH-0.5-src.tar.bz2) = 4123606
diff --git a/games/pokerth/pkg-descr b/games/pokerth/pkg-descr
new file mode 100644
index 000000000000..afa7997bb3ef
--- /dev/null
+++ b/games/pokerth/pkg-descr
@@ -0,0 +1,5 @@
+PokerTH is a poker game written in C++/QT4. You can play the popular
+"Texas Hold'em" poker variant against up to six computer-opponents
+or play network games with people all over the world.
+
+WWW: http://www.pokerth.net/