aboutsummaryrefslogtreecommitdiff
path: root/games/powder
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2010-01-30 09:43:31 +0000
committerMarcus von Appen <mva@FreeBSD.org>2010-01-30 09:43:31 +0000
commit6506e45d69278ab9aa0c11e218c71ca3e07664ec (patch)
tree05146fe73a348007077e1538540aa966348106d1 /games/powder
parent22e04ee7f9d92da1264361c15d77ce7418fb374a (diff)
- Update devel/sdl12 to version 1.2.14.
- Update audio/sdl_mixer to version 1.2.11. - Update graphics/sdl_gfx to version 2.0.20. - Update graphics/sdl_image to version 1.2.10. - Bump portrevisions for all ports depending on audio/sdl_mixer and graphics/sdl_image. - Update Mk/bsd.sdl.mk accordingly for the new shared lib versions. PR: ports/142147 ports/142248 ports/142249 Approved by: miwi (mentor implicit)
Notes
Notes: svn path=/head/; revision=248835
Diffstat (limited to 'games/powder')
-rw-r--r--games/powder/Makefile1
-rw-r--r--games/powder/files/patch-port-linux-linuxmain.cpp9
2 files changed, 6 insertions, 4 deletions
diff --git a/games/powder/Makefile b/games/powder/Makefile
index 38f9c0460b25..9a057ca3378d 100644
--- a/games/powder/Makefile
+++ b/games/powder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= powder
PORTVERSION= 112
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.zincland.com/powder/release/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/games/powder/files/patch-port-linux-linuxmain.cpp b/games/powder/files/patch-port-linux-linuxmain.cpp
index 897faae5d86f..0ba703236eb7 100644
--- a/games/powder/files/patch-port-linux-linuxmain.cpp
+++ b/games/powder/files/patch-port-linux-linuxmain.cpp
@@ -1,7 +1,8 @@
---- port/linux/linuxmain.cpp.orig 2008-01-10 06:26:42.000000000 +0300
-+++ port/linux/linuxmain.cpp 2009-06-08 00:37:41.000000000 +0400
-@@ -1,4 +1,8 @@
+--- port/linux/linuxmain.cpp.orig 2008-01-10 04:26:42.000000000 +0100
++++ port/linux/linuxmain.cpp 2010-01-28 00:08:58.000000000 +0100
+@@ -1,4 +1,9 @@
#include <SDL.h>
++#include <errno.h>
+#include <err.h>
+#include <stdlib.h>
+#include <sys/stat.h>
@@ -9,7 +10,7 @@
#ifdef main
#undef main
-@@ -11,6 +15,15 @@
+@@ -11,6 +16,15 @@
int main(int argc, char **argv)
{