aboutsummaryrefslogtreecommitdiff
path: root/games/powermanga/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-26 13:23:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-26 13:23:30 +0000
commit7d480c1b006124aa558db96001d57d367e33e5d6 (patch)
treee2b085ac13d262426f731ea9c756d9e7f15baf24 /games/powermanga/Makefile
parent0fdce07768510feff95750f45f3f3cfe4b90ec86 (diff)
downloadports-7d480c1b006124aa558db96001d57d367e33e5d6.tar.gz
ports-7d480c1b006124aa558db96001d57d367e33e5d6.zip
Notes
Diffstat (limited to 'games/powermanga/Makefile')
-rw-r--r--games/powermanga/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/powermanga/Makefile b/games/powermanga/Makefile
new file mode 100644
index 000000000000..3b3b7c59130e
--- /dev/null
+++ b/games/powermanga/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: powermanga
+# Date created: 26 Jan 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= powermanga
+PORTVERSION= 0.78
+CATEGORIES= games
+MASTER_SITES= http://www.tlk.fr/lesjeux/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= An arcade 2D shoot-em-up
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_X_PREFIX= yes
+USE_SDL= sdl mixer
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN6= powermanga.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/powermanga.6
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} \
+ ${WRKSRC}/AUTHORS \
+ ${WRKSRC}/CHANGES \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>