aboutsummaryrefslogtreecommitdiff
path: root/games/powermanga
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 00:43:17 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-28 00:43:17 +0000
commitc0d0be9781199f3abc3e0573d82d9356cb74f041 (patch)
treea95ba077f620cf75f135c26cfae05e2d9ce29a29 /games/powermanga
parent38cae62a739f416036f6a7799d3afc477d98fae0 (diff)
downloadports-c0d0be9781199f3abc3e0573d82d9356cb74f041.tar.gz
ports-c0d0be9781199f3abc3e0573d82d9356cb74f041.zip
Notes
Diffstat (limited to 'games/powermanga')
-rw-r--r--games/powermanga/Makefile22
-rw-r--r--games/powermanga/files/patch-configure.ac15
-rw-r--r--games/powermanga/pkg-plist408
3 files changed, 21 insertions, 424 deletions
diff --git a/games/powermanga/Makefile b/games/powermanga/Makefile
index 93ad76970d30..ee94e6e91230 100644
--- a/games/powermanga/Makefile
+++ b/games/powermanga/Makefile
@@ -14,21 +14,19 @@ COMMENT= An arcade 2D shoot-em-up
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USE_XORG= xext xxf86dga
USE_SDL= sdl mixer
GNU_CONFIGURE= yes
USE_AUTOTOOLS= aclocal automake autoconf autoheader
-PORTDOCS= AUTHORS CHANGES
-
-MAN6= powermanga.6
+PORTDOCS= *
+PORTDATA= *
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -48,14 +46,10 @@ run-autotools:
cd ${WRKSRC} && ${SH} ./bootstrap
post-install:
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/powermanga.desktop ${PREFIX}/share/applications/
- ${INSTALL_DATA} ${WRKSRC}/powermanga.xpm ${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/powermanga.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/powermanga.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/powermanga/files/patch-configure.ac b/games/powermanga/files/patch-configure.ac
index e1564145d17a..44494d40bcdc 100644
--- a/games/powermanga/files/patch-configure.ac
+++ b/games/powermanga/files/patch-configure.ac
@@ -1,14 +1,23 @@
--- configure.ac.orig 2012-08-26 19:44:25.000000000 +0400
-+++ configure.ac 2013-08-23 23:16:37.792851553 +0400
++++ configure.ac 2013-09-28 03:45:02.570519016 +0400
@@ -52,9 +52,9 @@
dnl If defined [Ctrl] + [V], [Ctrl] + [P], [Ctrl] + [B] are available
AC_DEFINE(UNDER_DEVELOPMENT, 1, Define to enable development version)
AC_DEFINE(USE_MALLOC_WRAPPER, 1, Define to use a malloc wrapper)
- CFLAGS="-Wall -Werror -pedantic -Wextra -std=gnu99 -g"
-+ CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wextra -std=gnu99 -g"
++ CFLAGS="$CFLAGS -Wall -pedantic -Wextra -std=gnu99 -g"
else
- CFLAGS="-O3 -Werror -Wall -pedantic -Wextra -std=gnu99"
-+ CFLAGS="$CFLAGS -O3 -Werror -Wall -pedantic -Wextra -std=gnu99"
++ CFLAGS="$CFLAGS -Wall -pedantic -Wextra -std=gnu99"
fi
dnl Check for SDL_mixer
+@@ -97,7 +97,7 @@
+ i*86) ac_cv_need_asm=yes ;;
+ *) ac_cv_need_asm=no ;;
+ esac
+-#ac_cv_need_asm=no
++ac_cv_need_asm=no
+ AC_MSG_RESULT(${ac_cv_need_asm})
+ AM_CONDITIONAL(ASSEMBLY, test "${ac_cv_need_asm}" = "yes")
+
diff --git a/games/powermanga/pkg-plist b/games/powermanga/pkg-plist
index 0a665dbb69dd..d3359a1be9e8 100644
--- a/games/powermanga/pkg-plist
+++ b/games/powermanga/pkg-plist
@@ -1,411 +1,5 @@
bin/powermanga
+man/man6/powermanga.6.gz
share/applications/powermanga.desktop
share/pixmaps/powermanga.xpm
-%%DATADIR%%/data/curves/bezier_curve_000.bin
-%%DATADIR%%/data/curves/bezier_curve_001.bin
-%%DATADIR%%/data/curves/bezier_curve_002.bin
-%%DATADIR%%/data/curves/bezier_curve_003.bin
-%%DATADIR%%/data/curves/bezier_curve_004.bin
-%%DATADIR%%/data/curves/bezier_curve_005.bin
-%%DATADIR%%/data/curves/bezier_curve_006.bin
-%%DATADIR%%/data/curves/bezier_curve_007.bin
-%%DATADIR%%/data/curves/bezier_curve_008.bin
-%%DATADIR%%/data/curves/bezier_curve_009.bin
-%%DATADIR%%/data/curves/bezier_curve_010.bin
-%%DATADIR%%/data/curves/bezier_curve_011.bin
-%%DATADIR%%/data/curves/bezier_curve_012.bin
-%%DATADIR%%/data/curves/bezier_curve_013.bin
-%%DATADIR%%/data/curves/bezier_curve_014.bin
-%%DATADIR%%/data/curves/bezier_curve_015.bin
-%%DATADIR%%/data/curves/bezier_curve_016.bin
-%%DATADIR%%/data/curves/bezier_curve_017.bin
-%%DATADIR%%/data/curves/bezier_curve_018.bin
-%%DATADIR%%/data/curves/bezier_curve_019.bin
-%%DATADIR%%/data/curves/bezier_curve_020.bin
-%%DATADIR%%/data/curves/bezier_curve_021.bin
-%%DATADIR%%/data/curves/bezier_curve_022.bin
-%%DATADIR%%/data/curves/bezier_curve_023.bin
-%%DATADIR%%/data/curves/bezier_curve_024.bin
-%%DATADIR%%/data/curves/bezier_curve_025.bin
-%%DATADIR%%/data/curves/bezier_curve_026.bin
-%%DATADIR%%/data/curves/bezier_curve_027.bin
-%%DATADIR%%/data/curves/bezier_curve_028.bin
-%%DATADIR%%/data/curves/bezier_curve_029.bin
-%%DATADIR%%/data/curves/bezier_curve_030.bin
-%%DATADIR%%/data/curves/bezier_curve_031.bin
-%%DATADIR%%/data/curves/bezier_curve_032.bin
-%%DATADIR%%/data/curves/bezier_curve_033.bin
-%%DATADIR%%/data/curves/bezier_curve_034.bin
-%%DATADIR%%/data/curves/bezier_curve_035.bin
-%%DATADIR%%/data/curves/bezier_curve_036.bin
-%%DATADIR%%/data/curves/bezier_curve_037.bin
-%%DATADIR%%/data/curves/bezier_curve_038.bin
-%%DATADIR%%/data/curves/bezier_curve_039.bin
-%%DATADIR%%/data/curves/bezier_curve_040.bin
-%%DATADIR%%/data/curves/bezier_curve_041.bin
-%%DATADIR%%/data/curves/bezier_curve_042.bin
-%%DATADIR%%/data/curves/bezier_curve_043.bin
-%%DATADIR%%/data/curves/bezier_curve_044.bin
-%%DATADIR%%/data/curves/bezier_curve_045.bin
-%%DATADIR%%/data/curves/bezier_curve_046.bin
-%%DATADIR%%/data/curves/bezier_curve_047.bin
-%%DATADIR%%/data/curves/bezier_curve_048.bin
-%%DATADIR%%/data/curves/bezier_curve_049.bin
-%%DATADIR%%/data/curves/bezier_curve_050.bin
-%%DATADIR%%/data/curves/bezier_curve_051.bin
-%%DATADIR%%/data/curves/bezier_curve_052.bin
-%%DATADIR%%/data/curves/bezier_curve_053.bin
-%%DATADIR%%/data/curves/bezier_curve_054.bin
-%%DATADIR%%/data/curves/bezier_curve_055.bin
-%%DATADIR%%/data/curves/bezier_curve_056.bin
-%%DATADIR%%/data/curves/bezier_curve_057.bin
-%%DATADIR%%/data/curves/bezier_curve_058.bin
-%%DATADIR%%/data/curves/bezier_curve_059.bin
-%%DATADIR%%/data/curves/bezier_curve_060.bin
-%%DATADIR%%/data/curves/bezier_curve_061.bin
-%%DATADIR%%/data/curves/bezier_curve_062.bin
-%%DATADIR%%/data/curves/bezier_curve_063.bin
-%%DATADIR%%/data/curves/bezier_curve_064.bin
-%%DATADIR%%/data/curves/bezier_curve_065.bin
-%%DATADIR%%/data/curves/bezier_curve_066.bin
-%%DATADIR%%/data/curves/bezier_curve_067.bin
-%%DATADIR%%/data/curves/bezier_curve_068.bin
-%%DATADIR%%/data/curves/bezier_curve_069.bin
-%%DATADIR%%/data/curves/bezier_curve_070.bin
-%%DATADIR%%/data/curves/bezier_curve_071.bin
-%%DATADIR%%/data/curves/bezier_curve_072.bin
-%%DATADIR%%/data/curves/bezier_curve_073.bin
-%%DATADIR%%/data/curves/bezier_curve_074.bin
-%%DATADIR%%/data/curves/bezier_curve_075.bin
-%%DATADIR%%/data/curves/bezier_curve_076.bin
-%%DATADIR%%/data/curves/bezier_curve_077.bin
-%%DATADIR%%/data/curves/bezier_curve_078.bin
-%%DATADIR%%/data/curves/bezier_curve_079.bin
-%%DATADIR%%/data/curves/bezier_curve_080.bin
-%%DATADIR%%/data/curves/bezier_curve_081.bin
-%%DATADIR%%/data/curves/bezier_curve_082.bin
-%%DATADIR%%/data/curves/bezier_curve_083.bin
-%%DATADIR%%/data/curves/bezier_curve_084.bin
-%%DATADIR%%/data/curves/bezier_curve_085.bin
-%%DATADIR%%/data/curves/bezier_curve_086.bin
-%%DATADIR%%/data/curves/bezier_curve_087.bin
-%%DATADIR%%/data/curves/bezier_curve_088.bin
-%%DATADIR%%/data/curves/bezier_curve_089.bin
-%%DATADIR%%/data/curves/bezier_curve_090.bin
-%%DATADIR%%/data/curves/bezier_curve_091.bin
-%%DATADIR%%/data/curves/bezier_curve_092.bin
-%%DATADIR%%/data/curves/bezier_curve_093.bin
-%%DATADIR%%/data/curves/bezier_curve_094.bin
-%%DATADIR%%/data/curves/bezier_curve_095.bin
-%%DATADIR%%/data/curves/bezier_curve_096.bin
-%%DATADIR%%/data/curves/bezier_curve_097.bin
-%%DATADIR%%/data/curves/bezier_curve_098.bin
-%%DATADIR%%/data/curves/bezier_curve_099.bin
-%%DATADIR%%/data/curves/bezier_curve_100.bin
-%%DATADIR%%/data/curves/bezier_curve_101.bin
-%%DATADIR%%/data/curves/bezier_curve_102.bin
-%%DATADIR%%/data/curves/bezier_curve_103.bin
-%%DATADIR%%/data/curves/bezier_curve_104.bin
-%%DATADIR%%/data/curves/bezier_curve_105.bin
-%%DATADIR%%/data/curves/bezier_curve_106.bin
-%%DATADIR%%/data/curves/bezier_curve_107.bin
-%%DATADIR%%/data/curves/bezier_curve_108.bin
-%%DATADIR%%/data/curves/bezier_curve_109.bin
-%%DATADIR%%/data/curves/bezier_curve_110.bin
-%%DATADIR%%/data/curves/bezier_curve_111.bin
-%%DATADIR%%/data/curves/bezier_curve_112.bin
-%%DATADIR%%/data/curves/bezier_curve_113.bin
-%%DATADIR%%/data/curves/bezier_curve_114.bin
-%%DATADIR%%/data/curves/bezier_curve_115.bin
-%%DATADIR%%/data/curves/bezier_curve_116.bin
-%%DATADIR%%/data/curves/bezier_curve_117.bin
-%%DATADIR%%/data/curves/bezier_curve_118.bin
-%%DATADIR%%/data/curves/bezier_curve_119.bin
-%%DATADIR%%/data/curves/bezier_curve_120.bin
-%%DATADIR%%/data/curves/bezier_curve_121.bin
-%%DATADIR%%/data/levels/curves_phase/curves_00.bin
-%%DATADIR%%/data/levels/curves_phase/curves_01.bin
-%%DATADIR%%/data/levels/curves_phase/curves_02.bin
-%%DATADIR%%/data/levels/curves_phase/curves_03.bin
-%%DATADIR%%/data/levels/curves_phase/curves_04.bin
-%%DATADIR%%/data/levels/curves_phase/curves_05.bin
-%%DATADIR%%/data/levels/curves_phase/curves_06.bin
-%%DATADIR%%/data/levels/curves_phase/curves_07.bin
-%%DATADIR%%/data/levels/curves_phase/curves_08.bin
-%%DATADIR%%/data/levels/curves_phase/curves_09.bin
-%%DATADIR%%/data/levels/curves_phase/curves_10.bin
-%%DATADIR%%/data/levels/curves_phase/curves_11.bin
-%%DATADIR%%/data/levels/curves_phase/curves_12.bin
-%%DATADIR%%/data/levels/curves_phase/curves_13.bin
-%%DATADIR%%/data/levels/curves_phase/curves_14.bin
-%%DATADIR%%/data/levels/curves_phase/curves_15.bin
-%%DATADIR%%/data/levels/curves_phase/curves_16.bin
-%%DATADIR%%/data/levels/curves_phase/curves_17.bin
-%%DATADIR%%/data/levels/curves_phase/curves_18.bin
-%%DATADIR%%/data/levels/curves_phase/curves_19.bin
-%%DATADIR%%/data/levels/curves_phase/curves_20.bin
-%%DATADIR%%/data/levels/curves_phase/curves_21.bin
-%%DATADIR%%/data/levels/curves_phase/curves_22.bin
-%%DATADIR%%/data/levels/curves_phase/curves_23.bin
-%%DATADIR%%/data/levels/curves_phase/curves_24.bin
-%%DATADIR%%/data/levels/curves_phase/curves_25.bin
-%%DATADIR%%/data/levels/curves_phase/curves_26.bin
-%%DATADIR%%/data/levels/curves_phase/curves_27.bin
-%%DATADIR%%/data/levels/curves_phase/curves_28.bin
-%%DATADIR%%/data/levels/curves_phase/curves_29.bin
-%%DATADIR%%/data/levels/curves_phase/curves_30.bin
-%%DATADIR%%/data/levels/curves_phase/curves_31.bin
-%%DATADIR%%/data/levels/curves_phase/curves_32.bin
-%%DATADIR%%/data/levels/curves_phase/curves_33.bin
-%%DATADIR%%/data/levels/curves_phase/curves_34.bin
-%%DATADIR%%/data/levels/curves_phase/curves_35.bin
-%%DATADIR%%/data/levels/curves_phase/curves_36.bin
-%%DATADIR%%/data/levels/curves_phase/curves_37.bin
-%%DATADIR%%/data/levels/curves_phase/curves_38.bin
-%%DATADIR%%/data/levels/curves_phase/curves_39.bin
-%%DATADIR%%/data/levels/curves_phase/curves_40.bin
-%%DATADIR%%/data/levels/curves_phase/curves_41.bin
-%%DATADIR%%/data/levels/grids_phase/grid_00.bin
-%%DATADIR%%/data/levels/grids_phase/grid_01.bin
-%%DATADIR%%/data/levels/grids_phase/grid_02.bin
-%%DATADIR%%/data/levels/grids_phase/grid_03.bin
-%%DATADIR%%/data/levels/grids_phase/grid_04.bin
-%%DATADIR%%/data/levels/grids_phase/grid_05.bin
-%%DATADIR%%/data/levels/grids_phase/grid_06.bin
-%%DATADIR%%/data/levels/grids_phase/grid_07.bin
-%%DATADIR%%/data/levels/grids_phase/grid_08.bin
-%%DATADIR%%/data/levels/grids_phase/grid_09.bin
-%%DATADIR%%/data/levels/grids_phase/grid_10.bin
-%%DATADIR%%/data/levels/grids_phase/grid_11.bin
-%%DATADIR%%/data/levels/grids_phase/grid_12.bin
-%%DATADIR%%/data/levels/grids_phase/grid_13.bin
-%%DATADIR%%/data/levels/grids_phase/grid_14.bin
-%%DATADIR%%/data/levels/grids_phase/grid_15.bin
-%%DATADIR%%/data/levels/grids_phase/grid_16.bin
-%%DATADIR%%/data/levels/grids_phase/grid_17.bin
-%%DATADIR%%/data/levels/grids_phase/grid_18.bin
-%%DATADIR%%/data/levels/grids_phase/grid_19.bin
-%%DATADIR%%/data/levels/grids_phase/grid_20.bin
-%%DATADIR%%/data/levels/grids_phase/grid_21.bin
-%%DATADIR%%/data/levels/grids_phase/grid_22.bin
-%%DATADIR%%/data/levels/grids_phase/grid_23.bin
-%%DATADIR%%/data/levels/grids_phase/grid_24.bin
-%%DATADIR%%/data/levels/grids_phase/grid_25.bin
-%%DATADIR%%/data/levels/grids_phase/grid_26.bin
-%%DATADIR%%/data/levels/grids_phase/grid_27.bin
-%%DATADIR%%/data/levels/grids_phase/grid_28.bin
-%%DATADIR%%/data/levels/grids_phase/grid_29.bin
-%%DATADIR%%/data/levels/grids_phase/grid_30.bin
-%%DATADIR%%/data/levels/grids_phase/grid_31.bin
-%%DATADIR%%/data/levels/grids_phase/grid_32.bin
-%%DATADIR%%/data/levels/grids_phase/grid_33.bin
-%%DATADIR%%/data/levels/grids_phase/grid_34.bin
-%%DATADIR%%/data/levels/grids_phase/grid_35.bin
-%%DATADIR%%/data/levels/grids_phase/grid_36.bin
-%%DATADIR%%/data/levels/grids_phase/grid_37.bin
-%%DATADIR%%/data/levels/grids_phase/grid_38.bin
-%%DATADIR%%/data/levels/grids_phase/grid_39.bin
-%%DATADIR%%/data/levels/grids_phase/grid_40.bin
-%%DATADIR%%/data/levels/grids_phase/grid_41.bin
-%%DATADIR%%/data/levels/grids_phase/grid_50.bin
-%%DATADIR%%/data/menu_order_keystrokes.bin
-%%DATADIR%%/graphics/256_colors_palette.bin
-%%DATADIR%%/graphics/bitmap/fonts/font_big.spr
-%%DATADIR%%/graphics/bitmap/fonts/font_game.spr
-%%DATADIR%%/graphics/bitmap/fonts/font_score.spr
-%%DATADIR%%/graphics/bitmap/fonts/font_scrolltext.spr
-%%DATADIR%%/graphics/bitmap/main_menu.spr
-%%DATADIR%%/graphics/bitmap/options_panel_anims.spr
-%%DATADIR%%/graphics/bitmap/scores_multiplier.spr
-%%DATADIR%%/graphics/bitmap/tlk_games_logo.spr
-%%DATADIR%%/graphics/font_overlay.pcx
-%%DATADIR%%/graphics/movie_congratulation.gca
-%%DATADIR%%/graphics/movie_introduction.gca
-%%DATADIR%%/graphics/right_options_panel.pcx
-%%DATADIR%%/graphics/sprite.spr
-%%DATADIR%%/graphics/sprites/all_enemies.spr
-%%DATADIR%%/graphics/sprites/all_shots.spr
-%%DATADIR%%/graphics/sprites/bonus_gems.spr
-%%DATADIR%%/graphics/sprites/energy_gauge_blue.spr
-%%DATADIR%%/graphics/sprites/energy_gauge_green.spr
-%%DATADIR%%/graphics/sprites/energy_gauge_red.spr
-%%DATADIR%%/graphics/sprites/explosion_fragments.spr
-%%DATADIR%%/graphics/sprites/explosions.spr
-%%DATADIR%%/graphics/sprites/extra_guns.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_00.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_01.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_02.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_03.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_04.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_05.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_06.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_07.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_08.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_09.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_10.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_11.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_12.spr
-%%DATADIR%%/graphics/sprites/guardians/guardian_13.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_00.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_01.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_02.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_03.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_04.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_05.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_06.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_07.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_08.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_09.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_10.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_11.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_12.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_13.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_14.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_15.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_16.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_17.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_18.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_19.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_20.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_21.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_22.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_23.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_24.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_25.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_26.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_27.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_28.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_29.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_30.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_31.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_32.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_33.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_34.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_35.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_36.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_37.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_38.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_39.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_40.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_41.spr
-%%DATADIR%%/graphics/sprites/meteors/meteor_42.spr
-%%DATADIR%%/graphics/sprites/satellite_protections.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_1_frame_0.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_1_frame_1.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_1_frame_2.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_1_frame_3.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_1_frame_4.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_2_frame_0.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_2_frame_1.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_2_frame_2.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_2_frame_3.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_2_frame_4.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_3_frame_0.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_3_frame_1.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_3_frame_2.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_3_frame_3.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_3_frame_4.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_4_frame_0.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_4_frame_1.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_4_frame_2.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_4_frame_3.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_4_frame_4.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_5_frame_0.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_5_frame_1.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_5_frame_2.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_5_frame_3.spr
-%%DATADIR%%/graphics/sprites/spaceships/spaceship_5_frame_4.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_0.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_1.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_2.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_3.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_4.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_5.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_6.spr
-%%DATADIR%%/graphics/sprites/stars/star_big_7.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_0.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_1.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_2.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_3.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_4.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_5.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_6.spr
-%%DATADIR%%/graphics/sprites/stars/star_little_7.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_0.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_1.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_2.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_3.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_4.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_5.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_6.spr
-%%DATADIR%%/graphics/sprites/stars/star_middle_7.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_0.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_1.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_2.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_3.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_4.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_5.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_6.spr
-%%DATADIR%%/graphics/sprites/stars/star_spaceship_7.spr
-%%DATADIR%%/graphics/top_scores_panel.pcx
-%%DATADIR%%/sound/handheld_console/music_congratulations.ogg
-%%DATADIR%%/sound/handheld_console/music_game.ogg
-%%DATADIR%%/sound/handheld_console/music_menu.ogg
-%%DATADIR%%/sounds/music_congratulations.zik
-%%DATADIR%%/sounds/music_game.zik
-%%DATADIR%%/sounds/music_menu.zik
-%%DATADIR%%/sounds/sound_big_explosion_1.wav
-%%DATADIR%%/sounds/sound_big_explosion_2.wav
-%%DATADIR%%/sounds/sound_big_explosion_3.wav
-%%DATADIR%%/sounds/sound_big_explosion_4.wav
-%%DATADIR%%/sounds/sound_circular_shock.wav
-%%DATADIR%%/sounds/sound_downgrade_spaceship.wav
-%%DATADIR%%/sounds/sound_enemy_fire_1.wav
-%%DATADIR%%/sounds/sound_enemy_fire_2.wav
-%%DATADIR%%/sounds/sound_green_gem.wav
-%%DATADIR%%/sounds/sound_guardian_fire_1.wav
-%%DATADIR%%/sounds/sound_guardian_fire_2.wav
-%%DATADIR%%/sounds/sound_guardian_fire_3.wav
-%%DATADIR%%/sounds/sound_lonely_foe.wav
-%%DATADIR%%/sounds/sound_medium_explosion_1.wav
-%%DATADIR%%/sounds/sound_medium_explosion_2.wav
-%%DATADIR%%/sounds/sound_medium_explosion_3.wav
-%%DATADIR%%/sounds/sound_medium_explosion_4.wav
-%%DATADIR%%/sounds/sound_purple_gem.wav
-%%DATADIR%%/sounds/sound_red_gem.wav
-%%DATADIR%%/sounds/sound_select_closed_option.wav
-%%DATADIR%%/sounds/sound_select_option.wav
-%%DATADIR%%/sounds/sound_small_explosion_1.wav
-%%DATADIR%%/sounds/sound_small_explosion_2.wav
-%%DATADIR%%/sounds/sound_small_explosion_3.wav
-%%DATADIR%%/sounds/sound_small_explosion_4.wav
-%%DATADIR%%/sounds/sound_spaceship_fire.wav
-%%DATADIR%%/sounds/sound_upgrade_spaceship.wav
-%%DATADIR%%/sounds/sound_yellow_gem.wav
-%%DATADIR%%/texts/about_en.txt
-%%DATADIR%%/texts/about_fr.txt
-%%DATADIR%%/texts/order_en.txt
-%%DATADIR%%/texts/order_fr.txt
-%%DATADIR%%/texts/scroll_en.txt
-%%DATADIR%%/texts/scroll_fr.txt
-%%DATADIR%%/texts/text_en.txt
-%%DATADIR%%/texts/text_fr.txt
-@dirrm %%DATADIR%%/texts
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/sound/handheld_console
-@dirrm %%DATADIR%%/sound
-@dirrm %%DATADIR%%/graphics/sprites/stars
-@dirrm %%DATADIR%%/graphics/sprites/spaceships
-@dirrm %%DATADIR%%/graphics/sprites/meteors
-@dirrm %%DATADIR%%/graphics/sprites/guardians
-@dirrm %%DATADIR%%/graphics/sprites
-@dirrm %%DATADIR%%/graphics/bitmap/fonts
-@dirrm %%DATADIR%%/graphics/bitmap
-@dirrm %%DATADIR%%/graphics
-@dirrm %%DATADIR%%/data/levels/grids_phase
-@dirrm %%DATADIR%%/data/levels/curves_phase
-@dirrm %%DATADIR%%/data/levels
-@dirrm %%DATADIR%%/data/curves
-@dirrm %%DATADIR%%/data
-@dirrm %%DATADIR%%
@dirrmtry share/applications